Panasonic DEM-ES40V dvd player

I have a Panasonic DMR-ES40V. Just recently, it has decided that it won’t play back commercially recorded DVDs. I get a message that says it is not in my region! It has always played perfectly well in the past. I have tried a number of DVDs that played ok before and I get the same message. help!
Flaco :sad:

Welcome to the forum :slight_smile:

Commercial (or pressed as are commonly called) DVDs have a regional protection scheme that allows a drive to play only discs of the same region of the drive itself.

If you have a region 2 drive, you can play only region 2 discs. Probably you are trying to play discs from a different region. Check on the box: disc region is always shown somewhere in the label :slight_smile:

I understand that. My problem is that I am in the American region, and these disks have always played before. It’s not like I am suddenly trying to play French disks in my machine. Is there some way to get inside the darn thing and check the settings?

If you have changed the region 5 times, your drive is locked. Forever, sorry.

I have never changed the region.