Os doesnt recognize my cd/dvd burner & cannot install firmware

vbimport

#1

My Windows XP Professional x64 doesn’t recognize my CD/DVD burner (lite-on dvdrw shw-160p6s) I downloaded the latest firmware update from liteon and tried to install it but I got an error saying it cannot find a cd/dvd burner drive. Look below and single click on the image to enlarge it.

Edited: This is my first time problem with my dvd/cd burner, it had worked before on the same OS - WinXPProx64 (64bit) and WinXPProx86 (32bit/normal) in the past. I have checked inside my computer and found no damage. I also have unplugged off the IDE and reinserted it just to make sure. Any suggestion?


#2

Is it seen in BIOS and/or Device Manager? You may have a bad IDE ribbon or incorrectly jumpered if not. If it is seen in Device Manager, try uninstalling it, and then reboot which may have Windows correctly identify it.


#3

the liteon SHW-160P6S showed up on the bios so that probably means the problem lies in the WinXP Pro x64 OS itself. In the device manager, I have uninstalled it and used the scan for hardware change… it found the cd/dvd drive but with an error: “A problem occured during hardware installation. Your new hardware might not function properly.” (or something like that) so I checked the detail info… here it is: “Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19) Click Troubleshoot to start the troubleshooter for this device.” okay I clicked the troubleshoot buttion and came up with nothing.

Any suggestion? Should I get a new cd/dvd burner drive (probably sata one like this one Lite-On LH-20A1S SuperAllWrite) I already have some extra SATA connections that came with ASUS motherboard box.

Edited: I forgot to mention that I did found a good working ATA IDE cable… and replaced the old one with it… still got the same result.


#4

Hi and Welcome!

See if this helps: http://support.microsoft.com/kb/314060

Michael


#5

Did you try uninstalling the drive and reboot? The link in post #4 may help if you’re getting that error message but likely won’t if not getting that error.


#6

Try this Microsoft link as well http://support.microsoft.com/kb/883523/en-us


#7

Wow… you guys are awesome! After I removed the lowerfilter line from the registry editor and uninstall the cd/dvd rw burner under device manager and rebooted, it just started working again. Thanks guys again! :bigsmile: