OptoRite DVD +RW /-RW DD0401 Firmware problems!(help please)

I bought myself an OptoRite DVD RW Drive early this year runs fine but writes CD-R’s slower than my old CD RW so i thought why not upgrade firmware surely this is a good thing and after all will make my drive speed 8x for both formats according to the firmare upgrade information - http://www.optorite.com/_english/web/2_service/2_firmwares.php

After upgrading to firmware 150E my DVD RW Drive now thinks it is a CD Drive when i have blank media in the drive but when i take the media out it is a DVD RW once again leaving me unable to burn anything onto DVD, i have contacted OptoRite Technical support and they have been polite and helpful as well as replying several times but have not fixed this problem i have followed all of their suggestions so far and nothing fixes it i even asked them for the firmware that was originally shipped with the DVD RW Drive from the factory - installed that flashed it etc and it still doesn’t solve the problem. :confused: :confused:

Please help if you can any advice at all will be greatly appreciated from you and if you have been experiencing similar problems please reply also is there any unofficial firmware i can try to get it working just in case OptoRite technical support can’t fix it for me. :bow:

Thanks… :slight_smile:

Well i guess no one can help me then.

I may have to get a brand new one shipped out to me now… :iagree:

What burning software do you use? You know that Windows cannot burn DVD+R/RW or DVD-R/RW discs, right? How your drive is recognized by Windows (CD Drive or DVD RW) has no affect on the drive’s capabilities.

Getting a new drive shipped to you would be a waste of time, and updating the firmware won’t fix a non-existant problem.

The problem i have is VERY EXISTANT believe me why else would i be wasting my own time and OptoRite Technical Supports time, before i upgraded the firmare my DVD RW Drive functioned just fine, I use various burning software suits sometimes Nero, Roxio or Alcohol 120%

I am using Ritek Arita G04 DVD-R when the drive is empty it is a DVD RW in my computer but when I insert blank media it becomes a CD Drive.

http://ecoteq.xsmail.com Media Information

As I said, The name that Windows gives to the drive does not matter at all.

You may have too many softwares installed or you might want to try uninstalling anything under “IDE ATA/ATAPI controller” in Device Manager and restarting. You should also try more than just one type of disc if you have not.

I know I know… reinstalled XP twice already formatted HD etc done all of the uninstalling of the IDE drives both in safe mode and windows which makes no change then i uninstalled them from the IDE ATA/ATAPI controllers section in device manager but after i uninstalled them i was unable to get them installed again when i rebooted so i had to reboot into safe mode to do that.

I have done all of this so far

  1. Checked that DMA is enabled on my OptoRite drive.

  2. Upgraded chipset

  3. Gone into the Operating System “Safe Mode” and into the Device Manager. Removed all DVD/CD devices in the DVD/CD-ROM selection. Rebooted my computer then uninstalled all DVD/CD-ROM devices plus the IDE controllers.

  4. Made sure Windows was updated with the latest (service pack 1) and updates.

  5. Updated the firmware for the device with different versions that have been released after 120E that shipped with my DVD RW Drive. (http://www.optorite.com/_english/web/2_service/2_firmwares.php).

Now I am not sure what else i can do. :frowning:

OptoRite will be sending me a replacement DVD RW Drive. :slight_smile:

Okay wacky question…

Try to burn a DVD using Nero or Alcohol… does it work or not?

This is real…

It just happened to me today! Only I have the DD1205. It has been working great for 2 weeks. Now when I put in Any DVD the drive, the label changes to CD-ROM and tells me that the media is incompatable… which is impossible ( I have all ready burned 17 or this 50 pak.)

I tried everything mentioned in the posts.

IMPORTANT: This happened before I upgraded the firmware… I have been trouble shooting this for 6 hours and finally just flashed the drive and it still doesn’t work. (I don’t think it has anything to do with the firmware) It may just be a POS!

Help