Optical Drives Present In Vista, Absent In XP?

vbimport

#1

Greetings, folks. I hope this is the right place. My DVD Rom AND DVD RW Drives are not present in WinXP “My Computer”. They appear in “Device Manager” with a yellow exclamation mark and the message: “Windows could load the drivers for this device…”. Ive tried uninstalling them and letting windows find them and reinstall with no help. Both drives DO appear in the system boot page (POST Screen), they DO appear in BIOS as “Primary IDE Master” and Secondary IDE Slave" and they both DO appear and function in Win Vista. (Dual Booting With XP). They are older devices, (DVDRom/Lite-On LTD163D), (DVDRW/Lite-On LDW-811S, but do function properly when I boot into Vista. I updated the firmware/driver for BOTH ABOUT 1 MONTH BACK, The Rom from GHR2 to GHR8L. The RW from FS06 to HS0R (Was 411S Now 811S). Both worked great in XP after this and still work in Vista, I cant think of anything that may have caused this!
Should I just toss these drives and update?
Thanx much for any help!


#2

OK, a little running around on the 3W and I seem to have figured this one out. After some searching it appears to be pretty common. I tried uninstalling and reinstalling my hardware, I tried re-flashing the firmware each to no avail. Browsing @ sillydog.org/forums/sdt_9200.php I found the solution, along with countless others from as long ago as 2002. It appears to be a corrupted windows driver for some reason or another, maybe after an install or update or even deleting some burning software. I was directed to the Registry Editor where I navigated to "HKLM\SYSTEM\CurrentControlSet\Control\Class"
Look for "{4D36E965-E325-11CE-BFC1-08002BE10318}
Double Clicking the above displays various items two of which include:
“UpperFilters” and “LowerFilters”.
Each of these I deleted, clicked “ok” and rebooted.
Voila, both drives reappeared and are working fine!
I give much thanx to sillydog.org and many others where this fix appeared, I googled “DVD RW Error Code 39” and was directed to quite a few. If any others are having this issue this may be of some help!