Optical drives (even virtual ones) not found

Hi all!

Yesterday i finished my C2D build based on the Gigabyte P35-DS3R Mobo. (latest BIOS)

Today i found a weird problem: sometimes my optical drives simply dissappear! I have a Samsung SH-S203N drive and one virtual drive by Alcohol 120%. The drive letters are present, but when i click them, it says theres no disc present (this happens even on the virtual drive, while Alcohol shows theres an ISO file mounted). The drives dissappear in applications as Nero CD-Speed and ImgBurn too, however they are still present in the device manager.
After a system reboot the drives usually appear and work correctly (i did not have too much time for testing, tough).

My guess is, that is a driver problem, but i have no idea how to solve it. I tried to install the Intel Matrix Storage Manager, but the installer says my system does not meet the requirements…

Any idea what could be wrong ???

Check you bios settings Also have you loaded ALL the mobo drivers?

Yes, all drivers are loaded. And i dont think its a BIOS issue, because i can boot from the drive without problems.

But check out this pic: Theres a DVD+DL disc inserted in the drive, but i cant open it. However in the disk manager it looks like a new partition…

Tomorrow i will probably install my BenQ DW1650 into this machine, maybe it will help to trace back the problem


I found out that the problem was in Nero DriveSpeed (v3.06). Removing it solved the problem. I remembered that i had the same problem on my fathers office pc, where DriveSpeed running in the background hide the drive from every other program.

Maybe one of the mods could move this thread to the appropriate section and change its name to Nero “DriveSpeed problem”