Optical Drive Problems

vbimport

#1

My brother’s been having a lot of problems with programs that use the optical drive in his new PC. I can’t honestly remember the model, so I’ll have to check when I get a chance but the BIOS shows Sony, although that may be due to a firmware flash I did rather than being the actual hardware. I don’t think it’s really important anyway.

I installed a variety of programs to cover the tasks he does, including BurnAware Free. I just observed over Teamviewer that this locks up and it was impossible to kill, either via the TaskManager, taskkill or Process Hacker. It had two programs running, AudioCD.exe and MP3Disc.exe, neither of which I could kill, even after he ejected the drive (I’ve found sometimes that programs get locked up whilst trying to access the disc, so removing it can sometimes unfreeze them).

I then tried Ashampoo Burning Studio but that locked up and wouldn’t let me kill it either. I can understand it might have been fighting for the drive with BurnAware but I still should have been able to kill them.

He has DVDFabPasskey installed, so I wonder if that needs to be shutdown before running these burning apps?

He says the BurnAware Free also told him his disc was too big (i.e. over 80mins), despite the total time shown only being 79-something minutes and that either that program or Ashampoo said there was a problem verifying after the burn, although he was able to use another program to verify (I’m not sure what he used) and that worked fine.

It may be that these programs are just buggy and as all they all seem to have issues or limitations that made them unsuitable for my brother’s needs, he’s now just using Nero v8 micro for his burning tasks, so let’s forget about those programs, other than DVDFabPasskey which he still uses for ripping.

He ripped a DVD the other day and said it seemed to be slower than on his old Pentium 3 900Mhz PC with IDE optical drive and it also had an error in the rip which he had to correct with FixVTS which he didn’t get on his old PC.

Looking at the System Log, I saw a lot of the following:

An error was detected on device \Device\CdRom0 during a paging operation.

and

The device, \Device\CdRom0, has a bad block.

His main HDD is on the separate SATA3 inteface and he has an IDE HDD on that. The optical drive is currently the only device on the SATA2 ports, apart from the lead to the SATA port on the front panel (which doesn’t have any devices connected to it).

I got him to buy a replacement, better quality, SATA cable but he tells me that after replacing it, the first burn he did threw up a verify error, although he said it’s been OK since. He’s using decent quality Verbatim DVD’s, so that’s not the issue.

I checked the log and still see these errors

An error was detected on device \Device\CdRom0 during a paging operation.

although the errors after 28/11 refer to CdRom3 instead, so I presume it just changed the number when he replaced the lead for some reason.

I could buy him a new optical drive for Christmas if those errors point to the drive being faulty but I obviously don’t want to do that if there’s nothing wrong with it and the fault is elsewhere, so a new drive won’t help.

Anyone got any ideas?


#2

A lot of possibilities, as you state. I think I’d eliminate the PassKey program from ‘starting with Windows’ - disallow it to load or run, entirely - and see if the Burn vs. Drive problems persist.

Other users here will probably recommend IMGBURN which will feel quite ‘foreign’ to a Nero user, but it generates log files which users here can help interpret for you.

THE “FILL” ERRORS - when a software tells me I’m burning too large of data-set, there’s no need to argue with it. IT’S doing the burning - I must obey it’s constraints. (And putting 79 min on an 80-min CD is begging for poor playback opportunities. Why bother? Burn two and enjoy both with a greater certainty of top-quality playback. And playback is the purpose of burning - not to win some contest by cramming more into less.)

LENGTH OF TIME TO COPY/RIP - I’ve never understood why some disks take longer than others. Quality of the disk? Some kind of idiotic speed-governor like RipLock? I throw up my arms and accept whatever speeds are proffered - or else turn on another machine and try it over there!

To seriously decipher more possibilities, precise model numbers will probably be requested, too.

I might also uninstall all the burning programs except one just in case some programs (and Nero’s earned this notorious reputation) installs some kind of crypto-driver like InCD that offers to do more More MORE when you really want Just Plain Burning.


#3

Yeah, I think I have disabled Passkey from launching at startup as I recalled it can interfere with burning or verifying but I need to make sure my brother’s closing it after using it before burning.

I can certainly help my brother test with ImgBurn if the logs will be useful. Easiest would be to burn an ISO with it but we could do individual files if that would be better.

As I recall, the 80-min worth of music my brother was trying to burn was ripped from a single CD, so he wanted to burn it on one CD and not split it. It seems it was a bug with BurnAware anyway, as the other programs didn’t object and BurnAware had some other limitations (to do with gaps and volume normalisation as I recall) that made it inferior to Nero (or even WMP).

It was the same disc that my brother ripped on both PCs, so it can’t have been the quality of the disc but it was different drives so it’s possible there is a RipLock on it. When I find out what drive it is I can check whether I flashed the firmware and if not, do that if there’s a suitable one available.

I avoided installing Nero when I setup my brother’s PC as I was aware there are some questions about it but I thought they were mostly about how bloated it’s become. Anyway, as it turned out all the other programs either had limited features or were not user-friendly enough, I had to relent and install Nero v8 micro for my brother, which at least cuts out all the bloat.

I was thinking I could buy him a USB external DVD writer, like the Samsung SE-208DB, which would eliminate any fault on the SATA controller as the problem but I’m not sure how good they are for ripping and burning. Otherwise I could get him a LiteOn iHAS124 for less. Are they considered any good for ripping/burning?


#4

OK, I checked and the drive is the Sony AD-7260S v1.61 (or that’s what the firmware shows as anyway).

I checked the logs and they weren’t any new errors since last time (my brother confirmed he’d burnt some discs) so I guess it’s possible he forgot to close Passkey before burning/verifying before. I reminded him that he needs to do this but he did know already.

So I guess I’ll just have to check again in a few weeks and see if there’s still no errors. It might be worth uninstalling Passkey and installing an alternative ripping program that doesn’t do anything until clicking Rip (i.e. doesn’t install any drivers or run in the tray) if there is anything that works as well, just to avoid him accidentally forgetting to kill Passkey.

MakeMKV works well but I don’t think that allows ripping to ISO/VOB files unfortunately, as most of what my brother does is ripping to those, running through DVDshrink and making a backup to DVD+R.