Optiarc DVDRWBD BC-5600S. Hangs while burning

Hi.
I just got a new laptop ( Dell Studio XPS 1640 ) with a Optiarc DVDRWBD BC-5600S.
Everytime I try to burn something the burning starts up and after a while it just stops burning. It stops very randomly, sometimes it can stop at 1% and some other time it might stop at 50%, giving no error messages at all. It just completely stops burning. Any tips for making this work?

My system:
Dell studio XPS 1640
Intel duo core p8400 2.26ghz
4gb ram
ATI mobility Radeon hd3670
Windows Vista Ultimate x64 Edition SP1
Optiarc DVDRWBD BC-5600S

This is the ImgBurn log from last time i tried:

I 15:47:11 ImgBurn Version 2.4.2.0 started!
I 15:47:11 Microsoft Windows Vista Ultimate x64 Edition (6.0, Build 6001 : Service Pack 1)
I 15:47:11 Total Physical Memory: 4Â 188Â 104 KB - Available: 2Â 810Â 716 KB
I 15:47:11 Initialising SPTI…
I 15:47:11 Searching for SCSI / ATAPI devices…
I 15:47:11 Found 1 DVD±RW/RAM and 1 BD-ROM/HD DVD-ROM!
I 15:47:55 Operation Started!
I 15:47:55 Source File: E: est.iso
I 15:47:55 Source File Sectors: 279Â 358 (MODE1/2048)
I 15:47:55 Source File Size: 572Â 125Â 184 bytes
I 15:47:55 Source File Volume Identifier: TEST
I 15:47:55 Source File Application Identifier: Nero Burning ROM
I 15:47:55 Source File File System(s): ISO9660; Joliet
I 15:47:55 Destination Device: [1:0:0] Optiarc DVDRWBD BC-5600S 103B (F:) (ATA)
I 15:47:55 Destination Media Type: CD-R (Disc ID: 97m15s17f) (Speeds: 4x; 8x; 12x; 16x)
I 15:47:55 Destination Media Sectors: 359Â 843
I 15:47:55 Write Mode: CD
I 15:47:55 Write Type: SAO
I 15:47:55 Write Speed: MAX
I 15:47:55 Test Mode: No
I 15:47:55 OPC: No
I 15:47:55 BURN-Proof: Enabled
I 15:47:56 Filling Buffer… (40 MB)
I 15:47:57 Writing LeadIn…
I 15:48:28 Writing Session 1 of 1… (1 Track, LBA: 0 - 279357)
I 15:48:28 Writing Track 1 of 1… (MODE1/2048, LBA: 0 - 279357)

If you need any else information just ask and I will be happy to oblige

I have exactly the same problem with the BC-5600S in my Dell Studio 17 when I burn Verbatim DVD+R disks. When burning DVD-R disks the BD player already hangs when burning the lead-in. Problem persists even after updating to newest (108B) firmware.

Any solution yet?

Can you repeat that but burn at 12x?

Maximum DVD burn speed is 8x. It seems that the problem is solved in the newest Dell firmware update (10AB). I managed to burn a DVD-R now without problem.

[QUOTE=Teep;2413904]Maximum DVD burn speed is 8x. It seems that the problem is solved in the newest Dell firmware update (10AB). I managed to burn a DVD-R now without problem.[/QUOTE]

15:47:55 Destination Media Type: CD-R (Disc ID: 97m15s17f) ([B]Speeds: 4x; 8x; 12x; 16x[/B])
:rolleyes: