Optiarc DVD RW AD-7530B dead?

vbimport

#1

Hi!

I’ve got BENQ Joybook R56 laptop with Optiarc DVD RW AD-7530B drive under Linux Ubuntu 10.04.

With all previous versions of Ubuntu AD-7530B drive worked properly and all DVDs were burned OK. But when after the latest upgrade I tried to burn another DVD with GnomeBaker my drive produced strange drilling noise. I immediately stopped burning process, reboot my laptop and tried the process again that resulted in the same affect. I extracted the DVD-R (it remained blank) and inserted recorded DVD. It was recognized and read OK. In several hours DVD drive stopped recognize even recorded DVDs, then after some time it stopped open the tray and at last stopped to blink its LED.

It is still recognized as Optiarc DVD RW AD-7530B but does not show any sign it is alive.

Here is the info from the DVD drive:

$ sudo hdparm -I /dev/sr0

/dev/sr0:

ATAPI CD-ROM, with removable media
	Model Number:     Optiarc DVD RW AD-7530B                 
	Serial Number:      30647810 1151868Q111
	Firmware Revision:  NX02    
Standards:
	Supported: CD-ROM ATAPI-3 -4 -5 -6 -7 
Configuration:
	DRQ response: 50us.
	Packet size: 12 bytes
	cache/buffer size  = unknown
Capabilities:
	LBA, IORDY(cannot be disabled)
	DMA: mdma0 mdma1 mdma2 udma0 udma1 *udma2 
	     Cycle time: min=120ns recommended=120ns
	PIO: pio0 pio1 pio2 pio3 pio4 
	     Cycle time: no flow control=383ns  IORDY flow control=120ns

Could anybody analyze the situation and make a conclusion what happend? Is it possible to revive the drive or it is completely dead? If it is dead what could cause it?

Thanks for your attention!