Optiarc DVD RW AD-7530A not reading disks, not even outside Windows

vbimport

#1

Hello all,

I have an Acer Aspire 9300 notebook, and reinstalled Windows. After the reinstallation I noticed that the laptop doesn’t read any disks anymore.

If I look in the hardware manager, it says that it’s an “Optiarc DVD RW AD-7530A”. However, I cannot find this type anywhere on the internet.

Did anyone encounter the same problem? If yes: Can you tell me how you solved? (If you solved it ofcourse ;-))

Otherwise: Does anyone have a link to firmware or some kind of drivers for this disktray?

With kind regards,
“MasterGuy” Marcel


#2

You don’t need drivers.
Have you installed Windows from the Optiarc drive?


#3

Yes I installed Windows from that drive.
After the first reboot it didn’t read any disks anymore, but it does show up and it doesn’t give any error.

I tried:

  • Re-installing the drive
  • Un-installing, rebooting and installing the drive
  • Looking in the registry for the upper- and lowerfilter keys (they didn’t exist)
  • Slightly pressing the drive to make sure the connectors make the connection

None of them worked.

The drive does try to spin-up the disk, but it doesn’t. It keeps (concluded by the sound it makes) moving the laser forward and back, hoping it would find something readable, but it doesn’t. The disks do spin, but not on normal “fast” speed as they normally do when you place a disk in a tray.


#4

I have had a problem like that with portable cd players in the past. I think it was something to do with the motor.
But pretty much it was bad and had to get a new one.
How old is this drive?


#5

One year. And the strange thing is that it happened with the OS install… I Wish it didn’t happen after the OS install but during the run. then the reason would be clear.


#6

I’m having a similar problem with my Gateway notebook, running 32-bit Vista. I have the same Optiarc CD/DVD RW AD-7530A ATA combo drive, It stopped reading DVD’s completely, but CD’s work fine… weird.

Drivers are up to date, drive is clean, tried uninstall/reinstall, deleting upper/lower filter, etc etc etc.

My warranty is (of course) expired, so Gateway wants big $$$ for support, and this forum is the closest I’ve come so far to ANY kind of real info for a 7530.

Any help provided earns everlasting indebtedness!


#7

It could be something wrong with the connection inside the laptop. Have you dropped it at all? Could cause wires to come loose.
But, I’m not too familiar with lappy drives.
If its reading CD’s but not DVD’s it probably isn’t a connection problem though.


#8

Exactly the same here…
I just tested it again and it looks like its reading CD’s now again, however: not any burned ones… only the originals.


#10

Sounds like the laser is on its way out if it will only read original cds.

Burned cds are harder to read than original ones hence a struggling laser
fails.

Martin


#11

@masterguy: I don’t think I’ve heard of that happening. Do you have anymore details?

[edit]For example, what is the original CD you are using and what brand of blank media are you using?


#12

First I tried the original WinXP (prof) disk, but it didn’t read.
Last week I tried a random game (Empires, Down of the modern world) and it worked. After that I tried an original music CD from the local store (Author: Krezip) and it was read normally.

After the CD of Krezip I inserted a burned disk that reads perfectly on the other computers, but it failed. Also all DVD’s I tried fail.


#13

Sorry, I wish I could be more help.