Optiarc AD7170 flash problems



I’ve been having problems with my Opti-p.o.s. and decided to flash it today. I dl Binflash and gave it a shot… I keep getting the damn “checksum” error. So I read the faq and changed my IDE settings to PIO, but there was no change. Then I rebooted in safe mode and tried it again, yet I still had the same problem. Im at my wits end on this and was wondering if anyone had a solution.

Im hoping that by flashing the damn thing, that windows will finally recognise it as a burner and not just a cd-rom. Ive read some stuff claiming that Jmicron drivers were to blame, yet those problems apparently deal with the drive running on UDMA (mine appears to be running on UDMA 5). :a

Any info is appreciated!


As with most problems, you solve them when you least expect it. I took a shower aftewr 5 hrs, decided to use the windows drivers instead of the crap Jmicron ones recommended by ASUS, and wa la, windows recognises the damn drive. Then I rebooted into safe mode on a hunch, tried the flash program again and it worked like a charm! Thanks for the software!