Optiarc AD-7640s Not Reading Media

vbimport

#1

I’m a soldier currently deployed in Afghanistan and I ordered a new alienware M15x while on leave. Well two months later the disc drive has suddenly stopped reading discs. It’s an Optiarc DVDRW AD7640-s. I’ve talked to Alienware support already exhausting their knowledge which they have told me to reformat the computer and re-install windows. Unfortunately I do not have my disc here, nor do I wish to do that in the first place. Any help or recommendations would be much appreciated.

Things I’ve tried so far:

  • Deleting upper / lower registry (weren’t there)
  • Uninstalling the optical drives from device manager
  • Running dell diagnostics upon boot up (Last thing I see is the drive looking as though it’s passed and going to color bars asking me y/n if I see them at which point I can’t get past the screen)
  • Tried to boot from windows disc, goes straight past and loads windows
  • Looked for firmware or drivers updates couldn’t really find any. There is a BIOS update but I didn’t think the BIOS was the main issue
  • Drives show up in My Computer, for some reason it shows 2, a BD-Rom and DVD-RW
  • I’ve also tried changing the drive path from E: to A: or K:

What I’m running:

  • Windows 7 Home Premium 64-Bit
  • Radeon HD 5730

#2

When trying to boot from a bootable disc, did you check the BIOS options for enabling to boot from the optical drive (on screen or in the BIOS)?


#3

I was trying to boot from a disc to see if the problem was windows just wasn’t recognizing discs or whether it was more of a hardware issue. Yes, I tried switching it to booting from disc in BIOS still no dice it would just skip over. I want to exhaust every software issue before I give up and assume it’s a hardware issue. I heard there might be some programs that can interfere with the optical drive in the registry anybody heard this?


#4

Where did you hear that?

Some drivers like roxio or gear can easily interfere with proper drive drivers…


#5

Just reading threads like these I heard that. I still haven’t found a solution to the problem yet.


#6

I have the exact same problem as original poster. Is the drive just dead? Any advice?


#7

As you may have learned from reading this thread, changing the boot order in the bios so that the computer boots from the optical disk first is one thing to try. You’ll need a bootable disk also. Here is one: http://www.ultimatebootcd.com/download.html You can burn this ISO to a cd with ImgBurn (free). www.imgburn.com

If it will start from outside the operating system using your bootable disk, then you can safely assume the hardware is not at fault. You then move on to possible software issues, like upper and lower filter problems.

You can also use the Microsoft Fix It tool and see if it can find your problem, assuming a software issue. Look in my signature for a link that says [I]Microsoft support for optical drives.[/I]


#8

hello,
I have changed the boot order in bios to optical drive 1st, it just skips right through. I assume that means there is a physical problem, thus cannot be fixed…

I have been using this optiarc 7640 for less than 3 months…
Is anybody aware of replacement programs with optiarc? Their website doesn’t seem very helpful.

[QUOTE=Kerry56;2557860]As you may have learned from reading this thread, changing the boot order in the bios so that the computer boots from the optical disk first is one thing to try. You’ll need a bootable disk also. Here is one: http://www.ultimatebootcd.com/download.html You can burn this ISO to a cd with ImgBurn (free). www.imgburn.com

If it will start from outside the operating system using your bootable disk, then you can safely assume the hardware is not at fault. You then move on to possible software issues, like upper and lower filter problems.

You can also use the Microsoft Fix It tool and see if it can find your problem, assuming a software issue. Look in my signature for a link that says [I]Microsoft support for optical drives.[/I][/QUOTE]


#9

So your Laptop/device is still under warranty?
If thats the case, contact the seller.