Optiarc AD-7633A uses 100% cpu

Hello guys,

my AD-7633A is giving me a problem. It uses 100% cpu every time I use it so reading is slow and writing is impossible. Searching on internet I have found that a possible cause can be the trasfer mode. I have found that my drive is in PIO mode: http://digilander.libero.it/deathrider/ide.jpg . I have tried to switch it to DMA but nothing work. It continue to go PIO even if I uninstall the ide channel and reboot. I do not have idea of what to do.
Have you any suggestion for me?

Thank you all

PS.: My machine is a Toshiba M40-193

Hello Deathrider :slight_smile:

Download and run the “resetdma.vbs” file in this post - if it finds any channels to reset to UDMA mode, it’ll do so then ask you to reboot.

It not work. My drive actually is set to slave on secondary ide channel. What you think if I try to set it to master? Can work?

Since that’s a laptop drive, changing the Master/Slave setting won’t be so easy, and I’m not sure that will fix it.

What happened when you ran the “resetdma.vbs” file?

It will terminate normally and ask me to reboot system.
After reboot nothing change, I found my drive in pio mode.

Finally I solved the problem. I switched the ATA mode from normal to reverse. I use a tool you can now donwload here:
http://digilander.libero.it/deathrider/Optiarc_G63x_ATAChange_Tool.ZIP

I found the solution reading another topic on this forum. Now the drive read without problems. Tomorrow late I re-install Nero and try to write a disk.

Now the drive is secondary master and uses DMA.

Also writing is good.