Optiarc AD-7530A burning/read problems

Hi, I have a Dell Inspiron 1705, WinXP Home, with a Optiarc AD-7530A burner that I installed in Feb 07. The drive was working fine until 2-3 days ago, when it suddenly started writing discs at under 1x speeds. The drive still completes the burn successfully, it takes approx 1 hr to burn a full DVD+ or -R (single layer). Previously it could burn in under 10 minutes flat at 8x. I re-installed Nero 8 to ensure there were no problems with software, still no go. What could be wrong? I’m attaching drive info from Infotool.

No changes have been made to the system configuration.

Any help would be appreciated!


Nero InfoTool 5.1.0.0

Drive Information

Drive : Optiarc DVD RW AD-7530A
Type : DVD±R/RW DL Recorder
Firmware Version : EH31
Buffer Size : 2 MB
Date : ?
Serial Number : 30644560 1018821Q111
Vendor Specific : Nov02,2006
Drive Letter : D:
Location : 1:0
Mechanism : Tray
Read Speed : 24 , 20 , 16 , 11 , 5 X
Write Speed : 24 , 20 , 16 , 10 X

Read CD Text : Yes
Return C2 Pointers : Yes
Read CD-R : Yes
Read CD-RW : Yes
Read DVD-ROM : Yes
Read DVD-RAM : Yes
Read DVD-R : Yes
Read DVD-RW : Yes
Read DVD-R DL : Yes
Read DVD+R : Yes
Read DVD+RW : Yes
Read DVD+R DL : Yes
Read BD-ROM : No
Read BD-R : No
Read BD-RE : No
Read HD DVD-ROM : No
Read HD DVD-R : No
Read HD DVD-RW : No
Read HD-BURN : No
Read Digital Audio : Yes
Read CD+G : Yes
Read VideoCD : Yes

Write CD-R : Yes
Write CD-RW : Yes
Write DVD-R : Yes
Write DVD-RW : Yes
Write DVD-R DL : Yes
Write DVD+R : Yes
Write DVD+RW : Yes
Write DVD+R DL : Yes
Write DVD-RAM : Yes
Write BD-R : No
Write BD-RE : No
Write HD DVD-R : No
Write HD DVD-RW : No
Write HD-BURN-R : No
Write HD-BURN-RW : No
Buffer Underrun Protection : Yes
Mount Rainier : No
SolidBurn : No
Labelflash : No
LightScribe : No
Modes : Packet, TAO, DAO, SAO, RAW SAO, RAW DAO, RAW SAO 16, RAW SAO 96, RAW DAO 16, RAW DAO 96

Region Protection Control : RPC II
Region : 1
Changes User : 4
Changes Vendor : 4

CSS : Yes
CPRM : Yes
AACS : No
VCPS : Yes

Welcome to the forum :slight_smile:

Make sure you have DMA enabled on all your drives - there’s a link in my sig with details. :slight_smile:

Hi, thanks - I had already verified both primary and secondary IDE Channels are in DMA mode. (Primary channel is running UDMA mode 5, secondary is DMA).

Something strange I noticed while using Nero (when the problem started) is that the device read buffer (which is usually maintained at 100% during a burn) is not maintained at 100% anymore. It varies from 10 to 97%, mostly staying in the 30% range. As a result, the drive (well, Nero really…)automatically slows the burn process down (to prevent buffer underrun errors and produce a coaster). I’m not sure what is causing this - did the drive go partially defective? I ran disk defrag to make sure the hard drive was not trashed with file fragmentation - it was not.

Any other ideas other than to try replacing the drive? Any other firmware (liggy/dee) available for this drive? I did not see one.

Thanks in advance for your help!!!

i’ve the same issue with a compaq c540 laptop (that i’ve bought in july 2007) for finish a full dvd (-r, 4.30 gb) nero 7.8 spend some times like 30-40 minutes!

I need to send it to assistance? I can send only the unit and not the whole machine?

nbye and sorry for my bad english :wink:

Post a log…