Optiarc AD-7530A ATA Problems

vbimport

#1

The first problem I had with my Sager notebook was with the dvd player. It would spin the disc, and know that it had to read it, however it couldn’t. Under My Computer, it would be as if it were empty, but would still attempt to read the disc. I had to send it in last time to get it fixed (which took forever) and it worked alright until I installed Windows 7 recently. Now it is doing the same exact thing.

Now, I went to Sager’s driver download site and updated all of my drivers after installing Windows 7 that they had listed. My dvd player wasn’t, so I went to Optiarc’s page and found that my player wasn’t listed. I’m so confused! Even on this site, it doesn’t list my specific product. I’ve checked and rechecked what is listed in my Device Manager, and it reads: “Optiarc DVD RW AD-7530A ATA Device”.

I’ve tried letting my computer search for updates by itself, all to no avail. I can’t send in my computer until the end of this semester, but it would be best if I could just fix it myself now. Any suggestions?


#2

Welcome to the forum. :flower:

Did you get this fixed?