Optiarc AD-7203S read problems?

vbimport

#1

[qanda]This question is published in the hardware section for the Optiarc AD-7203S. Click here to view full specs.[/qanda]I have this problem where my drive seems to stop reading disks at random points. I recently tried installing a game that came on two DVDs. I put the first disk in, it went to autorun and installed okay, if a bit slowly. It prompted me for the second disk and the tray popped open. I put the disk in, and it wouldn’t read it; it kept popping the tray open waiting for me to put disk 2 in. I tried a whole bunch of times, kept hitting ‘retry’, and it wouldn’t read the second disk. I tried installing the game on another machine, and the second disk worked fine, and the installation completed. I tried unistalling and reinstalling the driver for the drive and that didn’t help. My computer sees the drive fine and assures me that there’s no problems with it. I’m running Windows Vista Home Premium, btw. I downloaded some updated firmware for the drive, but the installation program doesn’t seem able to find the drive when I run it. The drive does work, sometimes. I’m just wondering what combination of factors could lead to it working sporadically and selectively as it does, and what steps I could take to fix it?Â