Optiarc AD-7200A

vbimport

#1

Hello,
I purchased a computer with an Optiarc AD-7200A installed about a year and a half ago. Somewhere around 8 months after I purchased it I started to have issues with this drive. I believe it was after I downloaded some stuff off the internet ( may be wrong). It used to work fine: Reading, Writing, everything. However, now when my computer is turned on or returned from sleep mode the drive tray opens. If i shut it it opens again. The only way to get it to stay shut is to press the close button AS it’s openning. However, even after I managed to get it to stay shut using the trick I stated above, it refuses to read any disks. If I put a disk in and get it to stay shut, if I attempt to read the disk, it says “Please insert disk into D:” and then pops the drive open.

I don’t believe the laser is broken, because the error dosn’t state that it cannot read the disk, it simply believes that their is never a disk inserted in the first place. I hadn’t flashed the firmware till AFTER this started happening, and that hasn’t fixed the problem either. I was running firmware 1.06, and I recently flashed it with 1.09 to see if that would rectify the problem, which it did not.

Yesterday, I decided to see if it was a BIOS issue, as it happens on startup before Windows boots. I disconnected the ribbon cable, and only left the power cable in. Upon startup the problem persisted, so since the motherboard dosn’t have communication to the drive, I can only assume that it must be a firmware or hardware error WITHIN the drive itself.

I’m really just a novice user of computers. Im familar with the basics and what not but less familiar with how the software and firmware interact with the hardware (I don’t know any coding, etc.). I understand the difference between software and firmware, but I’m not sure about weither firmware can be infected with worms or bugs like software can. If it can, is it possible that a virus or worm has infected the firmware of my AD-7200A, and perhaps thats why that even after I flashed the firmware with a newer version, the problem persists? When flashing a drive, does it completly erase all of the previous content and load the new firmware, or does it simply write over specific oarts (like an update)? If it dosn’t erase all of the previous content, would it be possible to erase the firmware completly and THEN flash it with a new (or older) firmware in the hopes of eliminating any viruses or worms (if these can indeed infect firmware).

At this point i’m not afread of loosing the drive’s ability to function, because I already feel like it’s ruined. Bricking it won’t hurt me because if I can’t get any answers from here, then i’ll be forced to by a new one anyways.

Any help would be much appreciated.
Thank you,
James
Washington State

P.S. Excuse my English, I am and always have been horrible at grammer. English is my native language, spelling and sentance structure have always taken back seats to more logical persuances like math, science, and history.


#2

Hi and Welcome!

is there any opportunity to try the drive in another computer? I’d also blame the PSU as possible culprit.

If it can, is it possible that a virus or worm has infected the firmware of my AD-7200A, and perhaps thats why that even after I flashed the firmware with a newer version, the problem persists?
No. There are several mechanisms (checksums etc.) that prevent unwanted writing of data to the flash memory of the drive. And if some evil virus really managed to override these locks, then the drive would simply be braindead from that moment. Very unlikely scenario.

Michael


#3

James, it could also be a mechanical problem. If you’re so inclined, you could open up the drive case and take a look (it’s pretty easy, first take off the bezels on the front of the drive tray and the case, then there are 4 screws on the bottom of the case).

There could be a piece broken inside, or something there that doesn’t belong, preventing the drive tray from closing properly…


#4

I have tried the drive on another power supply, I have also tried opening it up before, but I produced nothing. Everything looks fine. it has to be something with the circuitry because I unplugged everything mechanical with the exception of the small motor that drives the tray and after restarting it still attempted to move the motor.