Optiarc AD-7170A Cannot install firmware

Hi, all.

I’ve got a problem with my NEC Optiarc AD-7071A. I want through posts suggesting firmware for my DVD, but for some reason, when I tried to install it, it couldn’t locate any Optiarc burners on my PC. I am using WinXP 64bit. Right now with default Windows drivers I can’t even see the DVD as drive.
Any help would be appreciated.

Update with another OS.

Welcome to the forum.
Has this drive worked previously on this PC with another OS?
Check that the jumpers on the rear of the drive are set correctly (master/slave)
Check or replace the IDE cable.
Un-install the IDE drivers then reboot and allow Windows to find and install them again.

Wish I could, but I have 4G RAM and 32bit OS see that as 3G.

Thanx.
The DVD worked perfectly on the same PC with the same OS just a few days ago, that’s what killing me. I recall it quite clearly, since I’ve installed motherboard drivers using the DVD. IIRC there was always problems with drivers, i.e. I’ve seen it with “!” mark in device manager, but it was reading CDs with no problem. Then at one point I just stopped seeing it under “My computer”. I will try what you suggested and see if it helps. Thanx.

4GB and 32-bit OS sees only 3GB - this is a known Windows issue and has nothing to do with this forum. I am not sure the flash would work with 64-bit. Best shot is to flash it under 32-bit.

It will flash ok in either XP 64bit or Vista 64bit.

It’s not the topic, I simply explained why I can’t use 32bit. Also I have no clue what flashing you’re talking about, would appreciate an explanation.

Do you still see the ! in Device Manager? If so, what’s the error code included with it?

Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)

Thanks :slight_smile:

Click the link in my sig - “How to delete your upper/lower filters” - it will take you to a Microsoft support page, which includes a Guided Help to make the process easier.

Give it a go. :slight_smile:

Great thanx, will do :slight_smile:

Finally found time for this, it helped, mucho thanx for help :bow: