Optiarc ad-5170a dvd-rw trouble

vbimport

#1

Hey.
I’m a first timer in these here forums, so i’ll lay down the background first:
AMD AM2 socket 4800+ processor
Gigabyte M57SLI-S4 mother board
3 SATA hard drives
1 Optiarc AD-5170A optical drive (firmware ver. 1.11)

I’m currently running winxp pro/win vista x86 home basic.

The problem:
I’ve recently installed the Vista operating system.
after installing it, my Optiarc stopped accepting DVD-R media.
it can accept the following:
CD, CD-R, CD-RW, DVD, DVD-R(after burning).
It is able to write and read all medias above.
When inserting the DVD-R media, the drive spins as if data had already been written on the media.
after restarting several times i’ve decided to try a different drive (have another lite-on DVD-RW drive).
the drive had accepted the media as DVD-R and burned successfuly.

Both windows OSs give the same reaction. In fact, when I restart and have a DVD-R media inside the optiarc, and the boot sequence reffers to “Boot from CD/DVD…” it spins again and won’t boot untill i remove the media from the drive.

I’ve tried dumping and updating the firmware (liggy’s 1.02). I don’t know if it was the right step but what is done, is done… I then recovered the original firmware.

Help would really be appreciated.

Rocky


#2

wow… I’m guessing this wasn’t the place? or no one can actually help…

Thanx a bunch for the views guys, appreciate it

I’ll just go out and buy a new one…


#3

Does the drive run in UDMA4 mode??


#4

Have no idea what UDMA4 means… sorry… I guess I’m reeeeeeealy new to this…


#5

Just googled it… (woops…)
ok, so I found that my primary IDE and Secondary (I’m only using SATA HDDs so I’m guessing this is reffering to the DVD-RW).
It is running under Ultra DMA4.
Should I change this on both primary and secondary (to PIO that is)?
Or is this not the problem?


#6

UDMA4 is fine.


#7

Can’t help you with Vista, but under WinXP have you tried deleting the IDE controllers from Device Manager and rebooting? You might need to do this from safe-mode. I assume you’re using WinXP SP2 right?

Also I wouldn’t worry about the booting off a blank disc…that might be a BIOS problem if it never did that before.


#8

yes I’m using SP2
my worry right now is the XP only, so don’t worry about the vista

I’ll try safe-mode->reboot->remove IDE->reboot into safe-mode again? or just a regular boot?

About the booting: I believe this whole problem is a BIOS misconfiguration of some sort. is there any way to reinstall the BIOS and return it to factory defaults?


#9

i tried uninstalling and windows automatically installs it back after reboot
still doesn’t work.


#10

I’ve tried using it on a different PC
does the same thing. Spins as if it were reading a dvd-rom.
what is wrong with my precious???


#11

i finally tried a different company media DVD-R. guess what? it worked…
strange…
I’ve been using BR-Tech media. till today that is…