Optiarc 7530 Problems

vbimport

#1

I’m running a Gateway notebook/Vista with an Optiarc 7530A driver.

Problem is that it will read and burn cds just fine, but won’t recognize any dvds. Autoplay is a no go and if I manually play through My Computer, it tells me to insert a disc.

I’ve manually deleted the upper and lower filters and rebooted. No change. I uninstalled and reinstalled with device manager, no change. I’ve tried several different dvds including burned, manufactured, and blank with no change. And I’ve manually reinstalled the entire drive out of the panel. Still nothing. BIOS recognizes it just fine…so I don’t know what’s going on.

I was told to maybe update the firmware, only to find that it’s near impossible to actually find firmware for this specific model.

Help!


#2

Maybe the drive is bad? Also try asking Optiarc.


#3

Hi, I also have exactly the same problem ! Drive suddenly went nuts when (I’m assuming) it was in middle of layer transition on the dual layer DVD I was watching. Since then it does not recognise DVDs but CD’s are fine. Also followed advice elsewhere and removed registry keys but no good (just upset my i-tunes which started telling me to re-install i-tunes !) Have uninstalled and reinstalled drive, but still no good. I’m waiting to hear back from Gateway, as they don’t have the drivers or firmware on their website and my next guess had been to update firmware - if I hear anything I’ll let you know. All the best,


#4

I have the same problem. Optiarc does not support this model, they basically sold it to the vendors (Acer, Gateway, Dell, etc.), so you have to get support from them.

Mine is also Gateway, and since the warranty recently expired I would have to use their pay-as-you-go support.

I’m leaning toward buying a completely different drive. Even if there’s a gap in the faceplate, at least I’ll be able to find some support for it.