Optiarc 7201S drive fails to install in Vista

vbimport

#1

I have Vista Home Premium and recently installed an Optiarc 7201S DVD burner. When Vista discovered the new drive, it tried to install the driver and failed with a message saying “This operation requires an interactive window station”. I’ve tried to reinstall the driver but keep getting the same error message. Microsoft’s site says this is something the manufacturer has to solve but the Optiarc site has no support option and only states that the driver for this DVD device is a standard MS supplied one and no Optiarc specific driver is available. The MS knowledgebase says that there is something wrong with the install process but doesn’t tell me what or how to fix it. I bought this drive from an internet site that has good prices but no support. I have a screen capture of the install error if that would help. Any help would be appreciated. Thanks


#2

Welcome to the forum.
Please check this document from MS
http://support.microsoft.com/kb/929461


#3

Thanks. I already had deleted the upper and lower filters from another problem I had with an IDE DVD drive that kept disappearing and that didn’t solve my problem. I bought the SATA DVD drive I’m having this problem with as a possible way to get around the IDE DVD drive disappearing but to no avail yet. I also downloaded the Devcon program that the MS KB article refers to but there are no instructions on what to do with this after I get it downloaded. I’m not familiar with this program and don’t want to mess up my computer by doing a trail and error approach. Are there any instructions on what to do with this program to install my SATA DVD drive? Thanks.


#4

What mainboard (chipset) do you have and in particular what controller is your drive connected to and what are the settings.

The SATA drive might not work properly if the controller is in AHCI or RAID mode.


#5

The MB is an Intel DP35DP. I’m not that familiar with the SATA setup but I have 2 SATA hard drives (250GB each) running as Raid 1 and another SATA hard drive (750GB) installed in addition to the SATA DVD burner that isn’t installing. If you could tell me what to look for, I can find the information. My disk controller devices shows a normal “IDE ATA/ATAPI controller” and a “Storage Controller” that had the name “Intel® ICH8R/ICH9R SATA Raid Controller”. All of the devices show in the control panel as being installed correctly and working except my SATA DVD burner. That doesn’t mean that they are really installed correctly but they look OK. Is it possible that these drives (750GB Hard Drive and DVD burner) are not really installed as SATA drives and are defaulting to look like IDE type drives? I saw some messages a few days ago that led me to think this might be so but I don’t know how to find out if this is true. If you could point me to some instructions on how to find this out, that would be great. Thanks.


#6

Unfortunately, if you already have a RAID setup then a SATA DVD burner is very unlikely to work on the same SATA controller. Perhaps your board has a second SATA controller, maybe listed as JMicron?

If it has, you need to connect the DVD burner to that controller and in the BIOS, set it to IDE or emulate IDE mode. Failing you have a second controller, you will need to purchase a PCI SATA addin card.

Let us know which part of the world you’re located in and we’ll try to provide a link to a suitable addin card.


#7

Thanks for the information. It sounds like you have hit the right answer. I’m in the US - New Hampshire to be exact. Will an add-in SATA board work as well as the MB controller and without problems? I’ve had other add-in boards that sometimes were more trouble than they were worth. Thanks.


#8

Many people (including myself) have used the Silicon Image 3x12/3114-based PCI-to-SATA controller cards without any problems, as long as the BASE BIOS is flashed onto the Flash memory. Here are two options: 3x12 or 3114.


#9

Thanks. Do these work with Vista and do they work independently from the onboard (MB) SATA controller?


#10

yes, the 3114 card works fine with Vista 32/64bit. But as mentioned above make sure you flash the bios as KTL mentions above.