openSUSE 11.2 Nero 4 not recognizing physical device

vbimport

#1

Hmmm…just today, used Nero 4 on this laptop to test new DVD drive, worked perfectly with openSUSE 11.1. I did a fresh install of openSUSE 11.2 and just installed Nero 4. Nero cannot find the physical device. System has it (sr0) and uses it without problems. I assume it’s a permissions issue, but am not clear as to how to make Nero “see” this device. Also, since this IDE device was recognized before with openSUSE 11.1, I wonder what has changed with openSUSE 11.2 to make Nero confused?

Thanks in advance for any advice on this.


#2

I have just confirmed that K3B finds the device with proper permissions, identifies it and has control over it without problem…I think it might be an issue with openSUSE 11.2 AND Nero 4? If mathf can figure THIS one out, he should have a bronze statue. They figured out the last issue with the multi-session issues!


#3

I will have a look to this issue… Sounds weird, even if we are not using the same device file as k3b…
Can you check that you have access to /dev/sg* for your optical disks devices ?


#4

Thanks, I will get back at that machine later this morning (USA)…what is the proper procedure for checking that I have ACCESS to those devices (files)…I can see that they exist and their permissions, but don’t know how to actually check that there is access (other than permissions of the device file)…or is that it. I will look at the /dev/sg* files and see what they look like later.


#5

Ok… Problem found… and problem fixed. It seems that the automatic configuration wizard does not let you have access to the ODD.
To change that, simply add your user account to the group ‘cdrom’.


#6

STUPID ME!!! I THOUGHT of that yesterday, but made the mistake of not logging off and back on for the new group to take affect…so after I made that change yesterday and it “didn’t” work because of that, I took that group off before I went on troubleshooting! THIS TIME I logged off and back on and walla…problem solved! Thanks…


#7

Just for my info… You must have had some warning dialogs when you started Nero Linux telling you at least that no drive could be found no ?


#8

Yes, it was set to check for devices at start-up and there was a big box that said that no physical device could be found and to check the manual for information. It’s very obvious because the recorder wouldn’t show up in the “choose recorders” section either…now all is normal. The warnings are programed correctly and it’s that big “box” over the top of the project dialog wizard right at program start-up. Of course, one of the options is to turn off device checking at start-up, which I usually do once I know that the system is configured correctly…that speeds up the start of the program, but there won’t be any warnings in that case.