One thing I have been meaning to ask

vbimport

#1

I noticed when I installed my PX-716A (note: A, not SA), Plextools identifies it as being a sata drive:

This is of course wrong. Its an IDE Pata drive, as you can see:

Is this typical? Any ideas why Plextools is confused, and whether it matters?

Thanks

Chip


#2

No this is not typical, the other way around (S-ATA drives being detected as P-ATA drives) is normal. But, this is the first time I’ve seen a normal ATA drive being detected as S-ATA drive, LOL :smiley: I don’t know what’s causing it but I bet it has something to do with S-ATA drivers or something. Does it matter? I wouldn’t know to be honest. If your drive performs as it should then I wouldn’t worry about it too much. Interesting problem though, let us know if you find out anything!


#3

Hehe That is different!! Like G@M3FR3@K says it’s usually the other way around. I have my IDE HDD’s set up in IDE Mode off my Promise S ATA controller and they show up as S ATA Devices and they are definately not S ATA. Could just be a Bios setting IE: IDE Devices set to S ATA vs S ATA- P ATA or good old Windows with a mind of it’s own. Like G@M3FR3@K says if everything is working OK I wouldn’t worry.:slight_smile:


#4

Thanks guys. I suspected it might be a disk driver problem, but I have tried a few different disk driver versions and it doesn’t make any difference.

Also, I doubt if its a “Windows” problem, since everything else in Windows correctly identifies the drive on the IDE channel. The problem is unique to Plextools.

And there aren’t any bios settings that could get it confused either.

So its all very odd. My hunch is that its something to do with nvidia’s nforce3 chipset and Plextools’ support (or lack of!) for it.

I wonder if anyone else here has a PX-716A hooked up to an nVidia nforce3 motherboard?

Cheers all.

Chip


#5

I just looked and mine is also displaying PX-716SA when I have a PATA. I also have a nforce3 motherboard. This doesn’t bother me though. Bottom line, I am getting awesome burns and that’s all that matters.

Chippy, how are your burns with that drive and configuration?


#6

My Brother has an MSI K8N Neo 2 Platinum Mobo NForce 3 chipset that I built for him and a Plex 716A and his shows up as an IDE device. Your Plex tools PNG lists it under SCSI device and then under that S ATA Interface so that is why it is showing up a a S ATA device and yes Plextools has some issues as it shows My Plex as Master and my three other drives as slave which is not the way my machine is set up.IE two masters two slaves.:wink:


#7

Strange, mine is a K8N Neo 2 Platinum as well. Very very odd. I wonder why your brother’s PC shows an IDE device and mine shows sata, with the same drive attached to the same motherboard.

I guess it could be down to the motherboard bios version, but that would seem very unlikely.

Still, this doesn’t really bother me. It was only idle curiosity really.

Buckeyeboy - How are my burns? Well not bad. Results fairly poor with Maxell media, but “quite good” with Taiyo Yuden 8x burned at 12x. PI errors not as low as some people here, but reasonable.

However, I only found out on Friday that my drive doesn’t read CD’s or CD-R’s at all ! I had owned it 6 weeks and not even tried a CD in it yet. (I have a Plextor Premium for CD’s). So anyway, the PX-716A has been RMA’ed. My replacement drive arrives tomorrow. I hope its not a refurb or an old TLA drive. We’ll see.

Cheers all

Chip


#8

it doesn’t show your drive as an SA but rather your interface as SATA…different things.

it has to do with the fact that the SATA controller and the IDE controller are running from the same chip on the NF3 chipset.

On-Board IDE/SATA

• An IDE controller on the nVIDIA nForce3 Ultra chipset provides IDE HDD/CD-ROM with PIO, Bus Master and Ultra DMA133/100/66 operation modes.

  • Can connect up to 4 IDE devices
    

• Supports 4 SATA ports. Transfer rate is up to 150MB/s
• NV RAID (Software)
• Supoprt up to 4 SATA & 4 ATA133 Hard drives

  • RAID 0 or 1, 0+1, JBOD is supported
    
  • RAID function work w/ATA133 + SATA H/D

#9

I don’t buy that answer for three reasons:

  1. Although its the same piece of silicon, the nForce3 controller does two specific things - controlls IDE disks and SATA disks. For Plextools to show an IDE device connected to a sata controller is just plain wrong.

  2. This is the most important part of the argument: If what you say is the cause of the problem, then why does crossq’s system not do the same? He has the same drive and the same motherboard with the same nf3 disk controller, yet Plextools gets it right with his setup. If your explanation was correct, Plextools would be wrong on his system as well.

  3. Lots of modern chipsets have integral, multi-function disk controllers. I don’t see the problem occurring everywhere else.

Thanks for your thoughts anyway. It is a wierd one, this.

Chip


#10
  1. it’s not the chip itself that determines what PT Pro shows, but rather the drivers used for the controller…i.e. the NV drivers versus the MS drivers…

  2. most likely crossg’s brother’s system is using the MS IDE drivers instead of the NV ones…hope he can let us know if that’s the case, but from what i’ve read crossg generally recommends (and thus i presume prefers and uses) the MS drivers…

  3. see my screen caps below…the 2 HDs (ID 4&5) listed under S-ATA Interface2 are both PATA/IDE HDs running off the Promise controller on my mobo which has both 2 SATA ports and a single IDE port running off the same controller chip…this holds true on my other mobo as well where it has a Promise controller with both SATA and PATA/IDE capabilities…

i’m not 110% entirely sure this is what is going on with your system, but i’m 95% sure as i’ve done my fair share of reading/research on the A64 platform and its corresponding chipsets.

edit: added screencap of the setup on my other PC which shows exactly the same thing…


#11

Fair comment - it could be a quirk of the nVidia drivers.

Although to blame the nVidia drivers exclusively would be a little harsh: Other programs manage to correctly interpret the architecture, whereas Plextools does not. So Plextools is at least partly complicit in the problem.

Cheers

Chip


#12

have you used the MS IDE drivers instead of the NV ones? if so, it still shows the same thing??


#13

I used the MS drivers previously but at the time I never checked with Plextools to see how it looked. Basically, I never noticed.

The problem with the MS drivers is that they are essentially old nVidia drivers. They are authored by nVidia anyway, but they are just old. The genuine nVidia drivers are much better in terms of disk throughput, lower CPU utilization etc. So I prefer to use them.

There was a time when the nVidia drivers caused problems with some CD and DVD writers, so lots of people prefered to stay with the MS drivers. But as far as I can tell that time has passed - the nVidia drivers are just plain better.

BTW - I have tried different nVidia driver versions and none of them make any difference.

I could try swapping back to test the MS drivers, but to be honest I really don’t want to go messing with my (perfecly working) system like that, just to prove a silly point. Like I said, the Plextools “problem” is only mildy annoying and it really doesn’t matter at all.

If anyone is using nForce3 with MS drivers and a PX716 though - it would be interesting to see how things look in Plextools.

Thanks

Chip