On The Fly Feature

Okay, I actually have two questions about clone 3.8 and above or any of them that have the “On the fly” feature. I have been trying to use the “On the fly” feature now for quite some time. I have actually (on other peoples advice) changed out processors, motherboards, an SD to DDR Ram swap and burners (from Plextor to Yamaha to HP to Sony) to try and make this program work. I have also tried 98, 2000,ME and XP. Nothing seems to make the “On the fly” feature work. I have asked many people and apparently I am alone on this unique problem. When I try to use “On the fly” and go from one plextor to the other without saving to hard drive first, it’s starts to copy fine but then my buffers start to drop. From 100% to 97 then to 89 and so forth and so on until it finally hits the RED and then presents an error and stops the burn. Like I said…some people tell me it’s the operating system so I’ve tried changing that and burners but it seems to do no good. I’ll post the other question after someone helps me with this. Thanks

Why would you want to copy on the fly? It only takes 5 minutes to burn a CD through the HDD anyway. On the fly only worked for me with my old 8x on a fast system or from a virtual drive.

Well, mainly because I back-up all my CDG’s and sometimes that’s 20 or 30 CDG’s at a time. I have a plextor 40/12/40 and also a plextor 16/10/40. It takes roughly 7 to 8 minutes reading 40X to get the image into the harddrive and then another 7 to burn it back to disk. That’s roughly 14 to 15 minutes for one CDG. The “On The Fly” feature can do it in like 6 to 7 minutes for a completed burn. When you have that many disks to back-up, that extra 7 to 8 minutes means a lot time wise. Several more hours. So the “On The Fly” feature would be much faster. Has anyone in here been able to make the “On the fly” feature work?

off topic;

why do you still use 3.8, instead of updating to the latest version??

Actually, I do have both 3.8 and also 4.0. I’m with a few other people that I don’t really like the way 4.0 is set up. It doesn’t give you certain options like decideing whether or not to copy using subchannel audio or data like the other versions do. But, I did have 4.0 installed for a while and it made no difference. The “On the fly” feature of the newer versions does the same thing. It starts out fine and then the buffers start dropping. I’m sure I can’t be the only one experiencing this. There has to be others.

ccd4 does have these options, they are just less obvious.
right click on a profile to edit it (or make a new one), or right click on the writer (in read/write select profile screen) to set global settings.

Even so I have still tried with clone 4.0 to copy “On the fly” and have the same problems with the buffers. Like I said before…I seem to be the only person encountering these problems and it’s really strange considering I have changed out my entire computer like 4 times now and still have the same buffer drop problems…

Mustang,

I have used on the fly copying with v4 succesfully, between any two of my DVD/CDRs : Pioneer DVD115, LG GCE-8320B, LG GCE-8480B, and/or LG CED 8080B. But to achieve this, you need :

1) Source should be faster spec than destination, or enough buffer should be dimensioned as to avoid buffer underruns. Note that if destination has a properly working burnproof or justlink or similar, then the risk is just to have a less quality burn, but not a coaster.
  1. Source and destination drives should be in different IDE channels.

  2. Don’t try to copy copy protected CDs ‘on the fly’. sector read Errors and recovery procedures are very likely to mess up the IDE transfers to/from the destination drive.

  3. Try to avoid using your system (at least until you are sure the process works) heavily during copies, specially such ‘activities’ or programs that make your PC lose responsiveness for several seconds (such as the usual winmodem dialing).

All this said, I am able to do ‘on the fly’ copying 99% of times, just by having dedicated IDE channels, and dimensioning a very big clonecd buffer (60Mb), so that I can see before the destination drive is even touched whether the source drive has too many errors or is being read at insufficient speed. All in all, very convenient.

Hope this helps
Regards
FTC

Thanks FTC…I’ve tried everything else so I will try this as well. I always read from my Plextor 16/10/40 at 40x and then I write with my 40/12/40 at 12X. I went into the settings screen and changed my buffer settings to the max on each one…the main buffers original settings were at 16.8 and the buffer underrun was set at 8.53. I max both of those out and did a burn. The buffers dropped slower than before but did still drop. I did notice that even at a read of 40X and a write of 12X, it read a lot slower than usual…burn time went from 7 minutes for a completed disk to like 12 minutes. But, like I said…the buffers did still drop. Slower but they did drop. When you burn on the fly, do your buffers stay at 100%? Or do they drop some or what? Thanks

@Mustangt93

Send a PM to PaRaDoX and ask about it. He is an OTF guru. He’ll need to know OS, mobo chipset model & driver versions, CPU, rig config, media used, optical brands, models and FW Revs at a minimum.

Mustang,

Of all I said, probably the most important thing is to have both drives on separate IDE channels… How is your setup?

Regarding my buffer behaviour, if reads happen faster than writes (which is the ‘normal thing’) , clonecd buffer remains at 100% till almost the end. Only times where I can see buffers dropping are :

  • Because I am reading from my 32x->40x drive and writing to my 48x CDRW… In this case normally my big buffer saves me because by the time it drops to 30% or so, the burn is already finished.

  • Or because of copy protection or damaged source CD, the read drive slows down…

Regards
FTC

Silly question, but…do you have a different proggie you can try? I’ve been using on-the-fly copying for years, both audio and data, using EZCD originallyand now Nero, with no particular problems.

It’s generally considered that the read speed should be at least twice the write speed (I don’t think you mention what speeds you’re using?). In my case, reading audio at 23x and writing at 12x is fine, writing at 16x and buffer under-run starts kicking in, writing any faster slows the whole thing down abysmally!
Data is a lot faster, but I always stick to the 2:1 ratio, just in case.

I haven’t tried Clone for on-the-fly (never really needed to, I guess), but I would have expected it to work, Clone being the excellent proggie that it is.

Fyi, I tried using Clone on-the-fly last night - LTD-165H reader, 32123s/40125s (xsu1) writer.
2mins. 50 secs. for 650mb.
3mins. 15 secs. for 648mb. using Nero.

Cheers.