Olli: CD-Text Problem

vbimport

#1

Olli, maybe you can test this yourself, if you have an UltraPlex 40max.

Some time ago, I copied the Gladiator Soundtrack with EAC, and added CD-Text to it.
Then I read this copy with my UltraPlex 40max and CloneCD 4b21. The CD-Text is recognized and will be copied.
I burnt this image with my PlexWriter 12/10/32S in DAO-RAW mode to CD-RW. On this CD, the CD-Text is still there, but my UltraPlex can't read the CD-Text anymore. Reading with my burner or Toshiba DVD SD-M1402 is no problem. Tested with CDRWIN, EAC and CloneCD.

Any idea ?

PS.: I thought, the CD-Text is contained in the subs. But why an entry is needed in the CCD file then?
Could you document all the CCD entries please or is there any information source to learn something about it ?

Many thanx in advance ...


#2

Look here and search in the mmc-2 specifications for the read-toc command. The output from this command is almost completely the same as the entries in the .CCD file. Also the specification of q-subchannels in ecma-130 (yellow book) will give you clues.

BTW If I remember correctly, there is something special about cd-text/subchannels and the Ultraplex 40ts… don’t know what it is exactly. I do know that sometimes my own Ultraplex also doesn’t read the cd-text all the time… have to do some more research on it.

:smiley:

Edit:

Also in this thread there is some info from Olli on subchannel reading!


#3

Many thanx for the great info, Upp3rd0G.

To give you remembering assistance ;-):

The UltraPlex is known to have probs reading subs from DATA Tracks (some sectors cannot be read). But ONLY if the CD is SecuROM protected. PSX Libcrypt (which uses sub, too) doesn’t affect reading. Maybe a firmware bug.


#4

Originally posted by little-endian
The UltraPlex is known to have probs reading subs from DATA Tracks (some sectors cannot be read). But ONLY if the CD is SecuROM protected. PSX Libcrypt (which uses sub, too) doesn’t affect reading. Maybe a firmware bug.

Interesting… where did you find this information?

:slight_smile:


#5

Very simple: I’ve tried it out ;-).
And this issue has been discussed @ the CloneClinic forum.

Maybe you can reproduce this error yourself (I think, you own a UltraPlex, don’t you?).
If a CD (original or DAO-RAW copy, it doesn’t matter) is SecuROM protected and you turn on subchannel reading from DATA Tracks, then some sectors cannot be read. If you turn subs off, then everything is just fine, but you don’t get the subchannels, of course :-(. You can try this out with CloneCD, BlindRead and CDRWIN (read the DATA Track as CD+G). Always the same error occurs. I’ve contacted Plextor and asked them, why the plex can’t read the subs properly. They replied that ALL Plextor drives are FULL MMC compatible and it would be the fault of the software used if they don’t read this. I don’t think so.

Allegedly there are some VERY lucky people (CloneClinic), who don’t have this problems with their UltraPlex. Strange.


#6

hmmm tried it out with my forsaken (securom old) cd in my ultraplex40. when i included subs i got read-errors from 41034 to 44493. without subs i got the same errors. but the disc is in perfect state, no scratches.


#7

Here are the results from Gunman if you’re interested …

I 1:08:36 AM Starting copy from PLEXTOR CD-ROM PX-40TS to C:\Gunman.ccd
I 1:08:36 AM Read Speed for Data Tracks: Maximum
I 1:08:36 AM Read Speed for Audio Tracks: Maximum
I 1:08:36 AM Read SubChannel Data from Data Tracks: Yes
I 1:08:36 AM Read SubChannel Data from Audio Tracks: Yes
I 1:08:36 AM Fast Error Skip: Yes
I 1:08:36 AM Don’t report read errors: No
I 1:08:36 AM Intelligent Bad Sector Scanner: No
I 1:08:36 AM CD contains CD-Text: No
I 1:08:40 AM Reading Track 1… (Blocks 0-219752)
W 1:08:41 AM If you don’t expect read errors on this CD, disable “Fast Error Skip”!
W 1:08:41 AM Failed to read Sector 0
W 1:08:43 AM Failed to read Sector 1
W 1:08:43 AM Failed to read Sector 9
W 1:08:44 AM Failed to read Sector 10
W 1:08:45 AM Failed to read Sector 11
W 1:09:05 AM Failed to read Sector 5001
W 1:09:07 AM Failed to read Sector 5002
W 1:09:08 AM Failed to read Sector 5010
W 1:09:09 AM Failed to read Sector 5011
W 1:09:10 AM Failed to read Sector 5012
W 1:09:21 AM Failed to read Sector 7370
W 1:09:22 AM Failed to read Sector 7371
W 1:09:23 AM Failed to read Sector 7379
W 1:09:24 AM Failed to read Sector 7380
W 1:09:25 AM Failed to read Sector 7381
W 1:09:29 AM Failed to read Sector 8101
W 1:09:30 AM Failed to read Sector 8102
W 1:09:31 AM Failed to read Sector 8110
W 1:09:32 AM Failed to read Sector 8111
W 1:09:33 AM Failed to read Sector 8112
W 1:09:39 AM Failed to read Sector 9173
W 1:09:40 AM Failed to read Sector 9174
W 1:09:41 AM Failed to read Sector 9182
W 1:09:42 AM Failed to read Sector 9183
W 1:09:43 AM Failed to read Sector 9184
W 1:09:45 AM Failed to read Sector 9430
W 1:09:46 AM Failed to read Sector 9431
W 1:09:47 AM Failed to read Sector 9439
W 1:09:48 AM Failed to read Sector 9440
W 1:09:49 AM Failed to read Sector 9441
W 1:09:57 AM Failed to read Sector 11195
W 1:09:58 AM Failed to read Sector 11196
W 1:09:59 AM Failed to read Sector 11204
W 1:10:00 AM Failed to read Sector 11205
W 1:10:01 AM Failed to read Sector 11206
W 1:10:05 AM Failed to read Sector 12000
W 1:10:06 AM Failed to read Sector 12001
W 1:10:07 AM Failed to read Sector 12009
W 1:10:08 AM Failed to read Sector 12010
W 1:10:09 AM Failed to read Sector 12011
W 1:10:10 AM Failed to read Sector 12058
W 1:10:11 AM Failed to read Sector 12059
W 1:10:12 AM Failed to read Sector 12067
W 1:10:13 AM Failed to read Sector 12068
W 1:10:14 AM Failed to read Sector 12069
W 1:10:22 AM Failed to read Sector 14060
W 1:10:23 AM Failed to read Sector 14061
W 1:10:24 AM Failed to read Sector 14069
W 1:10:25 AM Failed to read Sector 14070
W 1:10:26 AM Failed to read Sector 14071
W 1:10:31 AM Failed to read Sector 14986
W 1:10:32 AM Failed to read Sector 14987
W 1:10:33 AM Failed to read Sector 14995
W 1:10:34 AM Failed to read Sector 14996
W 1:10:35 AM Failed to read Sector 14997
I 1:21:57 AM Reading Track 2… (Blocks 219752-221716)
I 1:22:03 AM INDEX 0 Track 3 LBA 221567!
I 1:22:03 AM Reading Track 3… (Blocks 221716-224518)
I 1:22:12 AM INDEX 0 Track 4 LBA 224369!
I 1:22:13 AM Reading Track 4… (Blocks 224518-229371)
I 1:22:28 AM INDEX 0 Track 5 LBA 229222!
I 1:22:29 AM Reading Track 5… (Blocks 229371-235353)
I 1:22:48 AM INDEX 0 Track 6 LBA 235204!
I 1:22:49 AM Reading Track 6… (Blocks 235353-239468)
I 1:23:02 AM INDEX 0 Track 7 LBA 239319!
I 1:23:02 AM Reading Track 7… (Blocks 239468-241911)
I 1:23:10 AM INDEX 0 Track 8 LBA 241762!
I 1:23:11 AM Reading Track 8… (Blocks 241911-254282)
I 1:23:51 AM INDEX 0 Track 9 LBA 254133!
I 1:23:52 AM Reading Track 9… (Blocks 254282-260111)
I 1:24:11 AM INDEX 0 Track 10 LBA 259962!
I 1:24:11 AM Reading Track 10… (Blocks 260111-264605)
I 1:24:25 AM INDEX 0 Track 11 LBA 264456!
I 1:24:26 AM Reading Track 11… (Blocks 264605-269944)
I 1:24:43 AM INDEX 0 Track 12 LBA 269795!
I 1:24:44 AM Reading Track 12… (Blocks 269944-286295)
I 1:25:38 AM Duration of operation: 00:17:01
I 1:25:38 AM Average Speed: 658 kBytes/s (3.74)
I 1:25:38 AM Reading finished!

Although, FES is enabled, the Plex spins down to its lowest read speed.


#8

Originally posted by little-endian

Although, FES is enabled, the Plex spins down to its lowest read speed.

jep, same goes for me and forsaken. damn, i think i should mail the belgians :slight_smile:


#9

Originally posted by little-endian
Here are the results from Gunman if you’re interested …Although, FES is enabled, the Plex spins down to its lowest read speed.
That read looks very suspicious - what version of CloneCD? Gunman is prot by SecuROM new and has no errors and my disc is not data & audio (Cossacks has a read log like the one above).

Enabling FES, when not required, from Beta 9 (could be 14…)onwards will report errors in the log when there are, in fact, none. I had the same problem with MotoRacer 3; enable FES and you get phantom errors, switch it off or leave on auto and you get no errors. Images are the same and both will work in D-Tools.

Tip, leave FES on auto :wink:


#10

@FutureProof

I tried it with CCD v4b21.
I selected auto for FES, but it doesn’t make any difference.
A long time ago I read @ the elby.de page, that reading subs from DATA tracks always turns on FES on the UltraPlex.
It seems to be true.
If I deselect “read subchannel … DATA …” then no errors occur.

The read subchannels seem to be bad, too.

I’ve tested to read the whole CD with subs, ignoring the errors.
Then I read the CD again, but without the subs to get a “good” main-channel IMG-file. Then I replaced the IMG containing the errors with the error-free version and recorded this on CD.

But the copy doesn’t work :-[

PS: It’s the US-Version of Gunman Chronicles, I think.


#11

Yep

Reading Subchannel Data from Data Tracks with Plextor CD-ROMs, Sony CD-ROMs, Sony CD-Writers CR-X120E, CR-X140E/S, CR-X145E/S, CR.X160E, Hewlett Packard CD-Writers 8200i, 8210i, 9100i, 9110i, 9200i, 9210i, 9300i, 9310i, 9500i, 9600i will always enable Fast Error Skip, too. You might need to reduce the read speed for reliable results!