Old PC, new hard drive, IDE controller, help!

Hi, I recently bought a new hard drive, Western Digital parallel ATA,
80GB (WDD800) and tried to install on my pretty outdated PC (Pentium 3
500Mhz, 128MB RAM)
I am installing this new hard drive as the only hard drive in my PC as
my case is small and can’t fit 2 hard drives, so I took out my old
hard drive.

It turns out that my motherboard does not recognise this new drive
which is understandable the motherboard is old.

I checked out a few options to work around this. 1. I could flash my
BIOS, but the motherboard company hasn’t put out a new version and I
am too chicken to flash it antway. 2. I read an article on
PCWorld.co.nz (somewhere I can’t remember) that the easiest solution
is to install an IDE controller.

So I did. I bought “Silicon Image SiI0680 Ultra 133 Medley ATA RAID
controller” Installation took a while but I got there and got Windows
XP installed.
But here remains a problem I still can’t solve, hopefully one of you
computer geniuses can help.

On booting, the BIOS correctly shows that my primary master and slave
are empty (primary master was where I hooked up my old hard drive
which I now disconnect) and my secondary master occupied by a CD
writer. Then the controller kicks in telling me my new hard drive is
installed on it. But then a message “Disk Boot Failure” comes up and I
can’t boot. This occurs when I set boot sequence to “C - CDROM - A”
But interestingly, when I set the sequence to “CDROM - C - A” and I
leave my Windows XP disk in the CDROM, when it gets to booting, it
asks me to press any button to boot from CDROM, when I ignore this to
prevent booting from the CD, viola, Windows XP boots from my new hard
drive.

Can anyone tell me how I can get around this? I don’t when to have to
leave my Windows XP disk in there everytime I boot up.

Thanks

Try SCSI->x->y boot order. In most BIOS SCSI is meant not as SCSI but as off-board controller.

If that doesnt work,maybe the drive bootblock was not installed, dunno why, but could happen.

Your system is too old!

What maibnoard do you have?
Maybe someone knows a workaround or a place where a newer firmware exists.
Yes try SCSI->x->x as stated above, it might work… good luck!!!

Many Pentium 3 systems will recognize an 80GB drive with a BIOS update to the mainboard. I would suggest checking the manufacturer’s website for the latest BIOS update before you do anything else. The system I built for my wife has a Tualatin-core Celeron 1GHz chip, and its mainboard supports the 40GB disk I put in just fine. My father-in-law’s Gateway P3-450MHz supports the 80GB hard disk I put in it just fine.

What is the make/model of the system board? Some manufacturers made beta BIOSes that weren’t as widely available on their support website but could be found via FTP. I certainly wouldn’t be too chicken to do something that solves your problem without a lot of effort.

Thanks for your suggestion, but I tried that as well and doesn’t seem to work.

What is a “drive bootblock” and how do I get it?

AND
My motherboard is by “microstar”
MS-6163
and i have downloaded its live update software which tells me that my BIOS version is the most up-to-date available

The live updater is very unrelaible, i suggest you grab the latest BIOS and do it off a bootup disk, if that works, you no longer need to deal with the nonsense of a PCI controller card and all these issues.

ModelVersionSizePlatformBIOSBIOS DateCounterMS-6163FC(MS-6163FC)v. 2.0163 kbIntelAward BIOS5/1/20006789

Bootblock/MBR is the the disk sector the BIOS looks at to determine partition info, and to know where to jump next to start the real boot process. Sounds like your drive either doesnt have one or the BIOS cant see/use it. The reason the CD hack works is that the BIOS boots the PC from the CDROM bootblock, XP boot recognizes the installed system and jumps to it.

BTW, the SCSI->x->y sequence only woks IF the offboard controller is set to ALLOW bootable devices. If, for some reason your PCI controller doesnt support bootable devices, the SCSI->x->y thing will not do any good.