Oem liteon SHW-160H6S only burns CDs

I recently installed the lightscribe HSI so I could burn some LS labels, and was kind of disappointed when it didn’t work. I was more disappointed when I found out I could no longer burn DVD media!

Everything fouled up and the only burns I could get were by generating ISOs with Nero and then burning those with ImgBurn, and ONLY on CDRs. Anytime I try burning a DVD, the prog freezes while “setting read speed.”

I have:
OEM SHW-160H6S (CompUSA DRW-6S160H CSG4)
Windows 2000 SP4
Nero 7.8.5, ImgBurn 2.3.2, LS 1.6.45.1

I have tried:

[ul]
[li]Disabling LS service (No uninstall utility provided, does not appear in Add/Remove Programs)
[/li][li]Completely uninstalling Nero using all cleaning tools provided
[/li][li]Reinstalling Nero
[/li][li]Crossflashing OEM CSG4 firmware with LiteOn CS08 using CodeGuys FlashFix utility (without success)
[/li][/ul]

Excerpt from the nero log (attached):

11:51:32 PM #15 SPTI -500 File SCSIPassThrough.cpp, Line 179
CdRom0: SCSIStatus(x00) WinError(21) NeroError(-500)
Sense Key: 0x00 (KEY_NO_SENSE)
Sense Code: 0x00
Sense Qual: 0x00
CDB Data: 0x5A 00 05 00 00 00 00 00 48 00
Sense Area: 0x00 00 00 00 00 00 00 00 00 00 00 00 00
Buffer x05ecee80: Len x48

11:51:32 PM #16 CDR -500 File ThreadedTransferInterface.cpp, Line 1576
SCSI command aborted
H: DVDRW DRW-6S160H

11:53:12 PM #17 Text 0 File ThreadedTransfer.cpp, Line 269
Pipe memory size 74390400

11:53:12 PM #18 Phase 38 File dlgbrnst.cpp, Line 1762
Burn process failed at 16x (22,160 KB/s)

Ideas?

[U][B]update[/B][/U]

Using prog called devfilter, I learned that there are no upper or lower filter drivers loaded for the drive, as seen below:


Filter Driver Load Order http://www.bustrace.com

Upper Filter Drivers: No Upper Filter Drivers specified for this device.
Device Object: DVDRW DRW-6S160H SCSI CdRom Device
Lower Filter Drivers: No Lower Filter Drivers specified for this device


If I’m not mistaken, shouldn’t I see some form of ASPI and/or STPI in either or both of the upper/lower filters?

I used ForceASPI 1.7, and the ASPICheck reports all good, seen below.

 LOG0143: *****************************************************************
 LOG0144: Starting ASPICHECK installer on Mon Jun 04 22:28:16 2007

ASPICHK0438: OS = Windows NT (5.00.2195)
UPGRADE1004: c:\winnt\system32\wnaspi32.dll dated 09/10/1999 22:06:00, 45056 bytes.
UPGRADE1062: c:\winnt\system32\wnaspi32.dll version 4.6.0.1021
UPGRADE1004: c:\winnt\system\winaspi.dll dated 09/10/1999 22:06:00, 5600 bytes.
UPGRADE1062: c:\winnt\system\winaspi.dll version 4.6.0.1021
UPGRADE1004: c:\winnt\system32\drivers\aspi32.sys dated 09/10/1999 22:06:00, 25244 bytes.
UPGRADE1062: c:\winnt\system32\drivers\aspi32.sys version 4.6.0.1021
UPGRADE1004: c:\winnt\system\wowpost.exe dated 09/10/1999 22:06:00, 4672 bytes.
UPGRADE1062: c:\winnt\system\wowpost.exe version 4.6.0.1021
ASPICHK0582: ASPI is properly installed and is fully operational. A total of 4 host adapters have been detected.
LOG0218: Closing installer log on Mon Jun 04 22:28:17 2007
LOG0219: *****************************************************************

After doing so, got identical results in devfilter. Also, using KProbe2 I can only select SPTI driver, ASPI is grayed out.

Seeing as the drive and the software are not communicating (from what I can gather in the Nero log), is this a driver problem? I’m kind of lost from here…

Hi,

According to the data you provided, it seems to be connected to a 3rd party IDE controller that is run with drivers from the manufacturer.
From your log, it is attached to a VIA SATA controller. Make sure the latest VIA Hyperion Pro drivers (Ver 5.12a) are properly installed. Also, the controller should be set to “SATA only” (not RAID) in BIOS setup.

This problem is not related to upper/lower filters (these should be removed in case of trouble), and it is not related to Aspi. Aspi is totally useless for drives, that are connected to 3rd party controllers.

Michael

Thanks for reading mciahel. The hard drives are controlled by a PCI IDE controller (SIIG 0680 ATA/133). The DVD drive is not on a SATA controller, it is connected to the motherboard IDE controller (VIA Busmaster Ultra ATA) which is using the most recent drivers available.

The same IDE configuration has worked on this machine in the past. This is a fresh install of W2K, all was good until I installed the lightscribe utility.

Connect to another system to see if problem persists. If it does, then the DVD laser is probably dead.

Hi,

Switch them to MS default drivers anyway, at least in order to sort out any driver related issues.
I am also running W2kSP4 on a Via based system. Using MS default IDE drivers, and no problems with my optical drives attached there.

Michael

mciahel, someday in the far-away future some wierdo stranger is going to come up to you in the middle of the street and plant a big, fat, kiss on your cheek. They’ll buy you a beer and start telling the entire pub what a great guy you are until everyone else gets sick of hearing it. Eventually you’re going to ask the stranger, “so who are you anyway?” I’ll respond “Remember when you helped out that guyin808 with his stewpid driver problem?”

I guess you could say it worked…

Yo-

Kewl ending-eh!!! :iagree: :iagree:

Great post, and as Mike said, a “kewl” ending :bigsmile:

It only gets better - I was then able to cross flash the firmware and make it a true-blue LiteOn drive with HyperTuning and OverSpeed enabled. I’m not one of you disc burning experts, but I’m pretty sure I can feel good about results like this:

This drive has never worked so smooth. PLUS, I reinstalled LightScribe service and finally burned my first cover!

Life is good…

You can do Disc Quality scans too :bigsmile:

mciahel, how does one switch to Windows default IDE drivers? I suppose you uninstall the Via drivers, but how are the Windows drivers installed? I’m curious because I have a NEC 3520 that won’t read burned -R media and wonder if using Windows IDE drivers might help that problem too.

Hi,

Uninstalling (and reinstalling without IDE option after rebooting) Via drivers is one method. Windows default drivers are automagically installed after the first reboot.

The other method is using the “update driver” function in device manager:
Run device manager and select your Via IDE controller within the “IDE ATA/ATAPI controller” tree. Double click on that entry and select the driver tab. Click on “update drivers” and then select “show all known drivers and let me choose” option. Selecting “VIA Bus Master IDE controller” should be the correct choice there. “Standard Dual Channel PCI IDE controller” is not necessary.

The third option might be just uninstalling the controller within device manager and rebooting.

Please not, this is only valid for PATA drives. For SATA drives, VIA IDE/SATA drivers must be installed. But there is no problem running the PATA part with MS default drivers and the SATA drives with VIA drivers. If I remember correctly, this combination is set by VIA’s driver setup automagically.

Michael

Hi,

Nice way to say “Thanks” :slight_smile: :slight_smile: The beer is okay, but you should reconsider the kiss as I am married :smiley:

Fine you are up and running :slight_smile: Have fun with your drive!

Michael

Sorry Michael, the kiss stays - a wet, sloppy one! Not so much for the driver problem, but because you taught me a new super-awesome word, “automagically.”

Now that my system is PERFECT, I’m imaging the drive and never installing/uninstalling anything ever again. Except for | see this post |