Odd error on certain disks

vbimport

#1

First, I am using the most recent versions of CloneDVD (2.8.5.1) and AnyDVD (5.4.1.1), as of this writing (just in case you were going to ask). :slight_smile:

I’ve included a screenshot of the error I get. So far this has only happened on a certain series of disks–the Bob Hope/Bing Crosby “Road” movies (i.e. “Road to Morocco”, “Road to Zanzibar”, etc.)

I am able to rip the disks just fine, when I use DVD Decrypter, and then transcode and burn using either Clone DVD or Shrink. But no matter what DVD drive I use (I have 5), Clone DVD complains that it can’t find VIDEO_TS. Obviously, it’s finding something, as you can see in the right pane of the screenshot, and the VIDEO_TS directory is clearly visible in Clone’s file selection window. But if I go thru all the setup screens and try to rip and burn, I get the “Oh no!” error. So something’s wrong.

Since the bitrate on the “Road” movies isn’t that high, I get a good video out of it, but I want to know what’s causing this error, just in case I run into it on a movie that I don’t want to compress.

I did try a very recent movie (Sin City), and Clone DVD was able to read it just fine. It just seems to be this one particular series, and I’d like to find out what’s “special” about them.

They do have one of those obnoxious players that tries to install itself on insert, on the DVDs, but I’ve had other DVDs that have also had this, and they rip and burn just fine. So can anyone give me some insight into what might be causing this?


#2

A follow-up: I thought maybe a screenshot of the problem disk’s root directory structure might help, just in case it is using some applet that has caused problems in the past.

Anyway, here’s the shot of the disk’s root directory:



#3

Why do you rip the movies with DVD Decrypter? You don’t need it, you can copy the movies with AnyDVD and CloneDVD directly.


#4

Yes, thank you, I am aware that there are several ways to copy the files off a DVD, including–if I remember correctly–just using AnyDVD and Windows Explorer. I used DVDD because it performs certain checks of the DVD file structure–and because I simply wanted to see if another ripping program was having the same trouble as CloneDVD. It was not.


#5

But I don’t want to get off-track here by “why don’t you do it this way?” questions. I want to get back to my original questions, which are:

  1. What does this error mean?
  2. Why is it happening only w/these certain disks?
  3. Why does CloneDVD say it can’t see the VIDEO_TS directory, when it is obviously there? (And other rippers can see it and rip it?)

Olli, if you are around, I’d be grateful if you could check in on this one.


#6

No doubt Olli will get onto this; in the meantime you’ll note that there is no AUDIO_TS folder - many are empty anyway but early on, a combination of drives and players led Elby to add one to the rip…maybe a bug in the “latest version”? Dunno.

Still, the problem is in title configuration, so - just speculating - the disc structure is screwed (like many cheap porno discs). It would be interesting to know how many ‘broken structure’ fixes have been put into CloneDVD. LOL

As an aside, LIGHTNING UK and Olli have collaborated on a few things…some sort of “time remaining” count if I recall


#7

Hi FutureProof,

CloneDVD always adds an Audio_TS folder to the copied DVD. As far as I can recall this has been the case since version 2.0.x.x.

@ HLMencken: Does Shrink process and “burn” the movie (e.g. creates iso) you ripped with DVDD?


#8

This problem has been reported several times. It is NOT a bug in CloneDVD, it is a bug in some file system add on / additional tool on your computer.
It happens with certain DVDs which have additional directories beside the VIDEO_TS folder.
Current workaround: Drag’n’drop the VIDEO_TS folder to your harddisk with AnyDVD running and use CloneDVD from there.

You can search the forum for “directory not” if you like, to find other posts.
Or try to find the guilty program which is interfering (virus scanner? other background tool? google desktop search?..)


#9

Well “always” and “since version 2.0.x.x.” are mutually exclusive; however, I was just commenting and you are correct.

Sorry to be in-the-dark here, but has Olli stated that it’s not a bug? If it has been reported several times (how long has this been going on?), where’s the fix?

btw, to “Drag’n’drop the VIDEO_TS folder to your harddisk with AnyDVD running and use CloneDVD from there…” is always preferable if you have the CPU grunt & space :clap:


#10

I’m trying to recall just exactly how I resolved this issue (it was several days ago, and the ol’ short-term memory ain’t so good any more.) :wink:

I believe–since it was a 2-layer original DVD that I wanted to compress down to a single-layer blank–I used DVDD in File mode to rip the files, then used CloneDVD to transcode and burn. I like Clone’s transcoder speed, so I prefer to use it whenever possible.

I know that doesn’t quite answer your question the way you asked it, but I ran into another CloneDVD error on a different disk–“Those Magnificent Men in Their Flying Machines” (yes, I’m an old-movie buff). Tried twice; Clone ripped to 99%, then threw an error (which I should have saved, dumb me). It was something like TCE1 or TCE0, but I can’t rightly recall.

Anyway, the way I resolved this one was to rip in File mode w/DVDD, then transcode and burn w/Nero Recode (latest version). Everything went fine. This sort of answers your question, since Recode is basically Shrink in a new wrapper.

I’m certainly not going to dis Clone for these errors–my assumption (correct me if I’m wrong) is that Clone is much more thorough in examining DVD file structures and hunting for problems, than are other programs, which may be why it seems to find more errors.


#11

I’ve been wondering about this… I remember reading that AnyDVD could do this, when I was looking at it to purchase several months ago. The reason I haven’t tried this yet–so maybe you all can clear this up for me–is that I thought when rippers like DVDD, or Clone when it’s ripping, did some preliminary file/structure checking of the source DVD and made corrections? Also, I thought transferring the files via a ripper rebuilt the file structure on hard disk?

I’m guessing, from what you’re saying, that I’m wrong on both counts? That simply dragging the VIDEO_TS folder to my HD while running AnyDVD, then running Clone or Recode or Shrink, etc., to burn, fixes any file/structure problems, and rebuilds the file structure to match the target (blank) disk?

This will be good to know, as I do indeed have the CPU grunt and space. :slight_smile:


#12

I’ll certainly try the workaround. I’ll still wonder what it was about that particular disk, as Clone has ripped and burned other disks that have additional directories besides the VIDEO_TS folder just fine. I’ll also wonder why the “some file system add on / additional tool on your computer” doesn’t interfere w/any other ripping/burning programs I have–i.e. why does it do that to Clone, and not any other ones? (Not trying to be a wise-guy, just trying to understand how Clone does its thing.)

I very much appreciate the info.


#13

I went back thru the old posts as Tru suggested (yes, I’m an idiot for not doing that first), and found that Olli has commented that he can’t reproduce this error. He also asked for system info and specific info on what DVD(s) are causing this problem.

The DVD was the old Bob Hope/Bing Crosby film, “The Road to Zanzibar”, NTSC, Region 1.

I don’t have any packet-writing software installed (i.e. like InCD, etc.). I do run Norton AV 2005 w/all updates, and ZoneAlarm Pro latest version (which now has a spyware component installed, but I did get this error on disks before ZAP had that component). I don’t have any other AV/spyware/firewall progs running. The only other item sitting in my system tray that Olli might be interested in is Norton Ghost, but it isn’t physically running when I’m doing a rip/burn (i.e. not in the process of making an image). Tho I have other rip/burn programs installed (DVDD, Shrink, Nero Suite), they are not running when this error occurs.

It’s interesting that AnyDVD identifies the DVD as a data DVD, no doubt because of that funky DVD player that tries to install itself. I don’t know if that could have any bearing, but as I said before, I’ve successfully used AnyDVD/CloneDVD to rip and burn disks that also have such “data” directories on them. And again, the other rip/burn programs I use don’t have this problem at all.

Anyway, Olli, if you are around, I hope this helps you narrow down this issue. And please let me know if I can provide any other system info that could help you fix this.


#14

Can you try to disable Norton AV? Does the error go away?

Easy explanation: CloneDVD uses the Windows FileSystem to read from the source disc. Other programs (like Shrink) read sector by sector directly from the hardware.
Some tools like Norton AV want to scan files, so they hook the filesystem. Other programs which read directly from the hardware will not be affected by Norton & Co.


#15

Ahh… that is interesting (Clone using the Win file system). Next time I run into a problem disk, I’ll disable NAV and see what happens.

What I’m still curious about–and don’t know if you are able to answer at this point–is why just these certain disks? Many disks have data files on them (the useless players and such), but Clone doesn’t have trouble w/all of them–just the few I mentioned. (Not trying to be a pest, just trying to understand the workings under the hood.)

Is there some advantage to Clone using the Win file system, as opposed to the Shrink method of reading sectors directly?

BTW, what’s happened to Olli?


#16

Dunno. You have to ask that NAV or whoever is causing the problem.

Yes and no… Yes, because it is portable (CloneDVD for Mac already exists, maybe a Linux version?). The code is always the same regardless where you read the source files from (CD/DVD/Harddisk). For example Shrink or Recode read with the Windows File System from harddisk, but sectorwise from DVD.
This is the reason, why some discs work better with Shrink, if you copy the files to harddisk first.
No, because broken 3rd party software can more easily interfere with CloneDVD. But this is not CloneDVD’s fault.