NTLDR is missing error

vbimport

#1

Ok guys, I downloaded and installed a security update from MS for Windows XP. Rebooted and got NTLDR is missing error.

Here’s what I’ve tried: Change boot order. Restore NTLDR and ntdetect.com. Repaired boot.ini. New partition boot sector. Repaired the master boot record. Did a complete restore installation of the operating system.

None of that worked. I can put the Windows XP disk in the disk drive, get a message to hit any key to boot from the cd, ignore that message and the computer boots into the operating system on the hard drive with no problems. Weird huh?

Suggestions?


#2

How about uninstalling the update?


#3

Update went away when I did the restore installation. No change.

By the way…only one operating system on this backup computer


#4

Did you run chkdisk on the HDD? Did you try a different cable on the HDD?


#5

Did not run chkdisk. Cable is the same, but everything is working perfectly well once I’m in the operating system, and from the sequence of events, am pretty sure this is software, not hardware.

I can try chkdisk…back in a minute


#6

As above about Checkdisk plus I tried a few links & a couple of them referred back to this one.


#7

I’ve had loose IDE cables do exactly what you are describing.


#8

Checkdisk did nothing to change the behavior of the computer. One of the first steps I took when diagnosing this was to look for loose cables (though I forgot to mention it). No loose cables found. I can try a new one, but believe it to be a very long shot.

Oh, tried chkdsk with the /f modifier. Any disagreement on using that?


#9

Brand new IDE cable…no change


#10

I’m out of ideas.
Ok just one more, does it use nvidia ide controller? If so install MS drivers uninstall nvidia ones.


#11

I never use the Nvidia IDE drivers, but good thought. This is an older Nforce4 939 board and has run very well for me.

I’m out of ideas too. Looks like it is time for the nuclear option of wipe and reinstall. Have to wait for another day when I’ve got more time.

Thanks to everyone for looking in and trying to help.


#12

Hey Kerry,

This is no help to you at this point, but as the saying goes…“misery loves company”.

Exact same thing happened to me a few months back with an MS update.
Drove me nuts, but not for long. I always keep a recent clone of my system hdd at the ready. I just hooked it up (esata), booted from it and cloned again with acronis TI…esata (source) —> c: (target).
All was well with my world again…:cool:
Can’t begin to tell you how many times and how much pain I avoid doing this.


#13

You might try a repair install from the setup CD. I had this type problem with Win2k for which repair install failed, and I had to restore a Ghost image to fix it. If you’re lucky, the repair install may work and will be a quicker fix if it does, but you probably have to do a new install if reapir option fails.

You may want to consider Ghost or True Image to create image to restore. I use Ghost 2003 to create image every 4 months which takes less than 10 minutes to create and to restore compared to some 10 hours plus to reinstall Windows and all apps from scratch. This way I only have 4 months at most of updates and new programs if any are added that takes so very few minutes.


#14

what update where you installing Kerry?

my automatic update notification just popped up telling me to install 12 updates. dont want to reboot and get the NTLDR is missing error.

any of these?

Microsoft Windows XP SP3
 
Cumulative Security Update for Internet Explorer 7 for Windows XP (KB953838)
 
Security Update for Windows XP (KB950974)
 
Update for Windows XP (KB951072)
 
Update for Windows XP (KB952287)
 
Cumulative Security Update for ActiveX Killbits for Windows XP (KB953839)
 
Update for Windows Media Player 11 for Windows XP (KB939683)
 
Security Update for Windows Media Player 11 for Windows XP (KB936782)
 
Update for Windows Media Format 11 SDK for Windows XP (KB929399)
 
Windows Malicious Software Removal Tool - August 2008 (KB890830)
 
Security Update for Outlook Express for Windows XP (KB951066)
 
Security Update for Windows XP (KB946648)
 
Security Update for Windows XP (KB952954)

#15

I had to install 10 updates [and added 5 other updates] today, and my computer booted fine. The list [see the attachments]:




#16

Troy, the only thing I remember was that it said Security Update for Windows XP…don’t remember the number.

But as I mentioned in the chatbox, my main computer is also running XP, and it updated with no problems at all.


#17

ok, thank you both Kerry and Albert.

troy


#18

Insert the Windows XP bootable CD into the computer. Configure bios to boot from the CD.
When prompted to press any key to boot from the CD, press any key.
Once in the Windows XP setup menu press the “R” key to repair Windows.
Log into your Windows installation by pressing the “1” key and pressing enter.
You will then be prompted for your administrator password, enter that password.
Copy the below two files to the root directory of the primary hard disk. In the below example we are copying these files from the CD-ROM drive letter “E”. This letter may be different on your computer.
copy e:\i386
tldr c:
copy e:\i386
tdetect.com c:\

Once both of these files have been successfully copied, remove the CD from the computer and reboot.

:cool::cool:


#19

Hey Platinumsword thanks for looking in on the thread, but if you’ll look at my first post, you’ll see the six steps I tried before posting this thread…#2 on the list was just what you described.

Problem has been eliminated the hard way. Decided to nuke it and put in Vista…just to play around a bit more in that operating system. My main computer is still XP Pro, with a dual boot to Vista, but I’m rarely in Vista on that machine.


#20

There is a AMD and SP3 compatibility problem with some AMD processors that occurs when if the OEM Windows XP installation is not tailored for the specific processor. I had the same error message (and more) after I installed SP3. Here is a link to the specific problem. I don’t know if this is your problem but this link will tell you if the proper registry entry is there.:

http://support.microsoft.com/kb/888372