Notice your PC's HDD/SSD Activity LED flashing constantly? MCSE guy(s) to the rescue?

vbimport

#1

I’m a new SSD owner, having now had one fail and one new (so I’m an expert :disagree:) and have been working hard to address my paranoia associated with “wearing-out” an SSD with extraneous write activity. To this end I’ve done a lot of tweaks especially creation of a RAMDisk to off-load “nuisance writes” such as Windows and AppData temp folders, Firefox and Thunderbird cache, Windows event logging, and the like. Works great.

But one thing that annoys the bloody heck out of me is my PC’s HDD activity LED pulses constantly; once per second, and it is relentless. After an appalling amount of time looking for the culprit, it turns-out it is simply Windows polling my CD/DVD drives, no doubt looking for media. I can make the pulsing LED disappear ONLY, SOLELY by disabling the drive in Windows Device Manager. Poof–problem gone. Why is it a problem? Well the LED will otherwise be a clue to me if my SSD is being accessed, but now the LED is sorta useless for that.

Questions:

  1. Does this concern any SSD owners here, and does anyone know of a better solution than disabling the drive?

  2. I have Pioneer, LG, and Liteon drives, and the Pio appears quiet vs. the others. So I assume it is a driver and/or firmware issue. Might the MCSE author know the driver/firmware workings well enough to suggest (or make) a solution to this?

I suppose the MCSE author(s) will not be interested unless they have SSDs themselves…

Anyone else bothered by this, or am I the only worrier? Please, no moron posts about unplugging the LED or putting duct tape over it–it is a useful tool (especially with an SSD since you no longer have a hdd chit-chitting when it’s accessed) and not one I want to do without.


#2

I don’t know if your running Vista but this might interest you :


#3

I have always wanted to know why my HD light was showing activity all the time. Thanks


#4

[QUOTE=G_Ivan Awfulitch;2596962]I have always wanted to know why my HD light was showing activity all the time. Thanks[/QUOTE]
I can’t begin to tell you how long it’s been that this has troubled me too, so I am glad to know finally what has been causing it.

A couple other things I’ve learned since starting this thread:

  1. The USB-based Card Reader in another PC I have also causes the flashing–have to disable the USB Mass Storage driver for it to make the blips go away

  2. There is a command line utility called DevCon (built-in to Windows) which can enable/disable devices thus can be used in a batch file/shortcut to easily switch the offending devices in-and-out

Given I don’t use the DVD drive (or the USB reader) all that often, this is the likely solution for at least a couple of my PCs.

I suspect there is nothing that can be done at the drive firmware level so my plea to driver experts (i.e. MCSE) is likely for naught. :o


#5

Was dicussed several years ago in the ODD sections.

Check out some tools linked in my sig. :wink:


#6

You’re right, I searched again (man, this one’s hard to find!) and came across at least this thread about it:

Again some of those guys said “ignore it” but it’s hard to do in view of my SSD. Very interesting chef to see DevCon in your sig! Guess that is my best option…


#7

I can imagine that it kinda hurts to see the light always on at such a deviice, I wouldnt act different than you.
Its probably down to the controller firmware and settings.


#8

Aah men, i bought an OCZ vector some days ago and i have noticed the exact same problem. Just like you, if i disable my DVD drive then the led stops flickering. Im wondering if you have found a smarter way to get rid of this or if you are still stuck at the devcon trick… (srry for posting at this point, but google brought me here)


#9

[QUOTE=Sergigs;2680545]Aah men, i bought an OCZ vector some days ago and i have noticed the exact same problem. Just like you, if i disable my DVD drive then the led stops flickering. Im wondering if you have found a smarter way to get rid of this or if you are still stuck at the devcon trick… (srry for posting at this point, but google brought me here)[/QUOTE]
I have a new Vector also and 4 DVDRW drives and none of them flicker, I doubt whether the Vector has anything to do with your issue.


#10

Dunno… i just have 1 simple reference LG DVD burner and i get the same problem than the OP: My HDD Led wont stop flickering unless i disable my DVD drive in the Windows Device Manager. It must be something wrong with the DVD drive firmware i think. Im using a very fresh W7 installation BTW. I will try with my old mechanical HDD though, but yes, it doesnt seem to be a problem with the Vector but the DVD drive itself…


#11

[QUOTE=Sergigs;2680552]Dunno… i just have 1 simple reference LG DVD burner and i get the same problem than the OP: My HDD Led wont stop flickering unless i disable my DVD drive in the Windows Device Manager. It must be something wrong with the DVD drive firmware i think. Im using a very fresh W7 installation BTW. I will try with my old mechanical HDD though, but yes, it doesnt seem to be a problem with the Vector but the DVD drive itself…[/QUOTE]
Without knowing your system specs I really cant troubleshoot this issue with you. But only 1 DVDRW drive is not hard to trouble shoot unless its in a laptop. Is it an SATA or IDE DVD drive?


#12

Ahh srry for that, my initial purpose wasnt to get insta-help here. I know it is a weird issue and i didnt want anyone to waste much of their time on it. However if you are really willing to help me:

MB: Gigabyte Z77X-D3H
Processor: Intel Core I7 3770K @ 4GHz
Graphics Card: Sapphire Radeon HD 7970 3GB DUAL-X
RAM: Corsair Vengeance XMP PC3 12800 DDR3 1600 8GB (2x4gb) CL9
DVD DRIVE: LG GH24NS95
PSU: Corsair GS800
Hard Disk: OCZ Vector SSD 256 GB
OS: Windows 7 Professional x64

It is a SATA drive. In the BIOS i use “IDE” in the “SATA MODE” option. My problem here is, like i said, that the HDD Led pulses once per second when my PC is at idle. This “flickering” stops when i disable the DVD drive (just like the OP explains). I will keep on trying different things for myself, and if you have any idea of what could be my problem, or want me to try something, give you more info about my system… whatsoever, let me know.

Thanks.


#13

The one second HDD activity flicker is a polling signal from the DVD drive.
It’s the drives way of telling the system that its still there. Some HDD’s use this as well.

You maybe able to get rid of it by switching to SATA AHCI mode, and using the Intel RST drivers. But on an existing Windows install, this is not quite as simple as changing the BIOS setting from IDE to AHCI.


#14

Yes, that was one of my initial thoughts. I switched to “IDE” mode a few days ago in a desperate attempt to fix another problem i already had, this one related with the keyboard (and…pseh, it seems to be gone). I dont remember if this flickering also happened at AHCI mode, but yeah, i will switch back to AHCI and see what happens, performing a fresh Windows installation OFC. I guess i will have to deal with the keyboard issue instead of the DVD drive…

Thanks.


#15

[QUOTE=Sergigs;2680564]Yes, that was one of my initial thoughts. I switched to “IDE” mode a few days ago in a desperate attempt to fix another problem i already had, this one related with the keyboard (and…pseh, it seems to be gone). I dont remember if this flickering also happened at AHCI mode, but yeah, i will switch back to AHCI and see what happens, performing a fresh Windows installation OFC. I guess i will have to deal with the keyboard issue instead of the DVD drive…

Thanks.[/QUOTE] The very nice girl above can give you much better help on DVDRWs than I ever could, she taught me. LOL. I hope you get it fixed.:flower: Oh, and yes, we are always willing to help here at Myce.com.:slight_smile:


#16

FWIW Sergigs I have never found a “solution” to the issue. On one PC I have, I use the LG disc drive so seldom that I disable it in Device Manager. On this PC, the one with the Intel SSD, the enclosure is behind my monitor therefore I can’t see the LED pulsing–problem solved!

:stuck_out_tongue:


#17

Ok, so before formatting i decided to set AHCI mode in the BIOS and boot into Windows… just to try, and BAM, no more constant Led flickering, just the normal LED activity. Also, my boot time is now way faster, like 5 seconds faster, or more, than IDE (as fast as it used to be). Unfortunately, my mouse driver software isnt always showing on the bottom-right tray (nothing new here, it already happened before i switched to IDE, the driver is loaded and working, but the software tray doesnt show up), and when it shows, then my Keyboard doesnt work (i have to unplug and re-plug it to get it working… still, nothing new here). Very strange and random issue, im starting to think it may be due to the ultra-fast boot i get in AHCI mode (seriously, its ridiculously fast). Keyboard works as long as the mouse software doesnt show in the tray, or if i prevent either the mouse software or the keyboard software from loading in the windows boot by “msconfig”. Pseh, i will try some tweaks in my boot sequence or something i dont know, but im definitely not going back to IDE… so yeah, AHCI worked for me in this case, tnx for the support guys.

EDIT:

Doh, srry about that, thanks for your time Wendy :bow:


#18

[QUOTE=Sergigs;2680670]Ok, so before formatting i decided to set AHCI mode in the BIOS and boot into Windows… just to try, and BAM, no more constant Led flickering, just the normal LED activity. Also, my boot time is now way faster, like 5 seconds faster, or more, than IDE (as fast as it used to be). Unfortunately, my mouse driver software isnt always showing on the bottom-right tray (nothing new here, it already happened before i switched to IDE, the driver is loaded and working, but the software tray doesnt show up), and when it shows, then my Keyboard doesnt work (i have to unplug and re-plug it to get it working… still, nothing new here). Very strange and random issue, im starting to think it may be due to the ultra-fast boot i get in AHCI mode (seriously, its ridiculously fast). Keyboard works as long as the mouse software doesnt show in the tray, or if i prevent either the mouse software or the keyboard software from loading in the windows boot by “msconfig”. Pseh, i will try some tweaks in my boot sequence or something i dont know, but im definitely not going back to IDE… so yeah, AHCI worked for me in this case, [B]tnx for the support guys[/B].[/QUOTE]
Wendy was the one that figured out your problem and she isn’t a [B]guy[/B]. LOL. Just kidding with you, glad to have you here and welcome to MyCe.com.:flower:


#19

My BIOS is already set to AHCI on this particular PC and I still get the pulsing. But I’m also running MS drivers–maybe it would stop with the Intel RST, I dunno.


#20

Mhh, make sure your SSD and your DVD drive are both plugged into the “native” SATA ports of your motherboard. And if they are plugged into some 3rd party ports, make sure you have set AHCI in the BIOS for these ports too. For example, I have 2 SATA3 + 4 SATA2 ports controlled by the intel Z77 chipset (native), and 2 SATA3 ports controlled by the Marvell 88SE9172 chip (3rd party). In the BIOS i have 2 options that control the SATA mode, 1 for the intel ports, and another one for the Marvell ones. I dont know if this will help, but i had the same problem as you and AHCI did the trick for sure (at least for me). Im not using RST btw…