Nothing But Coasters With Ritek Clonedisc

vbimport

#1

So far my DVD burning attempts have been a disaster.

System : P4 2.8GHZ, 1GB RAM, PikaOne External Firewire 4x DVD-RW/R, Nero 6 burning software.

I was originally using Bulkpaq orange to back up DVD’s, they would always burn ok, but the majority would not play in either of my standalone DVD players, or would freeze after a while. They were always ok for data storage, though. Having read the comments here about Bulkpaq I opted for the Ritek white Clonedisc DVD -R’s, purchased from dvd-and-media.com.

The problem is I can’t burn ANYTHING with this media, every time Nero gets to the end of the burn and attempts to write the lead-out, I get an error message that this has failed. This is so frustrating, can anyone please help ?


#2

Since your drive is a rebadged BTC, the [COLOR=RoyalBlue]FW update may solve the problem.[/COLOR]


#3

Thanks, I tried that but the firmware update wouldn’t work - asked about that on the BTC forum… Update program wouldn’t even recognise the drive.


#4

True - update program only works with internal drives - not external.


#5

To get it to work can you make your drive internal then flash it…then you can put it back in its enclosure…it shouldnt be hard to do.


#6

I’ve had enough of making coasters, and after reading this forum have ordered a Plextor DVD writer and some Ritek Clonedisc AA+ +R’s and -R’s (to see which is best).

I think it was the combination of average DVD writer and shitty Bulkpaq’s that caused the problems.


#7

yes and pioneer even does good with crap media too…but you should be pleased with your plex. :wink:


#8

Jamos, You would choose the pioneer 8x over the opto12x?


#9

UPDATE

Received the Plextor external PX-708UF today, plugged it into the Firewire, EVERYTHING I burned onto the Clonedisc -R’s was 100% working on every standalone I tried - NO coasters, NO problems. A salutory lesson about using less than top notch media and hardware, well learnt !

Didn’t bother trying the Bulkpaq, they’re going in the bin.

The Plex external is fantastic and looks great, too.