No sound on DIVX

vbimport

#1

I am using vidomi, smart ripper, and virtual dub as my suite of software, and i can not get the audio to work. Ive tried 6 channel and 2 channel audio english, does anyone have any suggestions as to what i can do to fix this?


#2

Could you please be more specific about the processes you have gone through in each software application? This will make a diagnosis much easier and faster for yourself.


#3

I basically used this guide, but some of the stuff it mentions is not in the software i use, or i just cant find it.

  1. Put the DVD movie into your DVD Rom player. Pretty simple so far!

  2. Run SmartRipper and and it will make a Folder for you to extract the files too.
    (bottom…if nothin there just click on the folder icon and make a folder to put vob
    files frm dvd into)

  3. Select Settings on the “movie tab” in “Key-Check” set Every VOB File.
    In “File Splitting” set Every VOB File and in “Options” select Unlock Drive,
    DeMacrovision and Create Directories and just leave the rest as default.

  4. Selecting Start to start ripping the .VOB files of the DVD to your hard drive.
    This can take from 5 to 30 minutes depending on your computer setup and the DVD.

A typical directory of a DVD is similar to :

VIDEO_TS BUP 16,384
VIDEO_TS IFO 16,384
VIDEO_TS VOB 43,008
VTS_01_0 BUP 77,824
VTS_01_0 IFO 77,824
VTS_01_0 VOB 1,695,744
VTS_01_1 VOB 1,073,565,696
VTS_01_2 VOB 1,073,565,696 \ <-- This is the Main movie
VTS_01_3 VOB 1,073,565,696 /
VTS_01_4 VOB 589,365,248 /
VTS_02_0 BUP 18,432
VTS_02_0 IFO 18,432
VTS_02_0 VOB 43,008
VTS_02_1 VOB 1,014,976

                                    Using Vidomi.

1)Ok open vidomi and click on the round icon(next to the word "Vidomi"this is the mode icon)
to switch between the player and the encoder so we want encode mode.

2)Now click on the + sign(this adds files to vidomi)and add the vobs u just ripped to ur
hdd by holding ctrl and clickin 1 time on each of the 4 or 5 vob files makin them blue and
then ok(vidomi will pause a little,like it crashed…it is only just checkin the files u
added).Now click on the “Arrow” and select a place to save ur files and name it.

                               Options/General Options.

3)Now files r in vidomi u want to goto the options icon and click on options/general and
untick,
“Output Player and Encoder Debug files”.
“Display output when encoding”.
“Multithread Encode on Dual CPU’s”.

and put a tick in,
“Display Statistics When Encoding”.
“Use_INFO.text file if present”(if not there already).Now in
“Scan” “5” MB for Audio Tracks.
“Output All Files With The Extension” select “AVI” and in
“Range Select Output Size” select “100% of Source”

now put a tick in,
“Scan Pass Test Compressibility using Final Size”

“Overwrite Existing Files” is un ticked,leave

“Dual CPU Encode Buffers”
tick in,

“Enable Enhanced AVI Features”

“ignore All Settings abd use MPEG Copy Code” is unticked and last but not least…
“Chech For New Versions of Vidomi by Contacting Vidomi.com” is unticked,and click on OK.

                               Options/Video Options.

4)Ok,take out tick in “Hyper Crop” and make sure that “Deinterlace” and “Hyper Scale” are
ticked.
“threshold” is at “15” (under Hyper Crop)
“Blend” is unticked and “20” is in “threshold” (under Blend) and
"Scale by Percentage"is selected (under Hyper Scale)
“Left,Right,Top and Bottom Crop” are all set to “0”
"No Frame Rate Adjustment"is selected and “100”% of Width.

Now place a tick in,
“Force Output Dimensions to be a Multiple of 16”

Now under “Video Codec Settings” select “Set Divx Network Codec Parameters”

"Divx Network Quality Based(One Pass)"and select “Set Divx Networks Codec Parameters” and
divx 5.02(is what i use)window should pop up…goto “General Parameters” and click on
“restore codec’s defaults” and then tick “Enable Resize” and type in the
“output width x hight” 480x352(up to u but i pic Bicubic(Sharp))then ok.

now back to the "Vidomi Video Options"window make sure in “Encode Colour Space” that
"YV12(Faster) is selected…as it says…faster :0)…and click OK.

just leave the "Advanced Video Options to there defauls(should be greyed out neway
so u cant set nethin there).

                              Options/Audio Options.

5)Now goto option/audio options and in the "Global Audio Settings section put a tick in
"Process Audio"and
"Use Lame To Encode"and
“Limit Lame To Mpeg 1 Samplerates/Bitrates” and frm the dropdown window make sure
“No Normalize” and “Normalize Audio To “98” Percent” is there.

“Audio Channel Setting(Requires The Use of Lame)” section select in “Output Channel”“1”
“Use Audio Track” select “MPEG Audio Track1(2 Channels)”.Nothing is in “Channel Name”
“Lame Encode Mode” select “Constant Bitrate” and in “Lame Encode Type” select “Dual Channel”
“Lame Min Bitrate” select “128Kbps”
“Lame Encode Quality” select “Normal” and in
“Lame Output Frequency” select “Same as Source” and then clicl OK.

                               Output Size Options.

6)Ok this is the tricky bit…we want to goto Options/Output Size Options and for a DvD
around 5.5gig in size,I put in “Media Size Disk” section for
"Media Size(Maximum AVI File Size)"450"MB…this means that when it gets to 450MB it
will cut the file for u so u dont need to cut it later…now as i said this is tricky as i
dont really no what to put here…i did a 5.5gig movie and selected 450MB and ended up
with 2 files…1 at 450MB and a second at 422MB…so this is y i say tricky…u will have
to play alittle urself to fine a good size to enter there as all movies r different sizes,
and then click on OK.

                             Options/Network Options.

7)Now select Options/Network Options and put a tis in “Network Encode”,now it is time to
start the encoding… ;0)…so click on “start” and a “Statistic Window” should pop up and
give u an estimated time for the encode…trun off screensavers and nething else that may
bugger up the encode and Happy Dayz…u r now converting ur DvD to Avi with amazing
quality(click on the “Output” icon and take a peek(and to make sure u r convertin)and take
a peek at the file thats being encoded…but dont leave it up to long as it ups the time to
finish the encode by heaps.
If u get to the end and u have more that 2 files created or have 1 big file and wish
to split or join i will explain that next with Virtual_Dub.

                           Joing AVI with Virtual_Dub.

Ok,open V_Dub,click on “file” and load(open video file)file into v-dub,then click
video and click on “direct stream copy"then"audio"and click on"direct stream copy”.Now click
file again and then click on "append video segment"and select second file u want to join
with the first 1.Now click on"file"and save as AVI,name it,and select where u want to put it,
and happy dayz…u should end up with 1 joined file…alwayz good to check at the start
middle and end just to make sure that file is in sync and things r hunky doory;)…GOODLUCK

                         Splitting AVI with Virtual_Dub.

Ok u want to split an AVI file with Virtual Dub…first

1)Click on (top left)file/ “open video file” and load the avi that u want to split into
virtualdub.

2)Go to Video/ “Direct stream copy”. (Note that VirtualDub puts a dot by the options we
select)

3)Go to Audio/ “Direct stream copy.”

“Now u will see a slider,13 icons and some numbers(Frame)at the bottom of virtual dub so i
will be referin to the icons as 1-13 frm left to right”…

4)To cut the movie in half we must move to the middle,so First move to the end of the movie
by pressing the jump to end button (7th icon).(or crtl and the right arrow on keyboard)

5)Divide in half the number of frames that shows at(righthand side of 13th icon)…
This gives me something like “frame” number: 77229.

6)Now click ONCE on the slider and hold “shift+left arrow” and set it to half way(or where
u want to cut)Now this is the IMPORTANT point,we must use the “move by keyframe buttons”
(8th&9th icon)to select where to cut our movie,so click on the (8 or 9th icon)If you don’t
you could end up with a few seconds of corrupted video where the cut was made!!! =0(…

7)Okay, so we are at the point we wish to cut the movie.WRITE DOWN the “frame” number you
have selected to cut the movie in half,now Hit the “mark end point” button(13th icon)(also
called the “mark out” button).

8)Next, press the jump to the start button(4th icon).Then press the “mark start point”
(12th icon)(also called “mark in” button)You will notice that the slider bar now shows
a blue line in it,“the blue part shows the part u r cuttin and savin” so that means
that u r about to cut the right(white)side and savin the first(left)side "blue"of the movie,
and now u want to save it…

9)Now goto (topleft)File/ “Save as AVI” name ur file and click save…then watch it and
when if is finnished(normally only a few mins)close virtual dub and check ur file at the
start,middle and end just to make sure it is OK…and happy dayz u just cut ur first half
of the movie…now wasnt that easy =0)

10)Now u want to cut the second half so…start virtual dub repeat steps 1-3

11)Now remembering the “Frame” number u wrote down click on the(7th icon)(or crtl and
the right arrow on keyboard)

12)Now click ONCE on the slider and hold “shift+left arrow” and set it to half way(at the
“Frame” number u wrote down)Now this is the IMPORTANT point remember,we must use the
“move by keyframe buttons”(8th&9th icon)to select where to cut our movie,so click on the
(8 or 9th icon)…If you don’t you could end up with a few seconds of corrupted video
where the cut was made!!!and we dont want that!!!

13)Now that u r ready to cut to second half so click on the(12th icon)the ‘mark start
point’ button,then the(7th icon) and then the(13th icon)and the blue will appear in
the slider space again but this time it should start at the point u r cuttin and continue
to the end(right side of movie)

14)Now goto (topleft)File/ “Save as AVI” name ur file and click save…then watch it and
when if is finnished(normally only a few mins)close virtual dub and check ur file at the
start,middle and end just to make sure it is OK…and happy dayz u just cut ur second half
of the movie.


#4

It would have been simpler to just point to http://club.cdfreaks.com/showthread.php?s=&threadid=59485 :smiley:

You have also not explained exactly what you mean by "…i can not get the audio to work. " Some further explanation of the problem might help.


#5

after i encode my Video, i play it and there is no audio at all, its just a video with no sounds.