No PIO mode on DVD burners

Hi everyone.

I have just installed a new LG-H10N. I also have an older but well looked after Imation IMWDVRW8DI as a slave. Both are on the secondary IDE. Everything works fine and I have just copied the first of some precious DVDs I need to backup to DL blanks.

Unfortunately my daughter needs to play “The SIMS 2”. This software requires that the key disk be in a drive with DMA disabled. (Don’t ask me, it takes all kinds…). If DMA is enabled the game refuses to recognize the DVD as valid.

I run XP SP2 with all patches up to date and I accepted the standard Windows driver installation when the drives were detected. The control panel no longer has an Advanced Settings tab for either of these drives in the Device Manager and I cannot find any way to enable/disable DMA. I know that it is crazy to run these drives in PIO mode but I need to find a way for at least one of them.

Question:

  1. How do I disable DMA from the Control Panel?
  2. If this is not possible, is there a utility of some sort to do it?
  3. If not, does anyone know the Registry setting(s) for PIO mode?

Thank you all for your help.

Joe M.

The advanced tab in Device Manager is for the IDE controller, not the drive.

I am not sure why this is. It dosn’t need to be run in PIO mode to work normally. This is possible some problem elsewhere. Not sure where though.

And here is a lovely guide on how to change your mode. To make up for the above.
http://club.cdfreaks.com/showthread.php?t=101616

Thank you for your responses. The problem is solved my daughter is happy, and I have a big bump on my forhead from going “Of course!!!”.

I actually responded yesterday but obviously forgot to hit the Submit Reply button. It was clearly a “Three Stooges” kind of day for me.

Joe M.