No more LiteOn DVD-Writer 851S after Firmware-Update

vbimport

#1

Hi there guys,

I KNOW - it’s a problem which a lot of people stil have had hier.

But I please you understand me, starting a new topic. Just want to tell you why :wink:

The hole afternoon I worked with my LiteOn flashing and patching the LiteOn for several things (speedhack, etcpp). For all those thing I searched topics where I’ll get help, cause really NOTHING’s sucessfull and I got a lot of errors working with the tools.

so I used the search-function, read a lot of topics and found still some hints for my problems. So i get “hacked” the firmware’s - found solutions how to update it if windows-tools didn’t work and so on.

so at last, I do all I can and now, after flashing under DOS - my DVD-writer isn’t there.

Now, after searching all the afternoon, I’m really a wrack and I hope you’ll be able to hear my problem and give me a helping hint (or link!) even if it’s written here a lot of time; but I can’t find a solution now with the search-function for me.

So, first my hardware. The dvd-writer is in my second pc, which is:

AMD Athlon 900
Gigybyte-Mainboard
256 MB Cache
Windows 98 SE
LiteOn 851S-Writer (old firmware f; new firmware h (patched) at secondary master

So, I got really a lot of problems; some of the tools will not work with my system, e.g. XflashX. But I worked on and at least I run the update for the dvd unter dos with the originaly liteon-dos-tool mtkflash.

Even the LiteOn-EXE for flashing it doesn’t work here cause it told me: now drive found.

I entered the string mtkflash 3 w hs00.bin and the commands shown on the screen told me for every bank: OK.

I really got happy about that :wink: but only for a short time. Cause now, bios and windows isn’t able to detect the drive and now i didn’t have a dvd-writer anymore :frowning:

So, the still stupid question from a really irratatet newbie about working with the liteon-tools: WHAT NOW ?

I’m really happy for a easy hint or link for a solution; cause at moment I’m not really able to search and read more cause I’m not able to find the needed point in a lot sided threads.

A big thanks to you for the possibility to understand that :slight_smile:

Greetz,

Kinu


#2

Start by trying everything found in this thread, it’s a great resource and should help you out.


#3

Thnx! I’ll do and report - a lot of stuff to do :eek:

Are there any known problems using those tools with win98 or is that just the simple “only at your hardware”-effect ?

Kibu


#4

mtkflash is actually a DOS based program so it doesn’t matter what OS you are using.


#5

Yes, that’s clear :slight_smile:

I just mean it watching to all the other programms of the tool collection which won’t work in my windows… :wink:

ok, first “try” to repair:
This one postet last in your supposed thread
http://club.cdfreaks.com/showthread.php?s=&postid=531475&highlight=mtkflash+AND+bank+AND+first#post531475
I just found too yesterday, no result.

Just another question: Anyone here who has a regular bin-firmware for me ?

Cause (don’t ask why) the “Bin-Extractor” from the original LiteOn-EXE doens’t work and crashes starting it too…

The only I have is the “patched” bin…

An last question for now: is this regular, that the drivelamp doesn’t turn on using mtkflash ?


#6

Find BIN’s here.


#7

YEAHR :iagree:

Using the firmware of the drive it has as I bought it (0A) with mtkflash/dos my drive’s still back and alive :slight_smile:

May there be a reason my drive didn’t like the new 0H-firmware ?

So Ssseth, let me tell a big thnx ro you :bow: for helping and your great patience you’ve got with “my” (and sure others!) problem.

People like you are a great thing for every one and especially for this board :slight_smile:

just go on!

Kibu


#8

Flashes just go wrong somtimes. Thankfully it’s pretty rare but as you know can happen.

If you still want to try GS0H you can do so using mtkflash and a .bin copy found here. Or, you could also try flashing from Windows using LtnFW.

Anyway, glad to hear your drive is alive again. :smiley: