No audio in video playback

vbimport

#1

No matter if I install/uninstall/reinstall any audio codecs, I cannot get any audio playback in Zoom Player or any other Windows player for that matter. Windows Media Player tries to look for the codecs on the net (But does not find them of course) even though they are installed and registered correctly.

To test I dragged an AVI file into Graphedit and it complained about being an unsupported format and only splitting the video portion of the AVI with the AVI filter leaving pin 01 for audio not going anyplace.

I also checked in GSpot and it gives a “Render: Partial Failure” on the DirectX test.

I have SP2 installed but this is NOT what the cause is as I had th eproblem before installing SP2. I thought it might fix it but it hasn’t.

Zoom Player’s ‘Zoom Player Audio Filter’ is greyed out on the filters menu when I right click a movie. As are ‘Overlay Mixer’ ‘AVI Splitter’ and ‘Source File’.

If I select the ‘Graph Information’ it says:

Zoom Player Audio Filter
Class ID : {B38C58A0-1809-11D6-A458-EDAE78F1DF12}
Library Unknown

Output pins has nothing.

BTW that Class ID does not exist in the registry. I searched for it. Nothing. Could this be the problem perhaps?

Also under the AVI Splitter ‘Stream 01’ has nothing there unlike ‘Stream 00’ which clearly shows the video filter being used.

Guess what though? Media Player Classic will playback the audio just fine! It’s just that no players that seem to rely directly on the Windows own method of using filters work (Zoom Player, BSPlayer, Windows Media Player etc).

I’ve tried re-registering the filters in filter management. Nothing. Ran an SFC /scannow. Nothing. Reinstalled audio codecs until I am blue in the face. Nothing.

DirectX reports no errors in DXDiag.

I’ve tried reinstalling Zoom Player and Windows Media Player. I tried to reinstall DirectX 9C but it’s already part of SP2.

Windows Media Player plays audio files fine.

It’s more than likely something is missing or screwed in the registry.

I can’t find anything on a google or MS KB search for this.

I’m at my wits end!

Anyone got a clue?