nForce3 (MS IDE driver) Plextool detection problem

vbimport

#1

I recently picked up a new A64 3400+ w/nForce3 250 motherboard, but I have been unable to get the Plextools to detect my devices. Using Plextools or PXInfo I am able to detect the Primary/Secondary IDE interfaces, but not devices. I am using the new 4.24 nVidia motherboard drivers, but I am NOT using the NV SW IDE drivers. I have tried everything that I can think of, but to no avail. Does anyone else have any ideas? I can use other burning software (i.e. Nero, BW, A120%), but I really would like to be able to use the VariRec, GigaRec, and SecureRec features I bought the Plextor Premium for. :a

-Malichite


#2

Maybe the PLEXTOOLS PRO currently doesn’t support nForce3 chipest.

Try to use another motherboard to check the problem.


#3

http://mwarhead.motherboardfaqs.com/content.php?content.5

use modified drivers for your nforce chipset…download it from the link above.


#4

Yes I had everything working fine on my previous AMD 2800+ w/nForce2 Ultra board before I upgraded. I took a look at the modified drivers and they didn’t make any difference. I used the nVidia Reset, Driver Cleaner, and remixed nVidia in the correct order and everything is working on my system EXCEPT Plextools can’t detect any CD/CD-R/DVD/DVD-R devices. Also I have tried with and with the nVidia SW IDE drivers. If I use them Plextools doesn’t even detect the IDE interface and without it sees the IDE interface just without any devices. Here is a snippet from what PXInfo sees (same for IDE interface 1, but didn’t want to post redundant info).

IDE Interface: 0 ID: - Maximum # Targets : -
Description :
Type :

Port Driver : atapi.sys
Provider :
Description : IDE/ATAPI Port Driver (Microsoft Corporation)
Location : C:\WINNT\system32\drivers\atapi.sys
Version : 5.00.2195.6699
Date :

-Malichite


#5

The nVidia nForce3 250 chipset on your new motherboard support SATA ports, while the nForce2 chipset on your old motherboard does not. This makes nForce3 more complicated to configure properly.

I don’t know the details of your nForce3 250 motherboard, but I would suggest going into the BIOS setup to look for a setting that controls the resource allocation of PATA/IDE and SATA ports. The exact description of such a setting can vary among motherboards, and can be a bit tricky to locate. In some cases, it may not even exist.

If you can find such a setting, I recommend setting the PATA/IDE ports to use legacy/compatible resources (IRQ 14 for primary IDE, IRQ 15 for secondary IDE, etc.), which implies the SATA ports will be configured to use native (non-legacy) resources. This configuration should have the highest degree of compatibility with various OS’es.

Another thing you can do is check whether the IDE channel (primary or secondary) the Plextor Premium is attached to is utilizing legacy resources. Go into the Win2000 device manager, and do “properties” on the primary or secondary channel (under the IDE ATA/ATAPI controllers section), and click on the “resource” tab. If you see IRQ 15 for secondary IDE or IRQ 14 for primary IDE, then the IDE channels are in legacy resource mode, which is the most compatible mode. If you don’t see IRQ 14 or 15 for IDE then go into BIOS setup to see if you can reconfigure as described above.

Also try updating to the latest PlexTools Professional 2.15 for the Plextor Premium. Your problem may be a case where PlexTools Pro needs a bit of “help” to work properly with the nForce3 250 chipset.


#6

Unfortunately I have already tried most of those suggestions. My primary/secondary IDE interface does use IRQ14/15 and I am also using the latest 2.15 PlexTools. Additionally I am only using PATA IDE drives, so I have disabled as many of the SATA options as possible. That being said I am unable to disable the nVidia nforce3 250’s integrated RAID SATA, since this isn’t supported in the bios. This means that PXInfo detects the NVRAID interface along with the standard IDE interfaces, but no devices are listed upon any interface. It is also not possible to disable this in Windows as far as I can tell since the typical “disable” option is unavailable for the NVRAID interface. I have an outstanding support request in to Plextor now, but who can say if anything will come from it. Can you think of anything else to try?

BTW my setup is an AMD A64 3400+ w/Gigabyte K8NS-Pro nForce3 250 motherboard. Using a Plextor Premium w/1.05 firmware and PlexTools v2.15.

Do any other burning software packages support the GigaRec, VariRec, and SecuRec offered by the PlexTools?

-Malichite


#7

Does the motherboard BIOS offer a setting to change the SATA ports from RAID back to “plain” SATA? If you have the NVRAID driver installed for the nVidia SATA controller in RAID mode, but you are not using any SATA hard disks, the NVRAID driver may be conflicting with PlexTools in some way. If the nVidia SATA controller can go back to plain, non-RAID mode, you should have the option of replacing the NVRAID driver with the Microsoft IDE driver included with the OS.

If you see the NVRAID driver under the “SCSI and RAID controllers” section of Win2000 device manager, and this driver is not supporting any devices in your system, you can use the DISABLE button to turn off this driver (you will get a red X mark on the icon). This is an alternative if the device itself cannot be disabled in BIOS.

I have heard from various sources that the NVRAID driver has been quite buggy, so I’d recommend staying away from it if possible, or at least keep on top of any available updates.


#8

Yup that disable option inside the SCSI/RAID Controllers isn’t available. I can only select Uninstall, Scan for Hardware Changes, Properties. On the other SCSI devices I can select disable, but not on the nVidia nForce RAID Controller. If instead I unistall it, it simply gets reinstalled upon restart. I have removed the *.inf so it doesn’t get reinstalled, but this still doesn’t fix the problem. The ATA Interface (NVRAID) no longer appears in the PlexTools menu, but still nothing new is displayed.

As for the SATA RAID, the nForce3 250 chipset has an integrates 2 port SATA/RAID interface built into it and you use software in windows to manage whether you use plain SATA/RAID setups. The Gigabyte motherboard provides an option to disable thier secondary SATA chip (provides 2 additional SATA port for a total of 4), but there is no way to disable the integrated SATA interface found within the nForce3 250 chipset.

-Malichite


#9

This is another indication that NVRAID is not a well-developed driver. Even support for disable is not available!

I can’t come up with more suggestions at this time. I do have a motherboard at work with the same nForce3 250 chipset, so next week I can connect a Plextor Premium to it, install PlexTools Pro and see if I can replicate your problem.

While we are talking about the nVidia nForce3 250 chipset, did you know that this chipset has been confirmed by nVidia to have major susceptibility to electrostatic (ESD) damage? nVidia found out that various signals associated with the nForce3 250/Ultra series chipsets, including USB data signals, power and reset button signals, and even SMBus signals connected to each memory DIMM socket, are vulnerable to ESD. If the system is left in the off state (ACPI S5 state), such as after a proper OS shutdown, and any of these susceptible chipset signals takes an ESD zap, the next time the system is powered up, the nForce3 can go into latchup mode and burn up!!! Of course this will result in a dead and wasted motherboard. In analyzing the dangers, it appears that installing/removing memory DIMMs on nForce3 motherboards can be a very risky activity! Even the casual hotplug of USB devices (such as USB flash drives) into the USB ports of a nForce3 motherboard is not entirely risk-free! (Can you believe this? :eek: ) It is vital to observe proper ESD grounding procedures before working on your nForce3 motherboard, otherwise you risk spontaneous destruction of the chipset and your board! :eek: