New SH-182M Not Recognizing Discs

Hello! I just bought an SH-182M, and it’s not recognizing many discs. I’ve played with it, and I think theres about a 99% chance that I’ll have to send it back. But thats a pain, so thought I’d check to see if theres anything else I should check first.

Discs I’ve tried so far:

  • 3 commercial DVDs, not recognized
  • 3 commercial CDs, recognized and worked fine
  • 1 blank CDR, recognized, but didnt try burning
  • 1 burned CD, not recognized

I’ve tried:

  • Deleting the drive and letting Windows find it again
  • Setting a DVD region
  • Using the SB03 firmware released today
  • Installing latest MB chipset drivers

Windows doesnt seem to think that there is any media in the drive when the disc isnt recognized. But when I flash the firmware, the firmware utility knew there was a disc in there and made me remove it.

I played with DvdInfoPro a bit. I ran the speed test on a couple CDs it recognized, and it either didnt work or stopped after getting too many errors. Windows copied all files from the cds just fine, although with one I had to reinsert it after DVDInfo choked.

Anything else to try? I might put it in another computer to see what it thinks.

Dirty lens, perhaps.

Try the drive in another computer, if the reading errors continue RMA the drive.

Uninstall any software like Alcohol or Daemon Tools whilst you’re trying to troubleshoot this problem.

But if you try the drive in another PC as suggested, you won’t have to :slight_smile:

Well carp, it seems to be working just fine in my other computer. Unfortunately its an old 670Mhz beast that I dont think could cope with burning a DVD, at least at full speed. I’ll have to check, once I have some media.

I also had it as a slave in my “good” computer, and now it’s set to master. I wouldnt think that’d make a difference, beyond possibly affecting R/W speeds.

I had an old Sony CDR drive where the DVD burner was installed, but it has been disconnected for a while since it wasnt reading anything. Now I’m wondering if that would work in the crummy computer as well… The other 3 installed drives work fine, and the motherboard has been swapped since the Sony drive stopped working, so I’m doubting it’s a bad IDE channel. Maybe a bad cable? Hmmm.

Try the old cd drive and the 182 on the same ide controller in the new machine. For more info, read the last two pages of the lead-in thread on the same page as this thread.

are you adding a drive or replacing a drive?? if you are adding a drive it’s possible that you are drawing more wattage/amperage than your power supply is supplying. i have seen this before! unplug any other, non-critical, devices on that string of molex connectors and try the drive again. i fixed a system last week that the p/s checked out good and it booted fine with no optical drives or floppy attached. with everything plugged in the 12volt rail output dropped down to almost nothing. time had taken it’s toll and the rail was just too weak to supply anything

I’ll get to troubleshooting this more, but it may take a few days. I have a newborn in the house, so I dont get to sit around and rip apart computers anymore. :slight_smile:

I’m adding a drive. It’s possible that I’m overworking my power supply, I suppose. I’ll have to figure out how to test that without starting a fire.

I too have the same problem,I think I 've enough power supply and I don’t think it’s a problem with IDE channel as well. It was working fine for a week and now this problem starts to crop up. It’s recognizing some DVDs and CDs but not everythinh. The NERO CD with which it came was recognized by the drive earlier but it’s not longer recognizing it now. I guess it’s something to do with Firmware upgrade. Can any one help me with this??

Config:
nVidia 680i SLI Mobo
Core2duo E6600
550W Rosewill PSU
2GB 800 Mhz RAM
Geforce 7600 GT
Creative Audigy2 ZS Platinum

http://club.cdfreaks.com/showpost.php?p=1631870&postcount=131

Edit: Oh nevermind… saw you have a good power supply

Working on this problem, too. Should I RMA my drive or what?

Config:
Intel P965 mobo
Core 2 Duo E6600
480W Antec Trueblue 2.0 PSU
1GB 800 Mhz RAM
GeForce 6200 LE
Creative X-Fi Platinum

Someone help~

Uninstall the ide drivers, remove virtual drives and softwares like Alcohol as suggested, also delete the upper and lower filters (see my sig).

Then restart !! and try again.