New Premium2 came with v1.10 firmware?

vbimport

#1

Hi,

I just bought a Premium2 direct from Plextor and the firmware version is 1.10. However, when I look on the Plextor site, the most current version available to download is 1.03. The date of manufacture on the drive says February 2008, made in Japan.

Does anyone have any info on this discrepancy?

Thanks very much.


#2

Very interesting… The Premium II is still in production :eek:

Maybe the 1.10 is the same like the two versions of the PX-40TS CD-ROM drive.

There are two versions of this drive (with firmware 1.00 - 1.05 and 1.10 to 1.14). I think your Premium II has an incompatible hardware to the 1.0x firmware, for this reason a 1.1x firmware branch exist.

But this is all a guess…


#3

Very interesting. Thank you for reporting it.

Nothing is known so far. You’re the first one to report this. [I]TM[/I] has already stated one possibility. Another possibility might be special firmware for copy tower use. However such firmware up to now seems to be numbered after the 1.[B]5[/B]x scheme. Since the drive ist still being produced we might see additional Firmware releases in the future. Then we might now more looking at new version numbers. Until then only Plextor can tell.

One thing we can try: Plextools does also reveal the firmware DATE (drive info tab). Could you check what it says? If the date is the same as, say 1.03, we might know more.


#4

Thanks for the replies.

I ordered the drive direct from Plextor on 4/17/08 at the phone # I found in another thread on this site. 800-886-3935. I had called at the beginning of the month and they didn’t have any Premium2 drives, but the guy said they expected more in on the 17th. It was $179 plus shipping and the drive came with a beige bezel only.

Regarding Plextools, I’m using a Mac, but I do have a access to a vintage Windows 98 PC that I can try running Plextools on. I’ll see if can fire that thing up and let you know what the firmware date is.


#5

[B]Jan70[/B] reported recent “Made in Japan” production last month: http://club.cdfreaks.com/2016970-post14.html

Would be interesting to know your unit’s TLA# [B]StudioDweller[/B].


#6

Very interesting and Sigh :doh:


#7

[QUOTE=StudioDweller;2046624]It was $179 plus shipping and the drive came with a beige bezel only.[/QUOTE]:eek: holy crap…

I’d call them back and ask them about the deal with the firmware. Then post back what they said please.


#8

[QUOTE=Cressida;2046696]Would be interesting to know your unit’s TLA# [B]StudioDweller[/B].[/QUOTE]

Indeed.

Please, [B]StudioDweller[/B], if you remove the drive from your mac, please look for and post TLA#, manufacturing Date and the number at the bottom of the barcode (except for the last three digits, if you want to keep your serial private), i’d like so see how many units have been produced. Thanks!


#9

[QUOTE=hwp;2047006]Indeed.

Please, [B]StudioDweller[/B], if you remove the drive from your mac, please look for and post TLA#, manufacturing Date and the number at the bottom of the barcode (except for the last three digits, if you want to keep your serial private), i’d like so see how many units have been produced. Thanks![/QUOTE]Here is the number lets all call them up > 800-886-3935


#10

The manufacture date is Feb. 2008, made in Japan.
TLA #: 0110
S/N: 509100222xxx

I still need to run Plextools on that old PC to get the firmware date, but I’ve got a crazy busy schedule right now so it may not happen until next week. That thing takes nearly a week to boot up so perhpas I should start it now.:wink:


#11

Take your time. And thanks again.

[I]Edit:[/I]

For the record: Firmware 1.03 dates from 10/01/07


#12

Thanks, good to hear they are still producing this drive.


#13

[QUOTE=hwp;2047314]Take your time. And thanks again.

[I]Edit:[/I]

For the record: Firmware 1.03 dates from 10/01/07[/QUOTE]

You’re very welcome. If it wasn’t for this site, I wouldn’t have known that I could still get one of these so I’m happy to help out in any way I can.

BTW, what is the TLA #?


#14

[QUOTE=StudioDweller;2047489]You’re very welcome. If it wasn’t for this site, I wouldn’t have known that I could still get one of these so I’m happy to help out in any way I can.

BTW, what is the TLA #?[/QUOTE]It’s the hardware and f/w revision. Seems maybe something changed with them hardware wise?

I have a Premium,Premium II, and a Premium U.

I just picked up the Premium U for $25usd on ebay. Brand new in the box. Premium U is a Premium USB external.

Great CD-R burners.


#15

[QUOTE=StudioDweller;2047489]BTW, what is the TLA #?[/QUOTE]

The first two digits are the hardware revision and the last two indicate the firmware version. Hardware 01 appears to be the same as the last “Made in China” units, but the firmware jump from 03 to 10 is unexplained. Jan70’s new “Made in Japan” drive is 03, so it doesn’t appear to be the shift from China to Japan that started the new firmware revision.

TLA #: http://club.cdfreaks.com/f43/plextor-faq-read-first-49767/#general-tla

Thanks for the info!


#16

I’d like to see some burn scans please. You know anyone with a XP or Vi$ta machine