New Nforce2 Drivers (2.41) - Battlefield 1942 Won't Work!

vbimport

#1

Just noticed, this seems to be a rather common problem. For those using Nforce 2 based motherboards, the new 2.41 drivers fix all the IDE issues the old 2.03 drivers had. You can now burn CD’s using Nero no problems, and your HDD devices show up as normal IDE drives, not SCSI.

The one problem however, is that BF1942 will not play at all with the 1.31 BF Patch. It seems for some reason, that the Nvidia drivers have screwed safedisc protection somehow with these drivers, and it doesn’t recognise the disc. On running the game, it comes up with the error message “Incorrect CDROM, please insert the correct CDROM into your drive and try again”.

This happens regardless of whether it is cd1 or cd2 in the drive. Has anybody else experienced this problem. BF1942 is the only safedisc 2 game I have to test, and I have seen 2 other users from another forum with this same problem. Any ideas why this is happening?? Any feedback would be greatly appreciated.


#2

Did you have the listed IDE and such problems in the drivers of version 2.03? If not and upgraded just to obtain newer drivers, then downgrade back to the older version. If you did have those problems and for such reason installed newer driver version 2.41, it might be an unfortunate situation where you are stuck waiting for newer drivers to fix newer problems, or you will just need to play with the system till you get it to work. Otherwsie you are SOL:( I would check DMA and other cd-rom settings as a start. Also remove all cd-rom’s by deleting them in device manager and let windows install them again. Things like this you should mess with, can’t think of any others off hand but when I do I will add to thsu post :slight_smile:


#3

Done all that already. It is definetely a driver problem. These were installed on a fresh WinXP install and the problem still exists. After having browsed the NforcersHQ forums it seems this is a common problem with Safedisc 2 games. There is a fix, but that requires changing your CDROM / CDRW / DVDROM to PIO mode, and that I don’t want to do. Looks like we have to wait for a fix from Nvidia now :frowning:


#4

I am wondering what the response of Electronic Arts is.


#5

Originally posted by Mr. Belvedere
I am wondering what the response of Electronic Arts is.

As in their response to Nvidia or the public?? AFAIK, this problem affects quite a few Safedisc 2 games. I’d be kicking Nvidia’s arse if I were EA right now, the copy protection is there for a reason, now people (like me) with legit copies can’t play it :frowning:


#6

What is PIO mode?.. and why are you so hesitant to use it if it will work? At least try it temporarily till NVidia makes another update, enjoy your game dude!


#7

Originally posted by xtacydima
What is PIO mode?

A slow dinosaur from the early stoneage. Modern IDE-drives will suffer tremendeously from running in PIO-mode.

My suggestion is that you make a backup of BF1942 and mount it as a virtual drive. I do, I only use the CD’s to install once in a while.


#8

Some people are using the no CD crack OK, from what I’ve heard. Not sure of the version number though.

My MSI nForce1 seems unaffected by this, so I assume it only nForce2.

dr p


#9

No talk of Cracks on this forum.:cop:


#10

Originally posted by Chriso
No talk of Cracks on this forum.:cop:

Well, actually in the land of Oz, these NoCD cracks are legal :smiley:

But okay, let’s keep or forum out of troubles :wink:

I’m just wondering who is to blame here… if only those games protected with SD2 are having these troubles, I somehow expect that Macrovision is to blame for this…


#11

Sorry about that, didnt mean to upset anyone :cop: didnt think it mattered, just trying to help Lombers play his legally bought game, I’ll be quiet now :bow:

dr pepper


#12

A new version of the NF2 drivers has been released. Although nothing of SD2 was mentioned in the changelog, it may solve this issue…

Direct link here


#13

this reminds me of an old problem

might be wrong but its worth a shot go here


#14

NVidia retreated the NF2 2.42 drivers today because there where some problems (we know some of them;))… the 2.03 drivers are downloadable again, until new, bug-free (or better: with less bugs) are to be released…


#15

You can download the uninstall information here to get back to 2.03

This is the explanation of the uninstall procedure.

Case 1

If you installed nForce 2.03 driver kits and then installed 2.41 & the NVIDIA SW IDE without uninstalling 2.03 and want to go back to 2.03 driver kit, please follow these steps

Option 1: Auto Roll Back Using Windows System Restore

  1. Browse to the Start Menu > All Programs > Accessories > System Tools > System Restore (See option1.1.bmp)
  2. Select “Restore my computer to an earlier time”. Click Next (See option1.2.bmp)
  3. Pick a highlighted date on the calendar that is some date before the 2.41 driver package was installed.
  4. Click “Next”
  5. When you are sure that you have the right selection, click “Next” again. (See otpion1.5.bmp)
  6. Windows will roll back to an earlier date and then reboot.
  7. When Windows returns your system should be running with the 2.03 drivers again.

Option 2: Manual Roll Back

  1. Download the nForce 2.03 driver kit.
  2. Browse to the Start Menu and select “Search”
  3. Do a search on \windows for *.nvu (See option2.3.bmp)
  4. Delete the “nvide.nvu” file (Option2.3.bmp)
  5. Go to Control Panel, Add/Remove Programs
  6. Remove the option “NVIDIA nForce Drivers” (See option2.6.bmp)

NOTE: You must select the option with the exact text above

  1. Reboot.
  2. When the system restarts, hit “Cancel” when all devices are detected
  3. Re-install the nForce 2.03 driver kit.
  4. Click “Yes to all” when asked to overwriting old files
  5. Reboot when install is complete
  6. Upon system restart, right mouse click on My Computer and select Properties
  7. Select the “Hardware” tab
  8. Click on the “Device Manager” button
  9. Expand the section labeled “IDE ATA/ATAPI controllers”
  10. Left mouse click on the option labeled “NVIDIA NForce™ MCP2 IDE Controller” or “NVIDIA® nForce™ IDE Controller” (your system will only have one of the above options) (See option2.16.bmp)
  11. Right mouse click and select “Update Driver” (See option2.17.bmp)
  12. Select “Install from a list of specific location (Advanced)”
  13. Select “Don’t search, I will choose the driver to install”
  14. Select the driver “Standard Dual Channel PCI IDE Controller”
  15. Reboot.
  16. After reboot allow device detection.
  17. Reboot again.
  18. Everything should now be working correctly.

Case 2:
If you installed nForce 2.03 driver kits and then installed 2.42 & without uninstalling 2.03 and want to go back to 2.03 driver kit, please follow these steps

Manual Roll Back

  1. Browse to the Start Menu and select “Control Panel”
  2. Select “Add/Remove Programs”
  3. Remove the option labeled “NVIDIA nForce Drivers”

NOTE: You must select the option with the exact text above.

  1. Reboot.
  2. When the system restarts, hit “Cancel” when all devices are detected
  3. Re-install the nForce 2.03 driver kit.
  4. Reboot.
  5. After reboot allow any additional devices to be detected (if applicable)
  6. Reboot.
  7. Everything should now be working correctly.

Case 3
Your system is unbootable because you tried to use Add/Remove programs on the nForce 2.42 driver kit

Recovering Windows

  1. Copy the “nvatabus.sys” file to a floppy disk. This file is included in the zip file that include these instructions.
  2. Boot system to Windows XP installation CD.
  3. At the Setup screen, press ”R”.
  4. This will bring up the repair console.

Which Windows installation would you like to log onto
<To cancel, press ENTER>?

Hit “1” and <ENTER> or the number that represent your Windows XP installation.

Type the Administrator password:

Type password and hit <ENTER>

Insert the floppy disk with the "nvatabus.sys” file into the floppy drive. At the command prompt, type “copy a:
vatabus.sys c:\windows\system32\drivers” and hit <ENTER>. Once file has been copied, type “EXIT” and hit <ENTER>. This will reboot your system. Remove floppy from system.

  1. When the system restarts, hit “Cancel” when all devices are detected
  2. Re-install the nForce 2.03 driver kit.
  3. Click “Yes to all” when asked to overwriting old files
  4. Reboot when install is complete
  5. Upon system restart, right mouse click on My Computer and select Properties
  6. Select the “Hardware” tab
  7. Click on the “Device Manager” button
  8. Expand the section labeled “IDE ATA/ATAPI controllers”
  9. Left mouse click on the option labeled “NVIDIA NForce™ MCP2 IDE Controller” or “NVIDIA® nForce™ IDE Controller” (your system will only have one of the above options) (See option2.16.bmp)
  10. Right mouse click and select “Update Driver” (See option2.17.bmp)
  11. Select “Install from a list of specific location (Advanced)”
  12. Select “Don’t search, I will choose the driver to install”
  13. Select the driver “Standard Dual Channel PCI IDE Controller”
  14. Reboot.
  15. After reboot allow device detection.
  16. Reboot again.
  17. Everything should now be working correctly.

Weird though, i got 2.43 installed and have no problems at all :slight_smile: