New LG GWA-4164B Firmware!

vbimport

#1

There is a new LG GWA-4164B firmware update!
I don’t know exactly what is changed but I hope it’s gonna fix the DVD problem I have!

Download here: http://drivers.softpedia.com/get/FIRMWARE/LG/LG-GWA-4164B-105.shtml
If you have problems with updating try this:
Click!


#2

I’ve downloaded and installed this new firmware, but now I have a problem with my drive :’( I’m able to READ and WRITE DVD-type media, but my drive will not recognize anything that is CD-type. I’ve tried with burned discs, with retail ones and they just won’t load up within Windows.

I’ll get a loading CD icon where my mouse cursor is, but it’ll stay doing it until it gives up on the CD. If anyone can help me, it would be greatly appreciated. The full name of the drive is [HL-DT-ST DVDRRW GWA-4164B] and the firmware is currently at 1.05


#3

Hello LiquidStorm and welcome to the forum.

The thing about GWA model LG writers is that they seem to be custom model jobs for each computer manufacturer that bundles them in the systems they sell. So the GWA-4164B that comes with a Fujitsu system might not be the same as the one that comes with a Dell system. This is why it is recommended that you only use GWA firmware from the company that sold you the system your drive came in. You should only use GWA firmware from other unknown sources like the one above as a last resort. You’re not the first person to report these sort of problems.

The best thing to do right now is to try and get the previous version of firmware you were using from the website of the company that sold you your computer system and flash your writer with that.


#4

Aww, well that sucks =/ Would you know where to find the HP drivers for this model? I’ve looked around in many places and haven’t gotten anything from the HP site either, it’s why I looked thru the forums and found what I thought to be the right one, but guess not :’(

I found one in the HP site, but it was telling me that my system wasn’t configured for the drive, which I found weird, so it never updated anything. I was able to find the right one for my Optorite CD-RW, glad that one’s working at least.

Thanks for the info and I’ll try to revert the model back to what it came with, I think it was 1.02.


#5

Ok, after looking around again, I’ve figured out that I should be on version 1.I0 since my drive is a dual-layer. I just wanna check up with the pros [yeap, that’s you guys] to make sure that it’s correct.

I was able to find the file and the installer, so I’m gonna wait for a reply b4 I jump into any more problems. I’ll check in again tomorrow.


#6

Not sure anyone can help you with that confirmation because you are going to need someone who has the same drive you have and from HP as well. The retail LG writers don’t have these strange different firmware versions meant for different variants of the same drive, so most LG writer owners won’t be able to help you.


#7

Tried to download firmware for lg gwa-4164b but i keep getting error “Mismatched type”. I do have this dvd device but it presently has dell firmware on it. Cannot put other firmware on. Please help…


#8

The thread you replied to is almost 3 years old.


#9

Moved from 1.01, original firmware, to 1.05.
Reason for the move was that the drive sometimes did not recognise disc used in other drives.
NOW it only appears to recognise CDs but DVD’s no way. So far I have only tried +RW and the latest version of Nero.
I have not tried to burn either -RW or +R discs
:sad::sad::sad::sad:
I hoped that this would resolve the problem but no way.
At present I can not even return to the origin firmware.


#10

Maybe time for a modern drive. It is a dated one.