New installed 832S: big problem (no flashing, no writing)!

I have just installed a new 832S on my PC, but I have two big problems:

  • cannot burn DVD
  • cannot flash new firmware

More infos:

  • The firmware is the original VS03, the burn sofware is nero express
  • The 832S driver is installed on the second IDE channel as master (a DVD reader is installed as slave)
  • Win2000 can see the 832S and on this unit I can read CD-ROM, DV-ROM and all burned media without any problem)
  • I can burn CD-RW with the 832S using nero, but no DVD-RW
  • I use Verbatin DataLifePlus supports

Any suggestions?

Thank you for your help
Gio

Hello, and welcome!

I am very sorry to hear of your problems… and you have certainly come to the right place. If anyone can help you, you will find them here.

I most likely will not be able to help you myself (I am fairly new), but I am a hardware tech, and can ask you some questions that will help us all:

  1. What are your system specs?

  2. What software (burner specific) do you have installed (include versions)?

  3. Have you checked to make sure DMA is enabled for the drive?

  4. Why do you think that the burns have not been working? (as in what kind of errors??)

Hope we can help you!

-Skystalker

Hi Skystalker, thank you for your reply.

OK, I’ll give more infos:

  1. Dual boot system NT4-SP6a/Win2000SP4
    AMD Athlon 1200 MHz, Mobo: VT8366-8233, 256MB RAM

  2. Nero Burning ROM 6.3.1.11 (included in Retail version)

  3. Under NT4 no DMA (under Win2000 I’ll check later)

  4. When I try to create a data disk with nero, all works fine, the whole disc is written i.e. the progress bar arrives till 100%, but then all stucks, nero does not responds to any command, the PC is instable and I have to reboot the computer.
    The same when I tried to delete the DVD-RW: all was ok till nero reached 100%…then again I had to reboot the PC.

Then I tried to flash to a new firmware using the win exe file VS0A.exe of the liteonit website: The exe starts, I select the right device, then appears the progress bar “programming…”, it works till 100% and then again all stucks and I have to reboot the computer. Then checking with the NeroInfoTool I see that the firmware is still the VS03.

What I cannot understand is that by writing CD-R, CD-RW all works fine!

One more info about my DMA setting:

Having a VIA chipset, I used the DMA-tools that I received whith the installation CD of the mainboard.
The ViaDMATools report that for the 832S is set the UDMA mode
(I have to check off the option to enable the DMA mode)

Using the microsoft “checkdma tool” or “NeroInfoTool” no DMA support is deteceted.

The 832S requires the latest VIA drivers to be installed to work properly. You can get then from here.

Bingo. Get the latest VIA drivers, make sure to set DMA to ON (it’s done in the device manager under Win2000, under the IDE controller - not the drive).

Also, although many people suggest running burners as secondary master, I’ve ALWAYS run mine as secondary slave with my DVD-ROM as secondary master. On a relatively modern chipset it will seldom matter.

  • Gurm

Yea… the DMA thing is what is killing you, I would imagine. MUST MUST have DMA enabled. :slight_smile:

Follow CodeKing’s advice, and you should be good to go. LOL… I don’t think I have seen a bad bit of advice from him yet!

-Skystalker

Yes…the VIA drive was the problem!!!
After updating to the latest one, all works fine under Win2000
(Anyway I still didn’t flash to the last firmware VS0A)

But under Win-NT4 the 832S still does not work (and I have update the VIA driver for NT4 too… :sad: )
I will try some work around under NT4 and then inform you again.
(may be I’ll open a new specific thread for NT4 if required)

Gio

Well, now it works under NT4 too, but it is an odd story…

I had to remove the VIA miniport drive (that could not let me setting the DMA modus with dmacheck.exe) and use the standard MS drive.
After enablig DMA with dmacheck.exe, all was OK!

What I still do not understand: with VIA-DMA-Tools I could set UDMA2 for the 832S (UDMA should be better then DMA), but nevertheless the 832s wont burn…!

Thank you everybody for your help.

Gio

Heya, bro…

Many people have to try out what settings work for their system and OS. :slight_smile: You just had to troubleshoot twice!

Glad it works for you! Many happy burns!

-Skystalker

I have seen this with all of the late model Lite On DVD burners & it can be caused as a result of the IDE driver. The best thing to do is to get the latest IDE driver for “whatever chip set” your motherboard is based on.

Then in some cases (like mine!), that still doesn’t work which means you can revert to the default MS IDE driver and I have yet to see a system not work correctly using the default MS driver.

For some reason my MSI board will not work with any Lite On burner if I use the NVidia drivers -latest, older -doesn’t matter. With the default IDE driver and DMA enabled my 832s works PERFECTLY, couldn’t ask for anything better, especially when using Rioch JP-1 DVD+R burned at 8X!

For most NVidia chip set based boards the latest IDE driver solves the Lite On issues as well as Via (which you have right?).

Let us know if this does the trick and hopefully you will not have to revert all the way to the “default MS” IDE driver but if you do then I know I’m not alone while running it. :slight_smile:

  • under Win2000 all works fine with the latest VIA driver
  • under NT4 the 832S run only with the defautl MS atapi driver
    (I made several attemps with older VIA driver, but only the default MS let me set the DMA)

Anyway, at moment all seems to work, but I made just a couple of burns (DVD-RW backup of my data)

Gio

Hey, cool to see that the 832s runs well under Win NT, I’ve never had to use a DVD Burner under NT before but I have a client who is “all NT” (license wise) and will require a DVD burner for “backups” so now I know which burner to suggest that they purchase for use with NT. :slight_smile:

By the way, which burning software are you running under NT?

Thanks!

Nero 6.3
I got this software together the retail version of the 832S.