New firmware versions released for Premium and PX-708A drives!

vbimport

#1

Plextor Europe has released new firmware versions for the Plextor Premium and the Plextor PX-708A drives:

[i]Premium firmware v1.04:

Added:

[ul][li]Support for writing on 32x Ultra Speed CD-RW (Mitsubishi [*]Chemical Media SW74GU1).
[/li]> [li]Support for newer CD-R media[/ul]Improvements:
[/li]> [ul][li]Write quality on Ultra Speed CD-RW media.
[/li]> [li]Write and read performance of GigaRec[/ul]PX-708A firmware v1.01:
[/li]>
Fixed Bugs:

  • [li]Compatibility with Dantz’s Retrospect, Roxio’s Drag to Disc and other utilities

[/li]> [ul][li]Write performance for 8x writing on DVD+R media.
[/li]> [li]Write performance for DVD-R media.
[/li]> [li]Write performance for DVD-RW media[/ul][/i][/li]


#2

I was just wondering, are all premium drives the same whether you live in canada or europe? Because i live in canada and didn’t see the firmware on the north american site and was wondering if i could use the firmware from the european site.


#3

As long as i now they should be the same - btw has anyone tested the new firmware yet?


#4

Firmware versions that are released on the Plextor Europe website can be used for any drive, regardless where you bought it. I have installed both new firmware versions without a problem.


#5

Firmware upgrades seem to show up much sooner on the European site than the North American. I have never had a problem applying firmware upgrades downloaded from the European site to my (North American) Plextor drives.

Originally posted by joso__g
I was just wondering, are all premium drives the same whether you live in canada or europe? Because i live in canada and didn’t see the firmware on the north american site and was wondering if i could use the firmware from the european site.


#6

I find it very odd that it took Plextor this long to release the 1.01 firmware for the 708A when they have had drives on the store shelves with this firmware for a while.


#7

Kinda debating myself on whether or not to update, will this update affect the ability the back-up SecuRom? Hmm…


#8

@kamikazee
thats exactly why i asked if anyone tested it :slight_smile: - does anyone know if its possible to “downgrade” the plextor again?


#9

first and most importand question:

is SecuROM back-up still supported with firmware 1.04?

seccond and also pretty importand question:

is the plextor backwards flashable? (eg. have 1.04 on it and flash it back to 1.03)

i dont have a real reason to update the firmware to 1.04, dont have any problems with 1.03 first wanna be absolutely 100% sure about the SecuROM question or the backwards flash ability before i even start thinking about updating.


#10

So the main question is: Who’s gonna try it first!! :wink:


#11

Well, now you’ve got the answer… me :bigsmile:

My Premium is TLA0001 May 2003.

A little bit scared, I proceeded to update the firmware to 1.04 without any problem.

Securom 4.8x again is no problem with Blindwrite and Premium. I made a copy of Bloodrayne successfully :wink:

Safedisk 2.9 again IS a problem. I can’t copy Devastion with the new firmware :frowning:

Ah, by the way… I could go back to 1.03 easily… no problem.

Uffff, now I can take a relax and a big breath :cool:


#12

I was able to backup a Safedisk 2.9 Disk using Alcohol 120%…


#13

These are the media codes I found in the PX-708A 1.01 firmware:


DVD+R                            DVD+RW
BEALL P0001  (BeAll 2.4x)        CMC MAG W01  (CMC Magnetics 2.4x)
BeAll000P40  (BeAll 4x)          INFODISCA01  (Infodisc 2.4x)
CMC MAG F01  (CMC Magnetics 4x)  MCC     A01  (Mitsubishi 2.4x)
DAXON   AZ0  (Daxon 2.4x)        MKM     A02  (Mitsubishi 4x)
FUJIFILM003  (Fujifilm ?x)       OPTODISCOP1  (Optodisc 2.4x)
LD      001  (Lead Data ?x)      PRODISC W01  (Prodisc 2.4x)
MAXELL  001  (Maxell 4x)         RICOHJPNW01  (Ricoh 2.4x)
MAXELL  002  (Maxell 8x?)        RICOHJPNW11  (Ricoh 4x)
MCC     001  (Mitsubishi 2.4x)   RITEK   001  (Ritek 2.4x)
MCC     002  (Mitsubishi 4x*)    SONY    S11  (Sony ?x)
MCC     003  (Mitsubishi 8x?)
MPOMEDIA001  (MPO Media 2.4x)
OPTODISCOP1  (Optodisc 2.4x)
OPTODISCOR4  (Optodisc 4x?)
PRODISC R01  (Prodisc 2.4x)
PRODISC R02  (Prodisc 4x)
RICOHJPNR00  (Ricoh 2.4x)
RICOHJPNR01  (Ricoh 4x*)
RICOHJPNR02  (Ricoh 8x?)
RITEK   R01  (Ritek 2.4x)
RITEK   R02  (Ritek 4x)
SONY    D01  (Sony 4x)
TDK     001  (TDK 4x?)
TDK     002  (TDK 8x?)
YUDEN000T01  (Taiyo Yuden 4x*)

*)Burns in 8x on the Plextor

DVD-R                            DVD-RW
1FUJIFILM                        JVC/VictorT7
BeAll G00001                     JVC_VictorW7
BeAll G40001                     MCC 00RW11N9
CMC MAG.                         MCC 01RW11n9
CMC MAG. AF1                     OPTODISCK001
CMC00RG200                       PRINCO
DAXON004                         ProdiscDVDRW
FORNEX001                        PVCW000001Q9
FUJIFILM02                       PVCW000002A9
GSC001                           PVCW00D002K9
KIC 00RG200                      RITEK000V11A
KIC01RG20                        RITEK004V11
LD                               RITEKW01    
LEADDATA01                       SONY000000U9
LEADDATAA01                      TDK501saku]3
Lead Data                        TDK502sakuM3
LONGTEN 001
MBI
MCC 00RG200
MCC 01RG20
MCI4XG01
MCIG01
MEI 00V001
MXL RG01
MXL RG02
NANYA P1861
NANYA-JC001
OPTODISCK001
OPTODISCR004
PRINCO
PRODISCG02
PVC001001
PVCR001002
RITEKG01
RITEKG02
RITEKG03
RITEKG04
SKC Co.,Ltd.
SONY04D1
TAIYOYUDEN
TAROKO-X2
TAROKO-MX4
TDKG010000
TDKG02000000
TTG01
TYG01
UTJG01001


#14

More info PLZ :bigsmile:

hallo51


#15

Originally posted by Dufroise
[B]Well, now you’ve got the answer… me :bigsmile:

My Premium is TLA0001 May 2003.

A little bit scared, I proceeded to update the firmware to 1.04 without any problem.

Securom 4.8x again is no problem with Blindwrite and Premium. I made a copy of Bloodrayne successfully :wink:

Safedisk 2.9 again IS a problem. I can’t copy Devastion with the new firmware :frowning:

Ah, by the way… I could go back to 1.03 easily… no problem.

Uffff, now I can take a relax and a big breath :cool: [/B]

where you able to copy SD 2.9 with the 1.03 firmware?


#16

Originally posted by Maelstrom
where you able to copy SD 2.9 with the 1.03 firmware?

Sorry, I’m afraid not… bad luck. I think that firm 1.04 works at least as 1.03 does. Probably better… I was able to copy all Securom 4.8 but Colin McRae Rally 3, I don’t know why. This evening I’m going to try 1.04, and I’ll see if 4 is better than 3…


#17

Ok, folks, This is going to be a silly conspiracy theory question, Since this update was released 1 day after the new law took affect in Germany is it possible that Plextor could fall in line and negate the safedisc copying abilities, mine has been copying safedisc 2.90 without fail so far, so you can see why the question. the reason I would even consider the update is the 32x cdrw compatability.


#18

Hi
Having installed the new firmware upgrade for FX-708A , can you go back to the previous version (V1.0) and how? Not that I have any problems with the new upgrade, in fact it works 100%, but just for curiosity.

Stelios


#19

Originally posted by kamikazee
Ok, folks, This is going to be a silly conspiracy theory question, Since this update was released 1 day after the new law took affect in Germany is it possible that Plextor could fall in line and negate the safedisc copying abilities, mine has been copying safedisc 2.90 without fail so far, so you can see why the question. the reason I would even consider the update is the 32x cdrw compatability.

Sure, if I had a Premium that could copy SD 2.9, I wouldn’t try and upgrade the firmware. It’s the perfect burner!!! And I think the 32x compatibility is a secondary matter. Well done, Kamikazee… And if someday you need to upgrade, I say again that it was possible go back to an earlier version :wink:


#20

Ive got the Plexwriter Premium TLA 0001 from April too, and after the update to version 1.04 nothing went to bad. I could copy any copyprotections like before, but SD 2.9 doesnt work!

greets

vbgd