New firmware for PX-712A : v1.03

On http://www.rpc1.org I found a new firmware for the PX-712A : v1.03. :eek:
You can download it from :
http://forum.rpc1.org/dl_firmware.php?download_id=1826

I checked the Belgium, the Japanese and the American website, but I found
nothing about firmware v1.03. All these Plextor sites list v1.02 as the latest. :rolleyes:

Anyone found a change log or even already tried this new firmware ?
I feel a little uncomfortable to flash my expensive drive with this version…
Who will give it a shot and report his findings back ?? :wink:

Pat357

Plextor’s ftp site(ftp.plextor.com) is indicate that the folder not found…

   550 /DVD-R Firmwares: folder not found

So as I always say: There’s something going on :bow:
Let’s hope it’s good :slight_smile:

Well, I found this firmware on cdrinfo.com this morning, downloaded and flashed. Burned several DVDs since without any problems. Have no idea what the changes are, though.

Anyone tried SecuRom 4.8x maybe the px-712 in now able to burn SecuRom 1:1 copies !!!

hallo51

The mount time of the created DVD-R media became short. :o
Since I am not a resident in the English area, grammar may be amusing.
Please forgive. :bow:

First of all i’ve got my plex 712 since monday and i’m very hungry about it, i’ve done so many coaster burning dvd-r, so i tried the new firmware and now with nero when he finished he give me can not do disk at once error so i return back to 1.02,anyway maybe it’s the dvd-r i’m using but if i use the nec 2500a with the same dvd-r never had problem…
and i thought the plex was the best…

No burner works flawless with all blanks available in the market. Go to Plex’s website and look for recommended media. And yes, there is a reason why cheap media are cheap. :smiley:

I generally burn DVD+R media but my Plextor PX-712A works great with everything I’ve thrown at it, including DVD-R media.

I wonder what the changes in this firmware version are…

I second that … :bigsmile:

Hi guys,

guess what I’ve just found here:

http://www.plextor.jp/download/firmware/px712up.html

Translated with babelfish it reads as:

“Ver. 1.03
The record efficiency improvement of DVD
DVD-R mount time shortening of media
Correction of the trouble which is the times when you recognize DVD+RW which is recorded with other companies as blank
DVD+R DL disk lead/read functional support”

By the way you can officially download this firmware from here:

http://www.plextor.jp/download/internal.html

Nice :slight_smile: … if it improves the writing quality on most 8x media (see here :a ) then I’ll be even more pleased …

Have fun :slight_smile:

Very strange :
the 1.03 firmware for PX-712A a) from Japan : 223 Ko
b) rpc-1 : 669 Ko
Explanation ?

Very sorry but the first time I downloaded the firmware I received a file of 223 Ko ! I tried again and now , it’s 669 Ko.
Many thanks for the job you’ve done.

Hi cvs, welcome to the forum and thanks for informing us!

Just tried 1.03 with Verbatim DVD-R 8x (MCC 02RG20 Singapore made) (at 8x with latest Nero) and I’m delighted that the Sum8 PI has dropped from max 900-1000 (1.02) to 180 (1.03) now making this media useable at 8x. Fuill DVD burns in just over 8 mins. Well done Plextor.

I might even forgive them for having this media on their “recommended” list 3 weeks ago (when I purchased 50) - then relegating it to the “compatible” list - finally disappearing altogether from the compatible list a week ago… :a

Will report about Verbatim’s DVD+R 8x later.

Congratulations for all your tests.

It’s hard to be humble when you’re the best !!!

Lately, I bought a spindle of 25 DVD+R 4x Philips (probably made by Ritek, according Plextools 2.14). On my PX-712A rev 1.02, and with Nero Recode2, selecting the speed 4X, the burning sequence begins at 4x and after a while skips to 8x !!! I precise that the copy works FINE !!! Very good DVD+R, I guess.
I intend to change 1.02 to 1.03 before long and I’ll keep you aware of the results.

It’s a known fact that the Plextor PX-712A can burn quite a lot of 4x DVD+R media at 8x.

Hi @all!!

here a scan with the new FW 1.03.
until now, my best scan ever!!!

The One, DVD+R (8x cert.)
@12x with ImageBurnTool
Nero…15

just fantastic.
unfortunately only 3,1 GB
:eek:

but fine enough for me…

CU
lou


Released 1.03 at Plextor Europe!

Plextor USA updated too