New Firmware coming today for 1620?

vbimport

#1

Just looked over on the BenQ homepage and went to click on the download center and got a “This page is currently updating” with a little worker digging animation. Does this mean we’re going to see new firmware for BenQ DW1620A’s today? :slight_smile: B7N9 perhaps? hehe


#2

I don’t think so. I’m on the firmware page now.

http://support.benq.com/front/BenqMain.asp?MenuHead=128&ShowType=program&FileURL=service/driverlist.asp&Dataid=16041&downloadclass=Driver&product=3731&langu=null&ops=null&GenMenu=&RootId=undefined


#3

I don’t understand why from B7M9 jumped to P9, no N9 or O9. Before P9 it was just right, according to Hef’s link above, from J9, K, L, and M. And there’s an S9 released already, unofficially, so from P9 jumped over Q and R. Me curious.


#4

Not sure why N9 or O9 and the straight jump to P9 but I someone here had said that S9 is mainly a Firmware that is designed to handle cheaper media better over in Asia or something that like that. I’ve been using it and love the results it gives so far for the most part so don’t intend to change until a new version of our firmware comes out. :slight_smile:


#5

If you’re getting good results with B7S9, then that’s great news. But, I won’t use it because I don’t own crap Chinese media that it was supposedly made for. People have argued whether or not B7S9 is better or worse than B7P9. I have also heard people say that flashing to B7S9 screwed up their burns. Plenty have also stated the opposite. If B7S9 works for you, then all is well. I have B7P9 and won’t change it until BenQ’s global website updates with newer firmware. I don’t want firmware that’s only regional (China) and made for garbage DVD-R media. :slight_smile:


#6

B7N9 was an interim firmware found on some DW1620A just before the DW1620Pro (with B7P9) was released. btw, this B7N9 deos not seem to be available for download anyway. A few of the local buyers in SG had this firmware on their new burners bought in a recent PC show last month.

And the B7S9 was apparently meant for the China market mainly to cater for certain lower grade media found there.


#7

FYI, the guy who posted that S9 screwed his burn already clarify that it was Nero 6.6.x.x version and he stated that he is now using S9.


#8

Not necessary, S9 has two improvement over P9

  1. better burn result for CMC media
  2. able to read DVD burnt by Panasonic DVD writer which P9 was unable to, a user speculate that S9 was not released here was because Panasonic DVD writer is not popular in N. America.

#9

heheh, my info on B7S9 is as quoted from BenQ reps. Of course, both of you may still be right though, this is just info for you to ponder over.

Anyway, do note that I used “mainly” and not “solely” in my post and I wouldn’t bet my life that there are only “two improvements” in B7S9 too.

:slight_smile:


#10

Hi, It was me that started the thread about B7S9 dammaging my drive. Initially I thought it was not the firmware but nero but now after alot of troubleshooting i’ve come to the conclusion that it was the firmware. Seems like using .cvt file with the flasher to flash your BenQ isn’t a good idea. What screwed up my drive was a combination of using .cvt files instead of the .exe and updating to B7S9 firmware. Now i’m running B7P9 with the latest version of nero 6603 and getting consistent good quality burns as before this whole episode. See, after getting my BenQ 1620 oem drive i followed the 3 step method of converting my drive to the retail version. So the last two firmware’s i had flashed were B7L9 and then to B7P9 in that order using the .exe files from BenQ’s site. And I was getting fabulous burns with all +r media and the error rates were specifically low towards the end of the dvd which was great. Then B7S9 came out and i gave that a try, and i noticed higher PI failures at towards the end of the discs with a couple of discs I had burned, I immediately switched backed to B7P9 but couldn’t get the same results anymore. Then I rolled backed to version 6601 of nero but still i wasn’t getting consistent burns. Now, when i had went back to B7P9 this time it was using the .cvt file and flasher. So, I tried using the original .exe file that i got from BenQ site and still i was getting bad results. In the end I tried this, I flashed the firmware back to B7L9 using original .exe restarted my computer burned a full dvd using nero cd-dvd speed, flashed to B7P9 using again the original .exe (original meaning not hacked one or rpc1) restarted my computer and started getting good consistent quality results again with very low error rates towards the end of the dvd, just like i was getting originally. The huge error spikes at the end of the dvd had dissapeared. And this time it was permanent. I have burned more then 20 dvds after this and gotten good consistent results and not a single coaster. So anyone who’s getting big error spikes towards the end of the dvd can try this method. It worked for me. By the way, i’m using nero 6603 and there’s no problems with it. I think the whole problem with the spikes towards the end of the dvd lay in flashing to B7S9 and using .cvt files.


#11

I have a problem with cvt file as well, I had P9 and then tried S9 and when I switched back to P9, I didn’t use the exe file but cvt instead and all of a sudden all my burns won’t pass Nero cd test, an error message “no additional sense information” will appear right at the end of each test, altho all of them will play without problem with my standalone, after reading your message, I reflashed it to S9 this time with the exe file and what do you know…no more error message even with the previous ones.


#12

I, too had this error message “no additional sense information (00000000)” or something like that. My discs played fine also. When I would test same disc on my other BenQ, NO Error Message.
As I have flashed both my drives back & forth with cvt as well as exe flashes, I was not so quick to pinpoint where this error came from. Now as I read your post, I realize the error free drives were exe flashed, not cvt. Corruption of the cvt file on my system is certainly possible, so I do not want to scare folks. I have flashed both my drives back to earlier versions of B7xx or 47xx, using BenQ official exe flash programs. Then have flashed up also using exe from BenQ.
Thanks for clearing up this mystery for me.


#13

You’re incorrect as SonnyUnlocker has already told you. Nero was not the problem but the firmware was.