New Firmware 1.03 for the PX-708A

new firmware for the PX-708A :

Fixed Bugs:
The PC may hang when writing and erasing are repeatedly carried out on DVD+RW media.
Some drives cannot mount the DVD-RW media that was formatted for the first time on PX-708A.
Improvements:
Write performance on DVD+R media.
Write performance on DVD-R media.
Write performance on DVD-RW media.
Support for newer DVD+R media.
Support for newer DVD+RW media.
Support for newer DVD-R media.
Support for newer DVD-RW media.
Support for newer High Speed CD-RW media.

source :
Plextor Europe

download

it was about time…
I will test my Sony DVD-R discs tonight to see if it is recognised now.

The new supported media seem to be mainly DVD+RW. I found the following new media codes in 1.03 vs. 1.02:


DVD+R                            DVD+RW
LD      002  (Lead Data 4x)      CMC MAG W02  (CMC Magnetics 4x)
MBIPG101R03  (Moser Baer 4x)     INFODISCA10  (Infodisc 4x)
                                 MBIPG101W03  (Moser Baer 2.4x)
                                 NANYASC DRW  (Nanya 2.4x)
                                 PHILIPS 010  (Philips 2.4x)
                                 PHILIPS 041  (Philips 4x)
                                 PHTEST  RW4  (? 4x)
                                 PRODISC W02  (Prodisc 4x)
                                 RITEK   004  (Ritek 4x)
                                 SENTINELW01  (Sentinel 2.4x)
                                 TDKplusWt12  (TDK 4x)
                                 
DVD-R                            DVD-RW
                                 CMCW02       (CMC Magnetics 2x)

Thanks for the information!

There must be more jsl.

as BEALL and INFOSMART01 4X DVD-R do now work, they did not work before…

Still do not work:
Ritek G04 4X DVD-R (writes a coaster)
Princo 4X DVD-R (only some types)
Princo 2X DVD-RW (not detected or power calibration error depending on the type…I’ve 4 differrent princo 2X DVD-RW disc types here).

Sony 4x DVD-R still does not work…
probably princo made but cannot confirm

Beall have been there already in previous firmwares but I assume they are included in the improvement of “Write performance on DVD-R media”.
Infosmart is not in v1.03 but the performance on generic media might have improved too?

BTW about the Princo 2x DVD-RW, are these discs actually working on any DVD burner (including rewriting several times)? I’ve got the impression that they are really bad media.

Why does this firmware upgrade not show up in the Plextor site for North America? Are there any key differences between the 708A sold in Europe or elsewhere as opposed to the ones purchased here in America?

No there is no difference between european and american firmware.

But plextor america is always lazy and slow to update the site, normally lagging behind with 2-3 days.

jsl: ALL my four different princo 2X DVD-RW discs works in my memorex dual-x. On the other hand they do not work in the LG GSA-4040B…

In case anyone wonders how my ritek g04 coasters looks like:

You see that different colored ring? Yeah that is where it’s unreadable, 18% into the disc…

The drive must select wrong write strategy or something for that area.

The discs is branded datasafe/datawrite, only ritek g04 brand I’ve found in Norway. The discs works fine in all other drives I’ve tested them in.

Hi,

Is there anybody who tried the firmware 1.03 alyet?

I like to try it but i’m a litle bit scared to update because the last time when i did it it failed.

stony

Hey there,

I posted a new tread sorry i wanted to post a reply. sorry.

But my question is;

Is there anybody who tried the firmware 1.03 european version alyet?

I like to try it but i’m a litle bit scared to update because the last time when i did it it failed.

stony

Upgraded this morning without a problem. When I upgrade my firmware I simply close all apps that are running and start the EXE-file and after flashing I let it reboot.

@OC-Freak
Very strange your G04 problem. I’ve written around 30, so far no coasters burn quality beiing on par with my late Sony 510A. Probably you have a faulty batch of discs?

Originally posted by surg
@OC-Freak
Very strange your G04 problem. I’ve written around 30, so far no coasters burn quality beiing on par with my late Sony 510A. Probably you have a faulty batch of discs?

Maybe, but why do they work excellent in all other tried DVD-Writers then?

Strange, really strange. On rpc1.com forum users also reported g04 burning o.k.

I upgraded yesterday and had no problem at all. The drive is still working as it should.

I’ve been using some Shintaro -R 4X media (they’re Princo anyway) and had no problem. So far only one type of media didnt work with my baby, but I couldn’t get the code/manufacturer for it.

Great stuff, already burnt a whole stack of movies :wink:

I burned a coaster with my first try with 1.03 qnd Nero 6.0.0.19. I am going back to 5.5.10.54. All these burns are being done on Memorex 4X DVD+R JPNR01.
Well I just installed Nero 5.5.10.54 and tried to burn the same DVD+R and got the same fixation error and Could not close disc error. Tried BatchFix and DVDDecryter and no luck so coaster number 2. I am going to go back to Firmware 1.02 and see what happens. Well I went back to 1.02 and this time it burned successfully with Nero 5.5.10.54. So much for 1.03. Way to go Plextor. Before when the disc did not close I got (invalid field in command) not (session fixation error) before the (Could not perform end of disc at once error) which I closed with BatchFix. Session fixation errors started with 1.03 which made 2 coasters. I wish I had stayed with 1.00.

I am using Nero 6.0.0.11 without any hickups. RNM 4.61 with burn engine 500 works too, only drawback being not able to set speed i.e. it always burn at max.

Hi OC-Freak,
May have an answer for you. I also had the same coaster problem as you with Traxdata x4 (Ritek g04). My drive spec was ver. TLA:#0000 firmware 1.03. A few days later the drive stopped burning or reading to any CD/R/RW media, but burning or reading to DVD/±R/±RW worked fine expect Ritek g04. Drive sent back via RMA DOA since it was less than 14 days old. New drive arrived 3 days later! (Great RMA support). New drive was a ver. TLA:#0002 with firmware 1.02 and so upped to 1.03. Then when I burnt a the Traxdata disk not issues found. Have since burnt 3 more with no problems. I can not say for sure but could the model revision spec I.E. TLA:#0000 – 0002 be the issue?