NEW! DRM REMOVAL! April 6th 2005

vbimport

#1

Well it’s already all over the blogs so I better share before it gets fixed!

You need to obtain a version of MusicMatch Jukebox v6.1.
Install it then go to file -> convert
Open the folder with your .wmas ( make sure to select .wma from .wav at bottom ) select what you want to convert and select an output folder ( by default it will overwrite your current wma’s.

F.A.Q:
Q: Does this work with Napster?
A: yes

Q: Do you need to uninstall napster or reset any settings?
A: no

Q: Do you need any other program for this to work?
A: no

Q: Why am I seeing the converted files as 129kbps?
A: Not sure but when you convert to .mp3’s it will auto turn it back into 128kbps

Q: Do you lose any quality?
A: Not really sure here, the method it uses is not quite 100% confirmed yet. From my observations it works like any true record program but with a much faster record speed ( wierd huh ) if you notice when it is converting it will give the song duration and duration completed. Most true converting programs ( Virtousa ) do not do this since they do not record.

Q: Can this method be fixed?
A: Possibly if it works like I said above it will be a major loss for the music industry since it will not beable to be fixed ( all you would have to do is update the input wma codec for musicmatch ).

Few Notes:
The encoder is about 5 years old we don’t know for sure if you lose quality or not.

MAKE SURE YOU SELECT A NEW OUTPUT FOLDER OR ELSE IT WILL OVERWRITE YOUR PROTECTED WMA’s.

Ask questions people and enjoy! MAKE SURE YOU GET v6.1 of MusicMatch!


#2

If you need MMB 6.1 i found this > http://www.oldversion.com/program.php?n=mmatch


#3

The “Rat” says: “works like a champ!” Way to go xfuzion!!! :bow:


#4

This does not work on a consistent basis, at least with Virgin music files. BTW, Virgin forced a software upgrade earlier today.


#5

It still works with napster 100% :slight_smile:


#6

For two or three people thus far. Many are also reporting it does not work, so this is not a consistent/reliable workaround. It’s also open to the same fix Virtuosa did to stop it. Musicmatch can simply revoke its older version .wma secure playback license and that is the end of that.


#7

Dampier I still have it running using napster .wma’s.

I think Virgin Digital has updated their software to fight back at MM.

However, your assumptions of this being fixed are incorrect. If the program does indeed work as I think it does ( accelerated recording ) rather than true bitrate conversion ( Virtrousa ) then there is no way to fix it likewise to current recording software.

The thing is they can update their drm to block it but all you would have to do is update the input/output plugins to accomadate it ( since it is recording not conversion ) we really have no idea how it works though and it’s a 5 year old encoder.


#8

You cannot play a protected .wma file unless the software you use has a license that authorizes that. That’s the whole point of DRM… it can control every aspect of a protected file. In order for MM to record a song to convert it, it has to have the right to play it. Take away the license and MM will not be able to play the file in order to re-record it, accelerated or not.

An excellent example of this would be that if, indeed, Virgin has blocked the MM method, they have just proven my point because what worked a few hours ago on one song I tried no longer works.


#9

Also, see if the method still works after you reboot your machine. I’m trying to be optimistic and find some way of making this work consistently, believe me. But we need to better document the steps so this works for everyone consistently.


#10

I have already rebooted as well.


#11

Doesn’t work for me…goes about 4-6 seconds in and stalls; as well as leaking all possible memory until the system starts crashing.


#12

That’s my story as well. I just tried uninstalling Virgin (for awhile Napster tracks would convert with Virtuosa if you got rid of Napster) and it’s still a no-go. I’ll try rebooting and messing around with it later tonight.


#13

A reboot doesn’t solve anything post-Virgin removal.


#14

it won’t even install on my computer whenever it is done and i try to open it is says it has caused and error and would u like to send an error report


#15

I did manage to get it working in VMWare install of SP2. Only things installed were WMP10, Tunebite, Napster…

Only caveat I see so far is that for some reason it returned errors on newer downloads–but worked when I went back and did them again; and that obviously tracks purchased from another system can’t be played/converted.


#16

Can anybody else except bowrat confirm that this method works?
It seems that DRM licenses are updated every month, and if my theory is correct, people who can manage to get this to work still have their older DRM (before updates), while the current ones will have this loophole plugged.
BTW, what’s the conversion rate for this method?


#17

Still working here - but I just started Virgin Digital, and noticed the update. I DID NOT download any new songs from V-D, and then I went back and tried a bunch of NEW downloads from Nap - it is still working. It doesn’t make too much sense, because I have it working on 2 of 3 PCs at my house. (I haven’t tried the 3rd)
I keep all of my PCs updated on windowsupdate.com - I stay away from auto-updates, I like to CHOOSE what is updated. If I notice anything different, I’ll repost…

KUCING - email me!


#18

Hey Bowrat, glad to hear your still alive and kicking. Check your email. :wink:

Looks like Micro$oft is really pushing this DRM thing. Beware on April 12, everybody running XP is going to get SP2 shoved down their throat.
You can read all about it here, here, and here.


#19

Yeap and quick fix = turn off auto updating.


#20

Found out the reason it no longer works with Virgin Digital and how I was correct in my theory on how MusicMatch converted it.

#1) MusicMatch’s converter is like real time recording but at a much fast speed ( don’t ask me how )
#2) Virgin Digital Licenses contain “Collaborative Play Not Allowed” While napsters still do not. Collaborative play means no player but WMP can play them while recording or something… I’m not 100% sure but MuvAudio still works.