NEW conflict with Bypassing Napster Copyright

vbimport

#1

Hello All

Been very happy lately with all the free stuff from Napster along with the WinAmp conversion, couldn’t be happier.

I have hit a bit of a snag. When I go to play the WMA files in WinAmp to start the WAV conversion, I get a message saying:

“Please Select DirectSound Output Plugin to Play Windows Media Content.”

I have not downloaded any new software or update (those of which I am aware of). I personally think the problem lies within Napster and them “fixing” the whole WinAmp conversion. I also cannot seem to find the Output Stacker plug-in on WinAmps website anymore. Could the new Winamp version be “fixed” too? I also tried reinstalling everything, I also deleted the registry, I tried older versions of WinAmp.

Please help guys, I have a hilarious George Carlin cd I downloaded and am desperately waiting to put it on my iPod.

Dave C
Long time visitor, first time poster…on any website.


#2

To me it doesn’t sound like anything having to do with updated DRM protection. Real time recording cannot ever be patched. Try doing what they said… selectinga direct sound output plugin.

EDIT: Aaah, sorry for bumping such an old thread. I thought I clicked New Topics but I was actually in a search.


#3

In the recent versions of Winamp, they have updated the in_wm.dll file to only work with plugins containing the keyword “waveOut” or “DirectSound”. If the selected output plugin does not contain these keywords, you will get the error “Please Select DirectSound Output Plugin to Play Windows Media Content.” if you try playing a WMA file, whether protected or not.

It also appears that they have designed the plugin to crash Winamp if the output plugin does contain those keywords, but is neither of Winamp’s regular waveOut or DirectSound output plugins. For example, if you were to try and edit the out_disk.dll such that Winamp sees it with the title “waveOut output v2.0.3” for example, Winamp will crash as soon as you try to play a WMA file, although it will play and use the modified plugin with other file types.

I have tried using the Output Stacker, but can confirm that Winamp (at least recent versions) will give the same errors when attempting to play WMA files also.

Another option that may be worth trying is to get an old WMA plugin for Winamp, such as the one on Rarewares. This one allows the use of the Disk Writer plugin, however I’m not sure if it will play Napster’s music since it is about five years old. On the following site, go to the section “Alternative WMA plugins for Winamp”. The file contains two out_wm.dll plugins (one in a folder called ‘Peter’), so try the one that is in the top level folder:

http://www.rarewares.org/others.html

If the above plugin does not work, probably your best option is to re-record the music as it plays such as using TuneBite, GoldWave, or any other utility that records audio. Just be sure to mute all the recording channels apart from Wave and master. If there is no Wave volume selection in the recording channel selection, then select ‘Stereo Mix’ and mute everything in the playback channel selection apart from ‘Wave’ and 'Master. While this may not give as perfect conversion as a direct WMA to Wave conversion, any hiss or distortion introduced is generally much less than the audible artefacts I notice in the original WMA file anyway. :stuck_out_tongue:


#4

I think that they patched goldwave. I just tried to open a song, and it popped up the “this file is protected and you cannot open it” screen


#5

Did Goldwave re-record your music?


#6

no. It wouldnt even open the file. And I tried with WMP, and Gwave just didnt record. It might have been me, or it could be a patch.


#7

I’m guessing it’s most likely just you because I don’t think Microsoft has the authority to patch a legal program. It has to be one of these options:

  1. The creaters of GoldWave did this.

  2. Microsoft made it so that DRM’ed files can’t be played through an SDK (very unlikely since that would mean other re-recording programs wouldn’t work).

  3. It is just you.

I’m leaning toward option number 3.


#8

To record audio in Goldwave that is playing back from another application such as Windows Media Player, you will need to set your recording mixer either to ‘Wave’ or ‘Stereo Mix’ depending on your sound card:

[ol]
[li]Click Start -> Programs -> Accessories -> Entertainment -> Volume Control[/li][li]Click the ‘Options’ menu and click ‘Properties’[/li][li]Tick the ‘Recording’ option.[/li][li]Tick all the boxes in the section “Show the following volume controls:” and click ‘OK’. (This brings up the recording mixer)[/li][li]If a ‘Select’ tick box is shown within each volume control, then tick the ‘Select’ box for ‘Wave’. If there is no ‘Wave’ volume control shown, then tick the ‘Select’ box for ‘Stereo Mix’[/li][li]On the other hand, if a ‘Mute’ tick box is shown within each volume control, then mute everything except ‘Wave’.[/li][li]Drag the unmuted or selected volume control up to max.[/li][/ol]The following screenshot is from my recording mixer:

Now you should be able to re-record from Windows Media Player or pretty anything else that plays back audio.