New Burner and Rom Problems, Please Help!

Hi, I am new here and in need of help as i am beyond frustrated and have searched and searched and cannot find an answer. I have two issues that hopefully can get resolved.

  1. I just installed the BenQ-DW1655 today and am having issues, :frowning:

My computer recognizes the drive in device manager correctly as BenQ DW-1655 but it will not read or play any kind of discs!! It will not even acknowledge a disc in the drive.

Nero info tool recognizes it to and the firmware says BCAB.

I am starting to think it was DOA.

  1. I installed a Liteon SOHD-16P9SV DVD Rom also and it will not recognize a DVD or the PowerDVD Software install cd but will recognize the BenQ tools install cd,

I am very confused and would appreciate any recommendations.

Also i am running Windows XP and have tried several settings- such as slave, master, etc. As a side note i also have a Sony DRU-500A hooked up and it works fine.


Who made your BOX?

Bios update/mobo drivers update/bios settings
remove all your extra software for burning and duplicate copies of software
disk clean
clean broken links with Nortan or Spybot!
Clean your system of spyware and do a scan with antivirus
try one drive at a time as master
set it to auto/DMA in your IDE pull down in device manager

Use only one player program active/get rid of all the others.
Remove INCD in Nero and DLA in Sonic!

A pointed out by etp, probably some softwares and drivers interfere and conflict each other.

Also uninstall both IDE channels and the drive entries in devicemanager, then reboot.

I have done all that was mentioned and keep my compiter udated and cleaned on a regular basis.

As far as the BenQ DW1655 i came to the conclusion it is a dead drive. I came to that conclusion when i installed it on another computer and still no success. That drive is being RMA’ed.

As far as the Liteon SOHD-16P9SV everything seems to be ok accept for the PowerDVD install disk. I think that disk is defective as it will not read in any of my other drives as well.

Thanks for the advice! :slight_smile:

Good to see you have solved the problem!