New Boards and Sata Controllers and Optical Drives


#1

One of my PC have only Sata2 Intel Controller onbaord and the other PC have one 2 Port Marvel a little bit slow SATA3 Controller onboard and a lot of more Sata 2 Ports.
On the only SATA 2 PC i have an SATA 3.0 PCI-Express card for the SSD and all intel SATA 2 Ports run in IDE Compatible Mode.
On the SATA 2/3 PC i can choose wich port have AHCI and wich not. I choose SATA 3 yes and all SATA 2 no.

So in the Future when i buy a new Intel Board (Skylake or more Kaby lake or the Kabylake -X Chipset) or maybe is the same on all AMD Ryzen Boards… i read only SATA3 Ports… So of course when its only one Controller its AHCI then for SSds…

What did you do with these newer systems? When the optical drives dont work with AHCI`?

Running the mainboard controller on AHCI. Plug in other older non raid (SATA1/SATA2) cards for the optical drives without AHCI? And wich one?

Or did you choose IDE Compatible Mode if its still avaible and plugin SSDs and SATA3 HDDs on an extra Marvell, AS Media or something else SATA 3.0 Card?

I hope its the right forum here… if not move it pls on the normal hardware forum.


#2

You run the controler in AHCI mode, I never had an issue with intel and SATA2 or SATA3 ports, all my optical drives worked perfect, I can only assume that they same will apply to the AMD side.

I will avoid the IDE mode, there is nothing to be gained from using it. Maybe only if you have some strange compatibility issue.


#3

Just reading and burning works most time in AHCI… But some kind of special software like cd/dvd speed have problems to find drives on some pcs. Not only on my pcs.
IDE/SATA Adpater to Usb 2.0/Firewire/ USB 3.0 always works on my pcs but of course i dont wont to have 2 or 3 optical drives always on the table when you can have it inside the old PC Cases with more 5 1/4 Zoll bays.


#4

I did not have any issues with CDspeed seeing all the drives. All my drives are detected and all their features work.
If I needed something special I would prefer to have an old PC, like an i5 750 and have that run in IDE more, thats in the very extreme case that i need a function that for some reason did not work on a newer system.

The IDE/SATA to USB2 solution is very appealing and should work without any issues.


#5

Out of curiosity, when I built my RyZen x370 system, I tried a very old LG Super Multi Blue GGW-H10N BD drive. It worked without any issues.

The drive isn’t in the system now, in fact I have no optical drives in the system. I have a USB optical drive, for the few occasions that I may need to read or write optical media.

The LG Super Multi Blue GGW-H10N dates back to 2007, so if a drive that old works on a new motherboard in ACHI mode, then compatibility seems pretty good.


#6

Can´t say something about Ryzen or Sky / Kaby Lake, but on Intel B150-Boards actual drives should be work flawless (LG).

Older AMD-Boards can also used in mixed Mode, some ports AHCI and the other IDE

Should there really be a problem, get an cheap PCIe-controller with Marvell or Sil-Chipset


#7

I am using a Samsung 203 on an ASUS H110-A motherboard, and everything is fine, as @Dee said there should now be any compatibility issue,

I will assume that the same will apply to any PCIe expansion card, I dont believe that optical drives need any special commands to work, and do the job that they were made to do.


#8

Generations before the B150-chipset works flawless in general.

The only chipsets I remember which were critical came from VIA; but these chipsets had also problems with newer SATA-HDDs.

Most expansion-cards should also work, but I´m not sure about the high-price class (because I don´t use it), some RAID-only-cards maybe not work (good) with optical devices.

Standard-controllers with Sil, ASmedia, Marvell, JMB will mostly work, but can have issues, maybe depending on FW. I Have a JMB363 which causes speed problems with ODDs, if I burn with 2 drives at same time I don´t reach 1x speed on em, but my other JMB363-cards works.

IDE/PATA was different, some controller-cards don´t support ATAPI-commands and don´t worked with optical devices.

My experiences in over 20 years with PC-Hardware:)


#9

I dont have any access to B150, as I said on H110 everything works.

I cant remember the last time that my PC had a VIA chipset. Once upon a time I had an AMD with an NVIDIA chipset and I dont recall having any problems.

hahahaha defective by design :bigsmile:

If anyone is planning on using a high end RAID card… well I am out of words, either he/she has to much money, or they got if for free, and in that case limitation would apply on a tool that was designed for a specific task. I will assume that if your card allows you to change the mode to IDE or ACHI then you might want to do that and hope that you want have any problems. I would prefer to use it as a RAID card.

I only had one PCI IDE card, and if i remember correctly it was the non raid version, worked perfect with my optical drives.

:thumbsup:


#10

I´m also was never a fan of Via, but in the early 2000 Via was 2nd behind Intel with chipsets. Most AMD-Boards used em and many Budget-Intel-Boards also. And because the 686A/B-southbridge from Via was cheaper than the AMD 756-southbridge many boards used a AMD 751-Northbridge with a Via 686-southbridge.

I´m not sure whether many ppl here remember this :wink:

Via SATA1-Ports simply don´t likes SATA2/3-devices, maybe someone remember some SATA2-HDDs had a jumper for SATA1-mode.

I don´t hope anyone buy a real Hardware-Raid-Controller for a 11€-DVD-writer, but I want to mention it :wink:

Some IDE/PATA-controllers simply don´t worked with ATAPI-commands, this don´t depend on RAID or Non-RAID, the controllers don´t understand these commands. But that was long time ago.

Personally I used in the last ten years Nvidia-chipsets and AMD/ATI since SB600, Intel Chipsets from H55 - B150 and I can say overall it works. Maybe some problems can exist with a combination Board X with Drive Y, but it should rare happen


#11

I dont remember that issue with SAT2 drives and CIA chipset, but I do remember that back then most SATA2 HDD’s had a jumper to select SATA1.


#12

The Via had many problems with the compatibility. I was glad to use mostly Nvidia-Chipsets with AMD

But PCI-cards with problematic Via SATA-Chip were to get everywhere cheap, it still exist

https://geizhals.de/inline-66697b-a1023868.html?hloc=at&hloc=de


#13

Hi,

FYI I have a MB with 2 Intel Sata 3, 4 Sata 2, and 2 Marvell Sata 3.
I am running all in IDE mode because my original setup had a few Win XP drives in addition to some Win 7 64 bit drives all of which I can turn on or off with the system powered down.

The Marvell controller is a 88SE9172

I discovered by accident that if you load the “Marvell Sata Driver” onto the drive while it is in IDE mode and try to boot, it will BSD every time until you remove all traces of the driver. The driver is only compatible with AHCI mode.

I do not know if this applies to other Marvell SATA 3 controllers, but I figured I should warn folks since the OP and some responders mentioned Marvell Sata controllers.

HTH