New Benq 1640 Firmware BSLB available

vbimport

#1

Link:

Firmware File: http://support.benq.com/files/storage/Firmware/DVDRW/DW1640/BSLB.zip

Download Centre: http://support.benq.com/front/BenqMain.asp?MenuHead=128&ShowType=program&FileURL=service/driverlist.asp&Dataid=18367&downloadclass=Driver&product=3731&langu=null&ops=2756&GenMenu=&RootId=undefined


#2

Nice… just in time when I’ll recieve the drive. =)


#3

Just flashed to BSLB from BSKB in an attempt to fix my read/write woes above ~14x. (They have returned).

Unfortunately it’s still the same.



#4

can you check if Mount rainier is now supported ?


#5

Are you using a 40-pin, 80-conductor ATA133 cable with your burners?

Regards,
TerminalVeloCD


#6

DVD-R over speeding bugs are fixed, Datawrite classic 8x DVD-R burned at 12x :clap:


#7

delta123, thanks for the heads up on this one. :slight_smile:

p5-, is it USB 2.0 and what does the burst rate test report?
Forget this I just read you other thread. Hmm, very strange :confused:

conrar22, I don’t think you will ever see Mt. Rainer in a 1640 :wink:

8T8, that’s good news, thanks :slight_smile:


#8

BLSB nows does justice to the drive
Thank you to all who follow-up and advise.

My burns were almost perfect on TY T02 and G02 but only fair on MCC 003 with BSKB
.
With this fw, here follow my 2 first burns on
MCC 003 in jewel case MIT
OS on
SB on
WOPC 1rst scan on in 7 mn 35
WOPC 2nd scan off in 5 mn 25

What can we expect more ? Maybe confirmation on DL burns.




#9

Nice :slight_smile: More discs to wreck. Thanx for the post.


#10

I have the same problem, it’s fixed if i remove the drive that’s connected on the same IDE cable. I originally had the Benq on the end of the cable, so i plugged it into the middle connector - which fixed the problem temporarily. It has retrurned and i will have to eventually remove my other drive to fix the problem (i don’t want to though :confused: )


#11

@ Sapa

Those scans of MCC03 discs are insane! Makes me want to get a 1640 now.


#12

PIF spikes above 3GB for DVD+R is still there. :frowning:

MCC004 @16x
OverSpeed Enabled
SolidBurn Activated/Activated
WOPC Enabled




#13

thanks for the info…time to flash (again)…


#14

zevia

I forgot about those “phantom” :wink: spikes at 16X
I shall make a test without WOPC to see if the poltergeist can be rid of, unless somebody already did.


#15

Yep, I had a thread I included a link to in my post above. In fact a new Aopen branded ata133 80 conductor flat cable arrived today. So far I’ve tried 2x ebuyer rounded, 1x msi rounded, and 2 x flat 80 conductor.

Yes! I just discovered this very same thing earlier. I unplugged my Liteon 52327s CDRW drive which is slave to the BenQ 1640, and the transfer rate graphs (also writing and any reading) are perfect like attached.

But as soon as I reconnect the Liteon back to slave it returns to before :frowning:



#16

The above link appears to be dead. I tried the Australian and American Benq sites to no avail. No BSLB.


#17

It is not; Try emptying your cache.


#18

that link still works here…


#19

Yes it does, just after I made my post I decided to have another go and guess what?


#20

OMFG !!! i have a liteon 52327s as slave too!!! had it as master, benq slave - same problem.

As for BSLB - i’m surprised Benq have released so soon, great stuff. Hopefully i can burn more 4x media with stock firmware :slight_smile:

edit: if the link doesn’t work for any1, try
http://dice.zapto.org/bslb.zip