New 3550A issue

vbimport

#1

I recently upgraded my system BIOS (Dell Dimension XPS), and since doing so, my 3550A has become VERY sluggish. It won’t rip faster than 2X, where as I was getting rips at 12X before the “upgrade.” I re-installed Liggy’s firmware, but that doesn’t seem to help. Any ideas?


#2

Enable DMA mode.


#3

Thanks. I’ll check on that this evening. I guess the firmware update changed my DMA setting.


#4

Yes, that usually happens because in practice the OS gets the info that a drive becomes removed and a new drive appears…


#5

I’m experiencing the same issues, my 3550A just became dog slow after firmware upgrades. BUT, when I go into the device manager, it says it’s already running at DMA Mode2. Is this display incorrect or something because I’ve read in all sorts of forums that the drive is slow because it’s not in DMA mode.

If the DMA Mode 2 that is displayed in the device manager is incorrect, how can I force it to DMA mode when it’s already displaying that it’s in DMA mode?


#6

My friend is experiencing similiar problems as well with his nec 3550A ever since he installed it. The user read buffer level would spike from like 16% to 86% non stop when burning. Burning at 16x takes 40 min!! I checked if he had dma on and it says it was off, so i turned it on, however, device manager stil says it current transfer mode is PIO mode. Any help please!!


#7

Actually i got the drive to get into DMA2 mode by uninstalling the device and reinstalling it, but when i restart the computer it goes back to PIO mode. :a im going nuts here


#8

so I think I figured out my problem…it turns out it didn’t have anything to do with the DMA settings, my settings turned out to be correct.

It looks like firmware version 1.06 for this drive has riplocking enabled to 2x, so that’s why my rip speeds were really slow. I just downgraded to firmware 1.04 and everything is very speedy again.

This brings me to another question, am I missing out on anything by downgrading from 1.06 to 1.04? Thanks!


#9

I have exactly the same problem with my 3550A, the fastest ripping I can do is around 2.4x with DVD Decrypter and Nero CD-DVD. It’s on DMA2 (always been, never had a problem with it going to PIO) and I’ve tried firmware 1.06 (came with it) ,1.04, Liggy’s and Maddog’s. The 3550 is set as slave on the Primary channel on the Intel ICH7R on my Asus P5LD2 Deluxe.
I have no idea what else to try. HELP! :slight_smile:


#10

Here’s the benchmark I ran with Nero CD-DVD on “V for Vendetta”.

Is 2x normal reading speed for the 3550?? I really hope I’m missing something.
Thanks for any ideas.
Andres


#11

Iv’e had pretty good luck with Dee’s 1.Y6 with RPC1 and I get pretty quick burns on my 3550. With speed enhancements I was over burning my 8x at 12x with great success. My DMA shows its off, but I believe that is a false reading since I stll get encoding and writing done in 16 to 22 min. for 1.45 to 2hr movies.


#12

Nope, no luck. I had already tried the 1.Y6 Original but I thought I’d give the RPC1 a try. I’m all out of options, so I’m ok with trying things that don’t make a lot of sense :).
The 3550 shares the cable with a storage hard drive (not the system drive). Could that have any effect on the performance? I’ve tried setting the 3550 to Master and Slave (neither are on cable select) but it’s the same thing, 3x on average. Any more ideas?


#13

Is the DL video disc original/pressed?


#14

Yes, it is.


#15

Is pressed the same thing as original?? Well, anyway, what I meant was that it is an original movie.

I just tried unplugging the hard drive thats sharing the IDE port with the 3550 and the results were the same. I also tried connecting it to another IDE controller available on the motherboard (asus P5LD2) and again the results were 3x on average.
Seems I don’t have any other hardware options to try, right? Maybe something on the software end then?

Just in case I’m eyeballing a BenQ 1640 on ebay… :wink:


#16

Dell computers like cable select. Have you thought about a new 80 wire cable, it’s possible you have 40 wire cables. One question is the 40 min. total time or just actual write time. Sometimes if you have to compress to much it will take longer to process.


#17

I used the Media Code Speed Edit program to speedpatch Dee’s 1.Y6 firmware. I did this even though Dee states that the 3550a is not riplocked – :confused: I thought I read that somewhere but cannot find it now. It may be just my imagination :rolleyes: , but it seems like my rips have speeded up. regards, gamma1


#18

Thanks for the tip gamma1, but unfortunately it didn’t do anything to my reading speeds… I’m officially out of ideas.


#19

You need to do what’s described on this page. http://www.michna.com/kb/WxDMA.htm.

Use regedit and delete your MasterIdDataChecksum and SlaveIdDataChecksum keys in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318} for the controller where your drive is connected, and change MasterDeviceTimingModeAllowed and SlaveDeviceTimingModeAllowed to ffffffff if they’re not… You then delete your drive from Device Manager and rescan (prevent a reboot). You may want to add some additional keys to desensitize Windows from dropping your drives into PIO mode (further down the page).

If you’re hesitant in using regedit, ask someone who’s proficient to help you.